Jump to content
Leon

Спецификация для SW по ГОСТ

Ваш опыт использования пакета макросов SWPlus  

600 members have voted

  1. 1. Вы используете макросы из пакета SWPlus?

    • Да, постоянно на основной работе.
      442
    • Да, но не на основной работе.
      85
    • Нет
      75
  2. 2. Каие макросы из пакета Вы используете?

    • SpecEditor - для создания спецификаций и ВП
      496
    • MProp - для заполнения свойств моделей
      477
    • DProp - для управления листами чертежа
      332
    • SProp - для заполнения свойств моделей из разделов Стандартные изделия, Прочие изделия и Материалы
      315
    • SaveDRW - для "правильного" сохранения чертежа
      138
    • SaveAsPDF - для сохранения чертежа в формате PDF
      207
    • Master - для создания шаблонов основных надписей
      293
  3. 3. Были ли у Вас проблемы с освоением (изучением) макросов?

    • Нет, мне все интуитивно понятно
      159
    • Да, но я разобрался с помощью форума и описания
      297
    • Да, я до сих пор не могу разобраться как с этим работать
      96
    • Я не стал разбираться, глянул и стер все нафиг
      7
    • Я не пользовался этими макросами
      43
  4. 4. Были ли у Вас проблемы (глюки) с установкой и настройкой макросов?

    • Нет, все установилось нормально
      138
    • Да, но они решились
      265
    • Да, и я до сих пор не могу заставить макросы работать, но хочу это сделать
      151
    • Да, поэтому я и не стал с ними связываться
      7
    • Я не пользовался этими макросами
      41
  5. 5. Устраивает ли Вас подход к автоматизации оформления КД, заложенный в данных макросах?

    • Да
      276
    • Да, хотя кое-что я бы изменил
      244
    • Нет
      23
    • Не знаю
      59


Recommended Posts

Leon

Для крепежа используйте SProp. Галочки Обозначение из параметров конфиг и Наименование из параметров конфиг. отключите.

Share this post


Link to post
Share on other sites


Redinskiy
В 06.02.2020 в 20:05, Leon сказал:

Я пока использую 2018, поэтому не проверял. Скажите, а 2019 сп.4 такого не было?

Приветствую!
Не тестировали на SW 2019? Очень сильно тормозит, создание спецификации более 20 мин висит комп(( 

Share this post


Link to post
Share on other sites
agel
20 часов назад, Leon сказал:

Для крепежа используйте SProp. Галочки Обозначение из параметров конфиг и Наименование из параметров конфиг. отключите.

Я правильно понимаю, что в Sprop нужно включить галку "Включить имя конфигурации"? Иначе наименование будет прописываться в свойствах файла не во вкладке "Конфигурация", а во вкладке "Настройка" и будет общим для всех конфигураций.

 

Тогда как быть, если имена конфигураций выглядят как М4х12, М5х16, а в наименовании нужно получить М4-6gх12, М5-6gх16? Переименовывать все конфигурации? 

2020-03-06_15-19-19.png

2020-03-06_15-24-37.png

Share this post


Link to post
Share on other sites
kenny

@agel советую конфигурации прописывать чуть подробнее. тогда будет корректно работать сортировка SpecEditor. в противном случае крепеж в спецификации будет объединяться, я такое уже проходил=)

вот мой пример  

5e6251ca2afd8_2020-03-0616_35_43-SOLIDWORKSProfessional2019SP3.0-DIN933(...png.da458e3da1b2782bf1fb11a635497dce.png

Hide  

 

так же контролируйте параметры крепежа через "таблицу параметров" и через свойства детали

например  

5e625258c9e36_2020-03-0616_38_11-.png.7452bd640dbe71e6b35e582948f7c153.png

 

5e625261e241b_2020-03-0616_38_14-.png.4f9399595847fad38b6b22b49bc06de6.png

эту табличку я начал создавать благодаря @Alex8007

5e6252ab4aac1_2020-03-0616_39_23-DIN933(..).SLDPRT-Excel.thumb.png.1c11316bd3a81016bd811bce37ff804f.png

Hide  
Edited by kenny

Share this post


Link to post
Share on other sites
agel

@kenny  Спасибо!

В 06.03.2020 в 16:40, kenny сказал:

в противном случае крепеж в спецификации будет объединяться, я такое уже проходил=)

Да, я тоже уже прошел. Там какой-то своеобразный алгоритм сортировки.

 

@kenny Вы не могли бы показать скрин окна Sprop со свойствами этих болтов? Вы ставите галку "Включить имя конфигурации"? Почему имя конфигурации не попадает в наименование, они отличаются. И еще интересно как выглядит запись этих болтов в спецификации? У вас там и DIN, и ГОСТ фигурируют.

 

Share this post


Link to post
Share on other sites
kenny

@agel я пользовался Sprop буквально пару раз, когда пытался разобраться как он работает. больше я им не пользуюсь. мне удобней когда все столбцы я могу контролировать.

графы "ГОСТ","Класс прочности", "Покрытие", "Материал", "Масса" являются справочными. некоторые я ввел для удобства использования или их ввел @Alex8007, потому как они используются в формулах в таблице параметров. поищите его базу крепежа, она крайне качественно сделана. я половину оттуда себе забрал и немного доработал.

Моя спецификация выглядит как-то так.  

ЛТ1111.000.000 Колобашка — копия.pdf

это моя тестовая модель. выглядит не идеально, но лучше пока не смог придумать

Hide  

Share this post


Link to post
Share on other sites
Maik812
14 минуты назад, kenny сказал:

поищите его базу крепежа

Где найти? дайте ссылку.

Share this post


Link to post
Share on other sites
jekson

Вот у меня проблема добавления макросов. Не получается установить. Солид 2016. Пробовал 2014, 2017 и 2018 версии

Помогите решить проблему!

Макрос.jpg

Макрос 2.png

Edited by jekson

Share this post


Link to post
Share on other sites
Leon

Надо указать метод. Который со словом "main".

Share this post


Link to post
Share on other sites
eest

Привет всем.
Кто может помочь с таким вопросом.
Перевожу макросы на чешский язык (нужно помочь чешским колегам) и столкнулся с проблемой что не могу использовать диакретические знаки это такие ř č ě ů и т.д., когда ввожу название с этими знаками и нажымаю Enter диакритика пропадает.
Но эсли изменять слова прямо в названии как на рисунку ниже, проблем нет, хотя в свойствах название без диакритики.
image.thumb.png.a4ee30d66ad5536d470046f3df0eb80b.png

 

Когда нужно изменить название например здесь, рисунок ниже, вообще никак нельзя написать как нужно с диакритикой.
image.thumb.png.6e54bb16c430a0a57b02bcdac1dd09c6.png

 

Буду рад за помощь.

Share this post


Link to post
Share on other sites
nik_pain

Добрый день, коллеги. подскажите может у кого есть шаблоны для ПС,ВС?

Share this post


Link to post
Share on other sites
AleksandrVal

Коллеги, привет!

Поделитесь пожалуйста PDFCreator 1.2.3. На sourceforge только исходники остались.

Share this post


Link to post
Share on other sites
Plumber
8 часов назад, AleksandrVal сказал:

PDFCreator 1.2.3

У меня только 1.2.1, если устроит - кричи

Share this post


Link to post
Share on other sites
un_wn

Здравствуйте.

Забил в часто используемые необходимые мне материалы. Добавил к ним новое свойство "MaterialID". Подскажите как можно к этому свойству обратится и записать его в свойства файла.

Например макрос имя материала в свойства файла записывает при помощи "SW-Material@@По умолчанию@$PRP:"SW-File Name".SLDPRT"

Спасибо.

Share this post


Link to post
Share on other sites
Kazuki

При добавлении второго листа выдаёт сообщение что не удалось найти основную надпись.
При запуске макроса DProp и SpecEditor выдаёт одинаковую ошибку см. картинку
Как это исправить?, всё работало без проблем. SW2018_5

Ошибка при испр чертежа и созд. спец..jpg

Share this post


Link to post
Share on other sites
Leon

В файле MyProperties_2.ini проверьте разделитель в размере шрифта, должна быть запятая

Share this post


Link to post
Share on other sites
Kazuki

Вроде есть, но не работает

GOST type A
3,5

Share this post


Link to post
Share on other sites
Leon

@Kazuki Попробуйте перекачать с сайта макросы. Видимо что-то у вас в файлах с настройками повредилось

Share this post


Link to post
Share on other sites
Viktor_F

Здравствуйте коллеги!

Пожалуйста помогите начать работу с макросами. Затык на втором пункте настройки - не отрабатывает Мастер - сваливается в настройку. Также со свойствами

Прилагаю скрины происходящего. На них видно что у меня SW2019. Пакет макросов называется SWPlusMacro_v_2018_SP0.0 (скачал не помню откуда). Хотя файл справки там называется SWPlus_v_2017_SP0.0

Мастер.JPG

Мастер-1.JPG

Мастер-2.JPG

Свойства.JPG

Share this post


Link to post
Share on other sites
Leon

Шаблоны по умолчанию в настройках солида прописаны?

Share this post


Link to post
Share on other sites
Kazuki
19 часов назад, Leon сказал:

@Kazuki Попробуйте перекачать с сайта макросы. Видимо что-то у вас в файлах с настройками повредилось

Всё перепробовал, SW переустановил заново, месторасположение файлов настроил. Макросы переустанавливал (скачивал), не работает.
На 3х машинах работает с теми же макросами и настройками.
 
В папке SpecEditor, открыл файл MyProperties_2.ini и удалил запятую и цифру 5 в строке 2 сверху (в размере шрифта), тогда всё работает, отлично.
Число* с запятой в размере шрифта, например как было 3,5 установить невозможно, работать макросы MProp DProp и SpecEditor не будут.
Работает с числом без запятых, только так.
Почему так произошло непонятно, причина не найдена.
GOST type A
3* (было 3,5)
1
0
9
11
2019
16
15
46


 

Share this post


Link to post
Share on other sites
vasyam

@KazukiМожет в настройках винды в Языке и региональных стандартах, разделитель дробной и целой части вместо запятой стоит точка

Edited by vasyam

Share this post


Link to post
Share on other sites
Kazuki

Спасибо, это возможно, админ гад что-то настраивал через эту машину, с тех пор и не работает. Попробую настроить.

Share this post


Link to post
Share on other sites
vasyam
8 минут назад, Kazuki сказал:

Спасибо, это возможно, админ гад что-то настраивал через эту машину, с тех пор и не работает. Попробую настроить.

И еще, скорее всего не ваш случай, но все же.  У меня SW2019 при запуске дополнения Visualize он подменял региональный стандарты т.е. в настройках винды была запятая, но в дополнении запущенном из под SW вместо разделителя ставилась точка. После отключения Visualize все становилось нормально.

Share this post


Link to post
Share on other sites
Kazuki
15 минут назад, vasyam сказал:

@KazukiМожет в настройках винды в Языке и региональных стандартах, разделитель дробной и целой части вместо запятой стоит точка

В настройках было всё правильно, разделитель дробной и целой части запятая, решил изменить на точку - не работает, вернул как было запятую и в настройках шрифта MyProperties_2.ini

установил 3,5 по умолчанию как и было, и всё заработало!  Почему слетели настройки непонятно. Спасибо. 

Share this post


Link to post
Share on other sites
Viktor_F
15 часов назад, Leon сказал:

Шаблоны по умолчанию в настройках солида прописаны?

Спасибо - помогло, макросы заработали.

Шаблоны по умолчанию были на несуществующих путях - старые настройки до работы с макросами. Назначил пути на папку Шаблоны макросов.

Еще раз Спасибо!

Share this post


Link to post
Share on other sites
Viktor_F

Заработали, но главная цель Спецификация не получается. Срабатывает, но не корректно.

Задаю создать на отдельном листе: второй лист создается и в дереве присутствует на нем спецификация, но это чистый лист А4 (не бланк спецификации). Таблица спецификация видна на первом листе (сборочном чертеже), при этом в дереве ее нет, но появляется скрытый вид модели.

Я что то не понимаю? Не так делаю? Или это глюк макроса? Или глюк SolidWorks?

Спец-1.JPG

Спец-2.JPG

Спец-3.JPG

Share this post


Link to post
Share on other sites
Leon

@Viktor_F В настройках солида есть галочка "Отображать диалоговое окно формата листа...". Надо ее снять.

Share this post


Link to post
Share on other sites
eest

как изменить толщину подчеркивания если кто знает? нужна тонкая линия.

 

image.thumb.png.5c70f767c525f83fcb0c14586bc829a2.png

image.thumb.png.483f100fce2cb639efd2a5ac125e7207.png

Share this post


Link to post
Share on other sites
Viktor_F
4 часа назад, Leon сказал:

В настройках солида есть галочка "Отображать диалоговое окно формата листа...". Надо ее снять.

Спасибо! Опять помогло.

Share this post


Link to post
Share on other sites
scratchj

Здравствуйте. Подскажите пожалуйста по такому вопросу. При попытке запустить макрос ТТ, для заполнения технических требований, выскакивает окно с ошибкой "Run -time error '5'  Invalid procedure call or argument" 
При нажатии кнопки Debug, в окне отладки Visual Basic в логе запуска желтым цветом выделено AppActivate MyAppId
Потерянных библиотек нет, шаблоны и месторасположения макросов прописаны. При этом без нареканий работают RecordDimM и SpecEditor. 
 
Макросы скачаны с этого сайта, Solidworks 2018, Windows 10. На рабочем компьютере с Win 7 все работает и ТТ в том числе. 

Share this post


Link to post
Share on other sites
Kelny
21 час назад, eest сказал:

как изменить толщину подчеркивания если кто знает? нужна тонкая линия.

Пробуйте настройки толщины линий, в зависимости от версии программы за толщины отвечают разные элементы.

s06891755.jpg

 

1 час назад, scratchj сказал:

выскакивает окно с ошибкой "Run -time error '5'  Invalid procedure call or argument" 

Возможно для запуска макроса используется не та процедура. Обычно стартовой является MAIN.

Share this post


Link to post
Share on other sites
scratchj

Не могу утверждать, вот скрин лога, после нажатия на debug, где в меню выбора процедуры указано - main:

2-error-sol.jpg

Edited by scratchj

Share this post


Link to post
Share on other sites
eest
1 час назад, Kelny сказал:

Пробуйте настройки толщины линий, в зависимости от версии программы за толщины отвечают разные элементы.

s06891755.jpg

 

Возможно для запуска макроса используется не та процедура. Обычно стартовой является MAIN.

спасибо но к сожалению не работает. я думаю что дело в шрифте...

Share this post


Link to post
Share on other sites
Kelny
12 часов назад, scratchj сказал:

Не могу утверждать, вот скрин лога, после нажатия на debug, где в меню выбора процедуры указано - main:

В папке с макросом должен лежать файл с тем же именем что запускаемый файл макроса, но расширением EXE.

Попробуйте запустить файл EXE без макроса.

 

Скорее всего у вас отключено отображение расширений в виндовс (всех или зарегистрированных типов файлов), перейдите в настройки папки эксплорера виндовс (или через панель инструментов виндовс) и установите/снимите галочки что бы расширения файлов не скрывались (всегда отображалось).

11 часов назад, eest сказал:

спасибо но к сожалению не работает. я думаю что дело в шрифте...

Попробуйте сделать все типы линии одинаково тонкими.

 

Подчёркивание в заметке скорее всего от шрифта, а вот в стеке со шрифтом связано быть не должно.

Edited by Kelny

Share this post


Link to post
Share on other sites
scratchj
6 часов назад, Kelny сказал:

В папке с макросом должен лежать файл с тем же именем что запускаемый файл макроса, но расширением EXE.

Попробуйте запустить файл EXE без макроса.

 

Скорее всего у вас отключено отображение расширений в виндовс (всех или зарегистрированных типов файлов), перейдите в настройки папки эксплорера виндовс (или через панель инструментов виндовс) и установите/снимите галочки что бы расширения файлов не скрывались (всегда отображалось).

 

Спасибо, но к сожалению проблема не в этом. В свойствах проводника включено отображение расширения файлов и файл TT.exe так же находится в папке макроса вместе с TT.swp 

Share this post


Link to post
Share on other sites
Leon
В 10.04.2020 в 14:01, scratchj сказал:

Не могу утверждать, вот скрин лога

Закомментрируйте эту строку,т.е. поставьте в начале апостроф, так чтобы строка стала зеленой

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Сообщения

    • MotorManiac
      ошибки в координатах доменов быть не может ?
    • sloter
      Используйте драг-энд-дроп перетаскивание с Alt-ом. Там есть смена направления.
    • an_rushin
      пробовал. к сожалению, никаких изменений  
    • sloter
      Да, проверил. Для деталей и для сборок цвета сохраняются. Но, для маленьких тестовых... Проблема в том, что мою рабочую сборку (она то же не большая) 2017 sp3 в принципе не хочет сохранять\публиковать в  eDrawings - падает...???
    • MotorManiac
      Попробуйте уменьшить временной шаг. Я как понимаю раз sliding mesh, то речь идет о нестационарной задаче.
    • obratnov
      У меня англ. версия, русской никогда не видел, поэтому извините, если за возможные неточности. Итак, при быстром создании сопряжениий из выплывающего тулбара, детали часто оказываются ориентированы в направлении, противоположном желаемому. Приходится либо идти в свойства сопряжения и менять там, либо создавать через большой тулбар, который сразу открывает эти свойства. Это не так удобно. Нельзя ли как-то сразу подсказать софту, как я хочу ориентировать детали? Порядок выделения деталей на это не влияет.
    • an_rushin
      здравствуйте. пытаюсь симулировать вращение тормозного диска относительно тормозных колодок в постановке sliding mesh и получают такое сообщение:   WARNING: The solid velocity has a significant normal component on 556 faces of face zone 37.          The maximum angle between the velocity and face surface is 89.5 deg at ( 3.909e-03, -3.790e-02,  5.144e-02).          The solver may not achieve global energy conservation as a result.          The tolerance for this check (currently 20.0 deg) is controlled by the rpvar 'wall/vnormal-tolerance'.          Please check your setup. This warning will not be written again.   не откажите в любезности, подскажите, как можно это вылечить? спасибо.  
    • Zergus
      SolidWorks может напрямую Siemens NX с PMI открывать, а для STEP`а таких настроек в нем не видно.  
    • Zergus
      В ролике показана кастомизация NX, т.е. либо итальянцы сами написали себе такое приложение (что наиболее вероятно), либо им сименс по заказу написал. Трясите своих представителей сименс, может они добудут это приложение. А штатный функционал этот Вам нужен. Но это не точно 
    • imt
×
×
  • Create New...