Jump to content

Спецификация для SW по ГОСТ


Ваш опыт использования пакета макросов SWPlus  

609 members have voted

  1. 1. Вы используете макросы из пакета SWPlus?

    • Да, постоянно на основной работе.
      450
    • Да, но не на основной работе.
      86
    • Нет
      75
  2. 2. Каие макросы из пакета Вы используете?

    • SpecEditor - для создания спецификаций и ВП
      504
    • MProp - для заполнения свойств моделей
      485
    • DProp - для управления листами чертежа
      337
    • SProp - для заполнения свойств моделей из разделов Стандартные изделия, Прочие изделия и Материалы
      320
    • SaveDRW - для "правильного" сохранения чертежа
      140
    • SaveAsPDF - для сохранения чертежа в формате PDF
      211
    • Master - для создания шаблонов основных надписей
      294
  3. 3. Были ли у Вас проблемы с освоением (изучением) макросов?

    • Нет, мне все интуитивно понятно
      161
    • Да, но я разобрался с помощью форума и описания
      303
    • Да, я до сих пор не могу разобраться как с этим работать
      97
    • Я не стал разбираться, глянул и стер все нафиг
      7
    • Я не пользовался этими макросами
      43
  4. 4. Были ли у Вас проблемы (глюки) с установкой и настройкой макросов?

    • Нет, все установилось нормально
      140
    • Да, но они решились
      272
    • Да, и я до сих пор не могу заставить макросы работать, но хочу это сделать
      151
    • Да, поэтому я и не стал с ними связываться
      7
    • Я не пользовался этими макросами
      41
  5. 5. Устраивает ли Вас подход к автоматизации оформления КД, заложенный в данных макросах?

    • Да
      279
    • Да, хотя кое-что я бы изменил
      250
    • Нет
      23
    • Не знаю
      59


Recommended Posts

  • SHARit locked this topic
  • SHARit unlocked this topic
  • 1 year later...


UnPinned posts
6 минут назад, Snake 60 сказал:

Так зачем вы отдельно перенос копируете?

На случай, если св-ва уже заполнены и нужно вставить только перенос.

  • Нравится 2
Link to post
Share on other sites
Только что, malvi.dp сказал:

На случай, если св-ва уже заполнены и нужно вставить только перенос.

Ну если так, то да, согласен

Link to post
Share on other sites
6 часов назад, malvi.dp сказал:

Чтоб работало в MProp, нужно поправить файлик MProp_Firm.txt в папке с макросом, и все будет работать.

О, вот это то, что и хотелось. Только нужно не забывать, что в этом файле должно быть чётное количество строк. Ну и саму заметку в шаблоне нужно по высоте поправить в любом случае, иначе съедет.

И ещё вопрос, не знаю, задавал ли его уже:
Если в модели выставить свойства через MProp "Материал", поставить галочки, обозначить вручную, например

Труба квадратная 25х25х2,5

ГОСТ .....

L=1500 мм

применить, сохранить, а потом зайти в MProp снова, то всё выставляется по умолчанию, хотя в спецификации (читай, в свойствах) остается, как надо, если повторно не нажать "применить". Не очень удобно каждый раз переписывать всё, если вдруг что поменялось. Можно ли с этим что-то сделать, или это я не так что-то делаю?

Link to post
Share on other sites
Petrovich73
6 часов назад, malvi.dp сказал:

Чтоб работало в MProp, нужно поправить файлик MProp_Firm.txt в папке с макросом, и все будет работать.

 

У меня не работает, только первая строка отображается. Через свойства всё работает хорошо, но текст сдвинут вниз.

Edited by Petrovich73
Link to post
Share on other sites
15 часов назад, malvi.dp сказал:

На случай, если св-ва уже заполнены и нужно вставить только перенос

Там, где нужен перенос, поставить курсор и нажать комбинацию клавиш - левый Alt+0010

Неудобно, что в свойствах видимая только 1 строка. Можно для просмотра сделать шаблон в Property Tab Builder, тогда на панели свойств будет отображаться весь многострочный текст

Скрытый текст

Окно многострочных свойств.JPG

 

  • Нравится 4
  • Чемпион 1
Link to post
Share on other sites
27.11.2020 в 14:00, none сказал:

вставляет еще пустую строку между словами, если копировать через crtl-a.

Потому что в файле две строки, во второй находится признак конца файла, который по CTRL+A тоже копируется.

Для того чтобы это увидеть лучше пользоваться более продвинутыми редакторами типа AkelPad, Notepad++, etc.

Edited by Plumber
Link to post
Share on other sites
28.11.2020 в 10:02, Kir95 сказал:

Неудобно, что в свойствах видимая только 1 строка.

Да, но стрелками курсора строки в текстовом окне можно менять, точно так же как пробегаясь по символам слева-направо и наоборот.

Link to post
Share on other sites
28.11.2020 в 09:02, Kir95 сказал:

левый Alt+0010

Можно использовать так же стандартные хоткеи типа Shift+ENTER, Ctrl+ENTER. Последний при использовании в Word переносит на другую страницу

Link to post
Share on other sites
31 минуту назад, Plumber сказал:

Можно использовать так же стандартные хоткеи типа Shift+ENTER, Ctrl+ENTER. Последний при использовании в Word переносит на другую страницу

Не работает в самой строке свойств

Link to post
Share on other sites
27.11.2020 в 22:14, eljer0n сказал:

И ещё вопрос, не знаю, задавал ли его уже:
Если в модели выставить свойства через MProp "Материал", поставить галочки, обозначить вручную, например


Труба квадратная 25х25х2,5

ГОСТ .....

L=1500 мм

применить, сохранить, а потом зайти в MProp снова, то всё выставляется по умолчанию, хотя в спецификации (читай, в свойствах) остается, как надо, если повторно не нажать "применить". Не очень удобно каждый раз переписывать всё, если вдруг что поменялось. Можно ли с этим что-то сделать, или это я не так что-то делаю?

Попробуйте использовать GeOS. Где-то здесь на сайте поищите.

Link to post
Share on other sites
26.11.2020 в 14:32, Vasiliy85 сказал:

Это надо внутрь макроса залезать, там строчка прописано

Спасибо! Можете подсказать какая именно строчка отвечает за размер шрифта этой надписи? А макрос Mprop?

Link to post
Share on other sites
  • 2 weeks later...

Привет всем, подскажите в чем может быть проблема - перестала вставляться масса в чертёж. В 3D масса вычисляется, в свойствах конфигурации "масса_ФБ" тоже стоит как надо и вычисляется правильно, но в чертеже вставляется масса равная 0, запускаю MPROP и в нём в разделе массы ничего нельзя изменить - стоит 0 и все строчки неактивны. 

Link to post
Share on other sites

Нашёл в чём причина - не в макросе. В этих деталях были потеряны несколько привязок в эскизах, но 3D строилась и отображалась нормально. 

В 20 солиде что ли новая логика - с такими ошибками не считает массу нормально и возле детали в дереве висит светофор. Как только исправил эскизы, то масса стала считаться и в чертёж передаваться.

Link to post
Share on other sites
10 минут назад, anser89 сказал:

с такими ошибками не считает массу нормально и возле детали в дереве висит светофор

Так это кажись всегда так было - нерешенные компоненты не считались

Link to post
Share on other sites
15 часов назад, Plumber сказал:

Так это кажись всегда так было - нерешенные компоненты не считались

Ну хз, на 18 версии не замечал такого, на 20 перешел недавно

Link to post
Share on other sites
57 минут назад, Сергей 2020 сказал:

При создании ВП не пишет наименование детали и обозначение. в чём может быть причина

Название св-в в детали должны соответствовать, тем что используются в ВП и должны быть заполнены.

Link to post
Share on other sites
Сергей 2020
1 час назад, malvi.dp сказал:

Название св-в в детали должны соответствовать, тем что используются в ВП и должны быть заполнены.

Так а метизы он разве сам не берёт? или что-то указывать надо?

 

Link to post
Share on other sites
1 час назад, Сергей 2020 сказал:

Так а метизы он разве сам не берёт? или что-то указывать надо?

Смотря откуда вы их применяете. Если из тулбокса - скорее всего Обозначение и Наименование там пустые.

Я пользуюсь своими (у меня все св-ва предварительно заполнены в детали).

Чтобы проверить - откройте метиз и посмотрите, какие св-ва там заполнены и заполнены ли вообще.

Если св-в нужных нет - их нужно создать и заполнить.

Link to post
Share on other sites

Здравствуйте. Первый раз задаю вопрос. Пользуюсь макросами от LEON давно. Но почему то на SW 2019 лицензионный не могу установить. Выдает ошибку и завершает работу. В чем причина может кто знает. На предыдущих версиях все было отлично.

Link to post
Share on other sites
42 минуты назад, Borisvlad сказал:

Здравствуйте. Первый раз задаю вопрос. Пользуюсь макросами от LEON давно. Но почему то на SW 2019 лицензионный не могу установить. Выдает ошибку и завершает работу. В чем причина может кто знает. На предыдущих версиях все было отлично.

Ну так напиши что за ошибка, тут вроде экстрасенсов нет. я на 2020 лицензионный перешел и ошибок не было пока.

Link to post
Share on other sites

Нажимаю создать макрос указываю файл ( MProp.swp.) или другой из SWPlus  -- не возможно открыть C:\SW\UserSoft\Leon\SWPlusMacro_v_2018_SP0.0\MProp.  И это на двух компьютерах  с SW 2019  лицензионных

Link to post
Share on other sites

@Borisvlad

Пробуйте изменить путь к маросу, сделать его короче (например D:\SWPlus\MProp). Проверьте права доступа к папкам и файлам макроса. Диск С для этого - не лучший вариант.

Link to post
Share on other sites
50 минут назад, Solidman сказал:

Пробуйте изменить путь к маросу, сделать его короче (например D:\SWPlus\MProp).

Нет, это не влияет.

 

50 минут назад, Solidman сказал:

Диск С для этого - не лучший вариант.

То же не влияет.

 

51 минуту назад, Solidman сказал:

Проверьте права доступа к папкам и файлам макроса.

А вот это да, проверьте.

Link to post
Share on other sites
3 минуты назад, Borisvlad сказал:

Нажимаю создать макрос указываю файл ( MProp.swp.) или другой из SWPlus  -- не возможно открыть C:\SW\UserSoft\Leon\SWPlusMacro_v_2018_SP0.0\MProp.  И это на двух компьютерах  с SW 2019  лицензионных

 

1 час назад, anser89 сказал:

Ну так напиши что за ошибка, тут вроде экстрасенсов нет. я на 2020 лицензионный перешел и ошибок не было пока.

 

39 минут назад, Solidman сказал:

@Borisvlad

Пробуйте изменить путь к маросу, сделать его короче (например D:\SWPlus\MProp). Проверьте права доступа к папкам и файлам макроса. Диск С для этого - не лучший вариант.

 

Link to post
Share on other sites
20 минут назад, Sergei сказал:

Нет, это не влияет.

 

То же не влияет.

 

А вот это да, проверьте.

 

21 минуту назад, Sergei сказал:

Нет, это не влияет.

 

То же не влияет.

 

А вот это да, проверьте.

Сделал путь короче, переместил в диск D, проверил доступ. Не помогло. Не возможно открыть файл!!!

Link to post
Share on other sites
6 минут назад, Borisvlad сказал:

Сделал путь короче, переместил в диск D, проверил доступ. Не помогло. Не возможно открыть файл!!!

Там у Вас наверняка стоят права пользователя и пароли. Зайдите под администратором и повторите.

Link to post
Share on other sites
2 минуты назад, Sergei сказал:

Там у Вас наверняка стоят права пользователя и пароли. Зайдите под администратором и повторите.

 

8 минут назад, Sergei сказал:

Там у Вас наверняка стоят права пользователя и пароли. Зайдите под администратором и повторите.

Попробую завтра. Спасибо!!!

Link to post
Share on other sites

Проверил. Не получается. Или что-то не понимаю. Последовательность установки макроса, зашел в  СОЛИД , открыл чертеж или деталь, создать макрос, нахожу файл макроса жму , НЕ ВОЗМОЖНО ОТКРЫТЬ. 

ГДЕ стоят права пользователя и пароли И КАК  и КУДА зайти под админом?

Link to post
Share on other sites
1 час назад, Borisvlad сказал:

Проверил. Не получается. Или что-то не понимаю. Последовательность установки макроса, зашел в  СОЛИД , открыл чертеж или деталь, создать макрос, нахожу файл макроса жму , НЕ ВОЗМОЖНО ОТКРЫТЬ. 

ГДЕ стоят права пользователя и пароли И КАК  и КУДА зайти под админом?

Вспомнил - была такая проблема на win8 у коллеги. Что-то связано с обновлением винды. Завтра с работы отпишусь.

Link to post
Share on other sites
VadosBandos

Приветствую всех участников этой темы. Оговорюсь сразу, что использую спецификацию от компании iTools, которая вроде как работает на стандартной солидовской. Использовать какую-либо другую на данный момент нет возможности. 

Возможно ли каким-то макаром подцепить свойства чертежа в свойства модели.  Знаю, что чертёж второстепенен, но вдруг кому-то каким-то чудесным образом удалось это сделать) 

Теперь поясню, что хочу сделать: автозаполнение формата чертежа в спецификации. Каждый раз подгадывать какого формата будет чертёж при создании модели не всегда получается, а изменять впоследствии иногда забываю... 

Link to post
Share on other sites

@Leonа можете подсказать по основной надписи, как сделать чтобы она была серая на форматке, а при входе в её редактирование, она становится черная?

P.S. Возможно это элементарный вопрос, но я с SW не настолько хорошо знаком, а этот вопрос не дает покоя мне)))

5 часов назад, VadosBandos сказал:

Приветствую всех участников этой темы. Оговорюсь сразу, что использую спецификацию от компании iTools, которая вроде как работает на стандартной солидовской. Использовать какую-либо другую на данный момент нет возможности. 

Возможно ли каким-то макаром подцепить свойства чертежа в свойства модели.  Знаю, что чертёж второстепенен, но вдруг кому-то каким-то чудесным образом удалось это сделать) 

Теперь поясню, что хочу сделать: автозаполнение формата чертежа в спецификации. Каждый раз подгадывать какого формата будет чертёж при создании модели не всегда получается, а изменять впоследствии иногда забываю... 

Если я правильно Вас понял:

В макросах от Леонида, когда вы создаёте чертеж на деталь и с помощью макроса Мпроп вносите свойства, он прописывает форматку чертежа, который вы на него создали. В дальнейшем, создавая спецификацию его же макросом, он берет из свой деталей формат чертежа и прописывает в спецификацию его автоматически.

 

Если Вы используете сторонний софт от айтулса - тут вопрос как он работает, может ли он поддятигивать свойства с файла (если да, то какое свойство и откуда - вопрос к разработчикам) или нужно руками прописывать.

P.S. На ранних стадия тестировал их софт, у меня вообще в стоке не заработало. Обращение о проблеме отправил им. Решения не предложили... в итоге перешел на платные макросы от Леонида и никаких проблем больше не испытывал. Все четко, аккуратно. И техподдержка на уровне у них.

  • Нравится 3
Link to post
Share on other sites

Подскажите, касательно SaveDRW - возможно ли поправить макрос, что бы "Код документа" макрос брал не из модели, а из чертежа? Допустим, модель имеет обозначение МДЛ.000, а документы у меня к нему идут СБ, ГЧ, ТУ и т.д... Сейчас при сохранении через макрос постоянно приходится вручную удалять МС и МД =/

И второй момент по нему же - добавить пробел между шифром модели и кодом документа (МДЛ.000 СБ).

Link to post
Share on other sites
11 часов назад, OptiMystik сказал:

Подскажите, касательно SaveDRW - возможно ли поправить макрос, что бы "Код документа" макрос брал не из модели, а из чертежа? Допустим, модель имеет обозначение МДЛ.000, а документы у меня к нему идут СБ, ГЧ, ТУ и т.д... Сейчас при сохранении через макрос постоянно приходится вручную удалять МС и МД =/

И второй момент по нему же - добавить пробел между шифром модели и кодом документа (МДЛ.000 СБ).

МС - модель сборки

МД - модель детали

В макросе правишь код, и вместо МС и МД можешь поставить СБ (ну или в зависомости от назначение, можно написать любое значение, если это как пример на лазерную резку, меняем на "(контур резки)" и получаем МДЛ.000 (контур резки) ).

Пробел я думаю там можно просто поставить в коде либо после значение из которого берется обозначение или еще куда проще, в том значении на которое заменяешь (см. текс выше), просто перед сокращением (или что там будет у Вас) поставь пробел и всё.

Link to post
Share on other sites
18.12.2020 в 14:55, iDim25 сказал:

а можете подсказать по основной надписи, как сделать чтобы она была серая на форматке, а при входе в её редактирование, она становится черная?

Не очень понял вопрос... У меня вроде так и есть в моих форматках. Если вы хотите чтобы она всегда была черная, то надо отключить галочку "по умолчанию" в настройках цвета линий.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Сообщения

    • Viktor2004
      Да, станок 2011 года. Работает практически круглосуточно. Операторы меняются прямо на рабочей программе. Деньги. Деньги. Деньги. Даже не убирают станок. Однажды вызвали по причине того что смена паллет не идет. Оказалось ось Z не может физически доехать до точки смены, так как под кожухами набилась куча стружки. Когда вскрыли, обнаружили что на оси Z из танкеток давно вылетели все ролики и она просто елозит по направляющей стачивая ее. Без роликов провалилась миллиметра на 2, но это их не смутило. Перепривязались и дальше работают. Вызывают только тогда, когда ошибка какая-то не дает работать. В этот раз я в ладдере увидел что сигнал с гидрораспределителя снимается, а датчик давления не срабатывает. Реле они до моего приезда местами меняли с КР17. Я поменял местами два аналогичных гидрораспределителя. Ошибка осталась там же. Поменял два датчика давления, ошибка там же. И только тогда заметил что во время ошибки на реле светодиод не горит, а на гидрораспределителе горит.
    • Дезигнер
    • Гранник
      Не знаю, правда или нет.. Мне сказали, что Турте домик построили за вклад в науку. Вроде бы, на море, кажется, в Гелен.. не, дальше не помню((
    • ДОБРЯК
      @Jesse для информации. При генерации объема не всегда сразу удается сгенерировать тетраэдры по первоначальной поверхностной сетке. Если этого не происходит, то каждая программа импровизирует по своему. А при генерации узлов на ребрах нужно склеивать узлы. А чтобы это было быстро для большого количества узлов нужно применить быстрое геометрическое хеширование.
    • lexx174
      поищите в гугле installation_guide - там будет все по пунктам
    • ChePpolino
      Не сочтите за рекламу. Правила форума пока не позволяют мне картинки вставлять. Вот такую пластину хочу попробовать закрепить снизу на упор лапки потайным винтом. Готов принимать критику.  
    • kfmut
      @Viktor2004 м.б. там на нагрузке какие-нить переходные процессы, закисло, большой ток, я х.з. в гидрораспределителях  Может и предисторию стоит уточнить, типа станок год стоял и вот.
    • Molodets
      Добрый день. Помогите разобраться с постом для ncstudio. Установил на станок подменную поворотную осьY вдоль Х. Настроил чтоб она работала на градусы. Сейчас мучаюсь с постпроцессором для SOLIDCAM. Моя цель обработка круглой заготовки и сверление вдоль оси Х. Может кто-то сталкивался с этим. Корпус для фильтра.SLDPRT
    • ДОБРЯК
      Нравится модель. Но начинать лучше с более простых моделей. Взять диск вырезать 1/4 и попытаться смоделировать циклическую симметрию для оболочек. Какие нужно записать уравнения для этой задачи?    Надо забыть про условия симметрии. И начать с того что на бумажке записать уравнения циклической симметрии. Это реперная точка... Любые линейные уравнения можно записать... Для всех степеней свободы.  Поэтому мне и странно слышать, что для перемещений СВ записывает уравнения а для углов поворота не может...
    • Jesse
      Мистер Админ, перенесите, пожалуйста, тему в соотв-й раздел https://cccp3d.ru/forum/88-solidworks-simulationcosmosworks/ Мб люди чтоб не плодить тему про сетки в SW будут спрашивать в этой теме.. Можно с закрепом..)
×
×
  • Create New...