Jump to content

Замедленная, слишком мягкая, инертная работа SW


marokko1986

Recommended Posts

marokko1986

Всем привет!

 

На домашнем компе SW ведет себя как-то нестабильно. Время от времени начинает работать очень мягко, с запозданием типа "желеобразно" что-ли, инертно. То есть, реакция на движения мыши происходит с задержкой. При этом плавность и частота кадров высокая. Происходить это может как и на одной детали, так и на больших сборках и чертежах. При этом, в одно и то же время, большая сборка может крутиться и двигаться молниеносно, а деталь, открытая в другом окне - вот так вот замедленно. 

 

На другом компе, на работе такого не замечал.

 

Конфиг дом. компа :

i7 10700

Quadro p620

32 Gb RAM

SSD

 

На рабочем:

i9 9900

Quadro RTX4000

32 Gb RAM

SSD

 

Конфиги SW и там и там - одинаковые.

 

 

Link to post
Share on other sites


UnPinned posts
Kelny
2 часа назад, marokko1986 сказал:

Конфиги SW и там и там - одинаковые.

Проверить галочку Использовать программынй OpenGL - не должно стоять:

http://help.solidworks.com/2010/russian/solidworks/sldworks/legacyhelp/sldworks/errormsgs/graphics_adapters_and_drivers.htm

 

Так для решения проблем возможно стоит изучить SolidworksRX и попробовать варианты решения предложенной утилитой:

http://help.solidworks.com/2010/russian/solidworks/whatsnew/allcontent/solidworks/noncore/swrx/wn_2010/c_solidworks_rx.html

 

Если речь о ноутбуке, то возможно имеется две ведиокарты и для программы используется не та видеокарта. В некоторых случаях требуется отключить или удалить строенную карту, возможно с последующем восстановлением после запуска программы, или каким-то иным образом поменять приоритеты для запуска программы на нужной видеокарте.

Link to post
Share on other sites

Попробуйте:

  • сменить мышь
  • выйти из всех "лишних" программ - (steam, uplay, всякое что сидит в system tray)
Link to post
Share on other sites
Krusnik
01.02.2021 в 02:52, marokko1986 сказал:

Всем привет!

 

На домашнем компе SW ведет себя как-то нестабильно.

 

01.02.2021 в 02:52, marokko1986 сказал:

Время от времени 

Сколько в минутах? Каждые 10? Каждые 20?

Очень напоминает резервное сохранение.

Как только начинается бекап - все подтормаживает.

01.02.2021 в 02:52, marokko1986 сказал:

реакция на движения мыши

 На какие движения? Вращение вида? Клики на кнопки? Может простановка размеров? Или ещё что-то?

01.02.2021 в 02:52, marokko1986 сказал:

большая сборка может крутиться и двигаться молниеносно

Режим большой сборки включен?

01.02.2021 в 02:52, marokko1986 сказал:

а деталь, открытая в другом окне - вот так вот замедленно. 

Установлен ли патч с этой страницы? Да и вообще драйвер видеокарты?

Стоит ли галочка "использовать программу OpenGL" в настройках? (не должна)

В Win 10 можно смотреть производительность видеокарты. Посмотрите как она работает при вот таком замедленном вращении.

 

Link to post
Share on other sites
marokko1986
6 минут назад, Krusnik сказал:

Сколько в минутах? Каждые 10? Каждые 20?

Примерно минут 5 периодичность. Но это бывает-по разному, определенной закономерности нет.

 

7 минут назад, Krusnik сказал:

 На какие движения? Вращение вида? Клики на кнопки? Может простановка размеров? Или ещё что-то?

Любые действия в чертеже. Вращение модели, перемещение модели. Перемещение деталей в сборке. В общем, любые маниуляции.

 

8 минут назад, Krusnik сказал:

Режим большой сборки включен?

Нет. Все отображено по максимуму. В этом то и странность, что деталь может вот так вот "плавать", а сборка летать. И наоборот.

 

10 минут назад, Krusnik сказал:

Установлен ли патч с этой страницы? Да и вообще драйвер видеокарты?

Стоит ли галочка "использовать программу OpenGL" в настройках? (не должна)

В Win 10 можно смотреть производительность видеокарты. Посмотрите как она работает при вот таком замедленном вращении.

Патч никакой не ставил. Драйвера стоят свежие, такие же, как и на другом компе. Галочка OpenGL НЕ стоит.

Link to post
Share on other sites
Kelny
1 час назад, marokko1986 сказал:

Драйвера стоят свежие, такие же, как и на другом компе.

Попробуйте более старые и/или те что шли к видеокарте.

В плане драйверов самое последнее это не всегда самое стабильное. Для конкретной железяки более стабильными могут оказаться не самые последние драйверы или вовсе поставляемые с самой железякой.

 

Попробуйте отключить/заменить Антивирус.

 

 

Link to post
Share on other sites
Krusnik
2 часа назад, marokko1986 сказал:

Примерно минут 5 периодичность. Но это бывает-по разному, определенной закономерности нет.

 

Любые действия в чертеже. Вращение модели, перемещение модели. Перемещение деталей в сборке. В общем, любые маниуляции.

 

Нет. Все отображено по максимуму. В этом то и странность, что деталь может вот так вот "плавать", а сборка летать. И наоборот.

 

Патч никакой не ставил. Драйвера стоят свежие, такие же, как и на другом компе. Галочка OpenGL НЕ стоит.

Ставьте патч, и отключайте автосохранение. И да, присоединяюсь к @Kelny  - проверьте антивирус.

 

Чёткая периодичность говорит об автосохранении. Оно по умолчанию каждые 10 минут. В зависимости от того, что вы делаете он каждый раз сохраняет то чуть подольше, то побыстрее. Поэтому периодичность не совсем строгая но примерно 5 минут. Плюс каждый раз эти вновь сохранённые файлы может проверять антивирус, что не добавляет производительности.

 

В SW 2019 разработчики натупили с графической системой и без патча видеокарта бесполезна. Хоть теслу ставьте - работать не будет, всё ляжет на процессор. Отсюда и ватность.  Причём в движениях объектов по экрану. Кнопочки там, команды нажимаются и работают прекрасно. По поводу сборки нужно смотреть настройки. В конфиге по умолчанию стоит настройка "Оптимизировать качество изображения." Она "понижает уровень параметров качества изображения для ускорения производительности" (С). А в детали такого нет и процессор "захлебывается".

 

Edited by Krusnik
Link to post
Share on other sites
marokko1986

@Krusnik

Периодичность как раз нечеткая.

 

Автосохранение всю жизнь у меня выключено. Антивирусников тоже нет, стандартный Windows-овский - заглушен по максимуму. Патч установил, долго не работал, надо понаблюдать подольше, но каких-то изменений изменений в работе SW не заметил.

Link to post
Share on other sites
Krusnik
16 минут назад, marokko1986 сказал:

@Krusnik

Периодичность как раз нечеткая.

 

03.02.2021 в 04:34, marokko1986 сказал:

Примерно минут 5 периодичность.

"Примерно 5 минут" - это довольно чётко. Но пофиг.

 

18 минут назад, marokko1986 сказал:

каких-то изменений изменений в работе SW не заметил.

Монитор ресурсов смотрели? Загруженность видеокарты есть при вращении, зуме и т.п.?

 

Этот патч открывает галочку в настройках.

settings.jpg

 

Открываем в SW деталь и смотрим в мониторе ресурсов как загружена видеокарта.

WO_support.jpg

Видеокарта судя по графику загружена на 20%.

 

А вот картинка с патчем и включенной галочкой.

W_support.jpg

Уже 45%.

SW переложил решение графических вычислений с процессора на видеокарту.

Link to post
Share on other sites
marokko1986

@KrusnikВозможность включения этой галочки была и до установки патча. Со включенной галочкой почему-то не работает антиалиасинг в SW - после установки патча ничего не изменилось.

Link to post
Share on other sites
Krusnik
28 минут назад, marokko1986 сказал:

@KrusnikВозможность включения этой галочки была и до установки патча. Со включенной галочкой почему-то не работает антиалиасинг в SW - после установки патча ничего не изменилось.

Похоже видеокарта :hang2:

Если процессор действительно i7 10700 (без F) - то вытащите квадру и попробуйте на встройке.

Скорее всего тоже ничего не поменяется.

Link to post
Share on other sites
marokko1986

@Krusnik Процессор как раз с F. Такая ситуация у меня на обоих компах. Обоим квадрам нет и полугода. Вряд ли с ними обеими что-то не так. У меня есть сомнения по поводу патча - я его установил в папку, которую он предлагал по умолчанию, это правильно? Или надо было устанавливать его в определенную папку Солида?

Link to post
Share on other sites
Krusnik
17 минут назад, marokko1986 сказал:

@Krusnik Процессор как раз с F. Такая ситуация у меня на обоих компах. Обоим квадрам нет и полугода. Вряд ли с ними обеими что-то не так. У меня есть сомнения по поводу патча - я его установил в папку, которую он предлагал по умолчанию, это правильно? Или надо было устанавливать его в определенную папку Солида?

????

 

Там же .msi файл... Инсталлятор. Двойной клик и он сам устанавливается откуда угодно.

Link to post
Share on other sites
marokko1986
5 минут назад, Krusnik сказал:

Там же .msi файл... Инсталлятор. Двойной клик и он сам устанавливается откуда угодно.

Да, так и делал.

Link to post
Share on other sites
Krusnik

Попробовал сейчас на ноуте. 

Он сам ставится, ставит патч и потом удаляет эту папку. Так что пофиг куда ставить.

 

32 минуты назад, marokko1986 сказал:

Вряд ли с ними обеими что-то не так.

Ну не факт.

У меня на домашней p620 на второй день сгорел разъём, через 2 дня ещё один. Хотя сама карточка при этом работала. Без синих экранов и т.п. Повёз менять.

 

На работе к620 вроде работала. Эксель лагал жутко. Отправили весной на удаленку. Забрал домой рабочую станцию, Решил по приколу поставить домашнюю p620. Всё начало летать. Хотя k620 работала вообще без багов (не считая тормозов).

 

У nvidia тяжелобронированные карточки. Даже с браком выдают картинку на монитор.

Link to post
Share on other sites
marokko1986

@Krusnik Все же сомнительно, т.к. и игры (не самые слабые) тянет норм. Как еще можно проверить исправность карты?

Link to post
Share on other sites
Kelny
5 часов назад, marokko1986 сказал:

Антивирусников тоже нет, стандартный Windows-овский - заглушен по максимуму.

Тогда есть риски работы вируса.

 

03.02.2021 в 04:34, marokko1986 сказал:

Галочка OpenGL НЕ стоит.

Попробуйте поставить. Если с галочкой работает лучше, то разбираться с драйверами видеокарты (возможно установить не новые, а наоборот более старые) или с самой видеокартой.

 

01.02.2021 в 02:52, marokko1986 сказал:

Quadro p620

Quadro RTX4000

Установите рекомендованные сертифицированные драйверы (в некоторых случаях для разных производителей системников предлагает разные драйверы, раньше ещё был вариант без привязки к системнику, но сейчас этого варианта нет):

https://www.solidworks.com/support/hardware-certification

 

 

 

 

Попробуйте запустить программу через SolidworksRX без дополнений, а то может какое дополнение тормозит работу программы.

 

 

Edited by Kelny
Link to post
Share on other sites
Krusnik
1 час назад, marokko1986 сказал:

Как еще можно проверить исправность карты?

Как советует @Kelny . Поставить галочку Open GL. Если ничего не изменится или станет лучше - то видеокарте конец.

 

Также аппаратную поддержку можно отключить в Solidworks RX и попробовать без неё.

1 час назад, marokko1986 сказал:

@Krusnik Все же сомнительно, т.к. и игры (не самые слабые) тянет норм.

Вот только большинство неслабых игр работает на DirectX, а SolidWorks на пресловутом OpenGL.

Из новых игр OpenGL использует разве что Doom Eternal (но это не точно).

А так самая свежая игра на OpenGL - это Quake 4.

Link to post
Share on other sites
marokko1986

Установка рекомендуемой версии драйвера (более старой) и установка патча вообще не внесли никаких изменений. Режим софтверного OpenGL включал - ни картинки, ни производительности, очень сильно влияет. Видеокарта явно исправна и работает. В диспетчере задач при вращении деталей идет нагрузка на GPU.

 

Снял видео на телефон, приложил 3 ссылки:

https://drive.google.com/file/d/15Hx32gUt4aZlh0YcW3GhfhaHSucnOYh4/view?usp=sharing

https://drive.google.com/file/d/1_vhsEXKLumELJpzT9ZeX3FN3dcxDlJQ4/view?usp=sharing

https://drive.google.com/file/d/1Thw9Wo8-nptj535DHiRHMhGviAxNacNd/view?usp=sharing

 

На 1м видео - как раз эта самая "ватная" работа SW, явно видно как вращение сборки не успевает за мышью. На 2м - в это же время открытая другая сборка, все крутится молниеносно. На 3м видео - сборка, которая крутится "ватно", но я просто сделал окно SW на пол экрана что бы посмотреть диспетчер, и уже все крутится как надо. Пока снял видео и скинул, эта сборка уже опять крутится быстро. В общем, странная фигня. И да, как я уже писал, эта проблема никак не связана со сложностью модели или чертежа, может проявляться как в простейшей детали, так и в большой сборке.

 

 

Link to post
Share on other sites
Krusnik

А мышь какая?

Напоминает вот это.

Скрытый текст

 

 

Link to post
Share on other sites
marokko1986

@Krusnik Да, эффект именно такой. Но он проявляется только в SW периодически, и мышь у меня не такая как в ролике, таких настроек нет.

Link to post
Share on other sites
Krusnik
32 минуты назад, marokko1986 сказал:

@Krusnik Да, эффект именно такой. Но он проявляется только в SW периодически, и мышь у меня не такая как в ролике, таких настроек нет.

Ну попробуйте другую мышь.

Сегодня пятница. Возьмите домой на выходные рабочую мышь.

Одолжите у знакомого фаната CS геймерскую мышь - там обычно в софте мыши частота опроса меняется.

Настройки в Windows посмотрите.

mouse settings.jpg

Link to post
Share on other sites
01.02.2021 в 16:00, jtok сказал:

Попробуйте:

  • сменить мышь

)))

  • Чемпион 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...