Jump to content

Ошибка при пересмотре ревизии: Имя входного свойства пусто


Andrey337

Recommended Posts

Andrey337

Здравствуйте, коллеги!

 

У нас ТС10.1.7.

Столкнулся со следующей проблемой, при создании ревизии в интерфейсе ТС, я получаю ошибку - Имя входного свойства пусто.

Шаги для воспроизведения:

Выбираю ревизию и нажимаю Файл-Пересмотреть

Если в открывшемся окне нажать Готово, то ревизия создается без ошибок

image.png

В открывшемся окне нажимаю Далее

Если в открывшемся окне (на этом шаге заполняются атрибуты мастер-формы) нажать Далее, причем неважно, вношу ли я какие-нибудь изменения или нет, то я получаю ошибку.

image.png

Подскажите, пожалуйста, где можно посмотреть, в чем ошибка, о каком атрибуте сообщается в ошибке?

image.png

image.png

image.png

Link to post
Share on other sites


UnPinned posts

Ошибку можно посмотреть в syslog-ах возможно у вас на объекте присутствует обязательный атрибут

Link to post
Share on other sites
Andrey337
6 часов назад, @ash сказал:

syslog-ах

При воспроизведении описанных мною шагов, для проявления ошибки появляются только эти строки в логе.

Может быть можно включить расширенное логирование?

image.png

 

 

Edited by Andrey337
Link to post
Share on other sites
lexx174
15.01.2021 в 23:13, Andrey337 сказал:

При воспроизведении описанных мною шагов, для проявления ошибки появляются только эти строки в логе.

Может быть можно включить расширенное логирование?

 

 

set TC_APPLICATION_LOGGING=ON

set TC_SECURITY_LOGGING=ON

set TC_ADMINISTRATION_LOGGING=ON

set TC_SYSTEM_LOGGING=ON

set TC_DEBUG=ON

set TC_journaling=ON

 

так же ошибки на уровне интерфейса отбиваются в логе в папке RAC

Edited by lexx174
Link to post
Share on other sites
Andrey337
17.01.2021 в 10:09, lexx174 сказал:

set TC_APPLICATION_LOGGING=ON

set TC_SECURITY_LOGGING=ON

set TC_ADMINISTRATION_LOGGING=ON

set TC_SYSTEM_LOGGING=ON

set TC_DEBUG=ON

set TC_journaling=ON

 

так же ошибки на уровне интерфейса отбиваются в логе в папке RAC

Спасибо за ответ, эти команды надо запустить из консоли администратора на сервере?

image.png

 

Если я установлю эти preference в интерфейсе ТС для расположения сайт, это будет тоже самое?

 

Я посмотрел эти preference в документации для ТС10.1.7 и не нашел там вот эту - TC_DEBUG.

Подскажите, пожалуйста, где найти её описание?

Link to post
Share on other sites
lexx174

это переменные

их не надо добавлять в консоль администратора. консоль в данном случае не при чем

 

их надо добавить либо в переменные среды windows либо в батник который стартует тимцентр

Edited by lexx174
Link to post
Share on other sites
Andrey337

Добавил эти переменные в батник ТС, воспроизвел шаги до появления ошибки, вот результат:

Серверный лог

image.png

Пользовательский лог

image.png

 

Вот пример отношения, о котором указано в пользовательском логе у остальных также.

image.png

 

Есть идеи?

Link to post
Share on other sites
Andrey337

Также в пользовательском логе есть строчка.

image.png

Это свойство отсутствует на том объекте, на котором воспроизводится ошибка.

Я открыл xml файл модели данных и попробовал искать это свойство, поиск показал, что свойство указанное в логе - na5_analog_dse отсутствует в модели данных (в файлах локализации этого свойства тоже нет).

Где еще можно поискать это свойство?

 

 

Link to post
Share on other sites
lexx174

походу вам нужно разобраться  с объектами другой модели данных

 

вы что-то импортировали в свою модель данных перед этим?

Edited by lexx174
Link to post
Share on other sites
Andrey337

Нет, ничего не импортировал. 

Возможно, это свойство раньше было, но я его удалил (причем очень давно, но и ошибка эта давно), na5 это префикс нашей модели данных.

Link to post
Share on other sites

Я бы еще попробовал очистить серверный кеш, остановить все службы Teamcenter, кроме FSC, на сервере в папке temp найти папку V10000.х.хххххххх и удалить ее, обратите внимание для 2-Tier и 4-Tier директории temp разные и для них создаются разные папки V10000.х.хххххххх.

После этого запустить службы и проверить создание элемента еще раз.

Edited by Nek
Link to post
Share on other sites
Andrey337
22.01.2021 в 11:04, Nek сказал:

Я бы еще попробовал очистить серверный кеш

Остановил все службы кроме FSC удалил папку V10000.

Ошибка осталась.

 

image.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Сообщения

    • Plumber
      Только если добавить еще 3 колонны и перевернуть вверх ногами 
    • Fedor
      Так то оно и так, но без энтузиазма и риска капитализма не построишь. Не все же могут к бюджету присосаться и жить безбедно  :) 
    • Beggars
      DANDRUFF IS AFRAID OF THIS SHAMPOO AS A FIRE https://sstopperhot.com  
    • mishanag
      Нет. Просто не создается файл и все)))
    • Viktor2004
      Тем более что на Биглии это проще сделать не сбив нули. Там от батареек провода не шлейфом идут через интерфейсные разъемы, а каждый к конкретному приводу на контакты батареек. Правда. кнопку блокировки двери шкафа они неудобно сделали в верхней части шкафа как раз напротив приводов. Возможно придется снять что бы не мешала
    • Maik812
      Считаю нужно сделать тему по различным совместимым или взаимозаменяемым деталям или стандартам. Например разным деталям не обязательно стандартам , а например подшипникам или еще каких. Наверно выкладывать в виде файлов или ссылок.
    • Сатнур
      Добрый день всем. я пере установил комп. и удалил Tupe3 4.2.0. помогите пожалуйста   
    • Romario03
      Странно, а какая-нибудь ошибка выскакивает, когда не может сохранить?
    • gudstartup
      Когда происходит ошибка я могу видеть только состояние битов уже после ошибки какой сработал первый утверждать не берусь да и как это проверить привод сдвоенный LM ось Х чувствует себя при этом прекрасно и отключатся не собирается. Я думаю все таки перекинуть привод...
    • Viktor2004
      Да нет там тормозных резисторов. Привод альфа. Торможение организовано рекуперацией на шину постоянного тока. Где находится это реле DB черт его знает читал что за динамическое торможение отвечают DIP-переключатели на фронтальной части привода. Но как отвечают, не нашел
×
×
  • Create New...