Alexey8107

Проблема со спецификацией

Здравствуйте. Начал разбираться со спецификациями в T flex 12. Как обычно вылезла проблема. 

3D сборка сделана, по моему это называется здесь сборка снизу вверх, когда создаются сначала модели всех деталей, а далее перетаскиваются на сборку. Чтобы на сборке в спецификации появились составляющие ее детали, каждой детали надо присвоить как минимум имя и обозначение, как это сделать знаю как минимум два способа. Либо в чертеже детали создать основную надпись и заполнить ее, либо открыть нужную деталь, в меню Сервис/спецификации/данные заполнить нужные поля и закинуть в требуемые разделы спецификации при необходимости. Пользуюсь в основном вторым способом. Так вот, т.к. сборка еще не полностью готова, постепенно добавляю в нее компоненты. Соответственно нужно обновлять спецификацию. Но она обновляться отказывается напрочь, приходится эту спецификацию удалять и создавать заново. При любом обновлении через меню "сервис/спецификация/обновить все" выдает окно "ошибка обновления базы данных спецификации". Тоже самое если просто сделать полный пересчет сборки с соответствующей галкой. При использовании меню сервис/спецификация/обновить позиции спецификация не обновляется... Можно ли убрать эту ошибку? Компоненты поддержки стоят все. Возможно я что то делаю не так. Но, если создавать новую спецификацию, все отображается правильно и в нужных разделах, проблема при обновлении.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах


@Alexey8107 Какая винда? Видел такую ошибку, были проблемы с недавними обновлениями 10-ки 1703.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пробовал на двух компах с Windows 7 и Windows XP, на обоих одно и тоже. Можно еще на 8 попробовать, но пока админ не дает прав к тому компу, точнее у меня нет времени дойти до него.

Изменено пользователем Alexey8107

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
33 минуты назад, Alexey8107 сказал:

Пробовал на двух компах с Windows 7 и Windows XP, на обоих одно и тоже. Можно еще на 8 попробовать, но пока админ не дает прав к тому компу, точнее у меня нет времени дойти до него.

А что с правами при работе на ТФ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не на ТФ, а на винду. Политика учетных записей. В том числе не на всех компах я могу зайти в винду со своей учеткой.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Попробуйте установить на папку Program, которая находится в папке T-Flex, полный доступ.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

К сожалению не помогло :( Т.к. полный доступ был для пользователя "все" на всякий случай добавили мою учетку и дали полный доступ, также не помогло.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Скорее всего проблема связана с политикой безопасности и/или правами доступа. Как вариант, попробовать с правами администратора. Если поможет, выяснять, на что именно надо расширить права. Второй вариант - обратиться в техподдержку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И вот снова проблема со спецификацией в тфлекс 15. Все необходимые поля заполнены, галочки стоят которые необходимы(ну это я так думаю, сравнивал с другими чертежами все идентично), Но почему то некоторые фрагменты не включаются в спецификацию. Например плата БП, хоть и заполнены наименование и обозначение, галочки включать в спецификацию стоят, но вот именно плата БП по какой то причине туда не входит, таким же образом ведут себя другие, следующие за платой БП сборочные единицы и детали, до нее все включается в спецификацию. Оставил только эти элементы, т.к. размер архива ограничен. Подскажите что я здесь не так делаю?

Спецификация.rar

Изменено пользователем Alexey8107

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
10 минут назад, Alexey8107 сказал:

И вот снова проблема со спецификацией в тфлекс 15.

всегда проще обвинить программу :clap_1:

 

1.thumb.png.0ec5b211a69391a478d3d4d02e959545.png

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Программу я не обвинял, я же написал, что я делаю не так...:no:

Спасибо, все помогло. Только откуда взялась эта галка??? Ума не приложу...

Изменено пользователем Alexey8107

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
6 минут назад, Alexey8107 сказал:

Только откуда взялась эта галка??? Ума не приложу...

1.png.92910f5e9b8c6d8ed38565761bcb37da.png

файл сделал 23 окт некий пользователь smz, это лучше у него узнать)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Это я на заводском компьютере. Вот и не могу понять когда я успел эту галку поставить. По дефолту она не ставится.

 

Изменено пользователем Alexey8107

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте, снова возникла задача со спецификацией.

У меня есть несколько параметрических фрагментов, используемых в сборочном чертеже. Сделано как, оба фрагмента имеют несколько исполнений, отличаются только размерами, соответственно при вставке в сборку я выбираю нужное мне исполнение. В одном фрагменте поле $Наименование заполнено как "Наименование {L}х{d}", при вставке в сборку нескольких исполнений этого фрагмента в спецификации отображается этот фрагмент отдельно для каждого исполнения. Именно так и надо. А вот второй фрагмент поле $Наименование надо заполнять уже не напрямую переменными, а в зависимости от значения переменной подкидывать текст. Не нашел другого способа как сделать так L==24?"Текст 1":"Текст 2". Текст подкидывается правильно в зависимости от значения переменной, так же на сборке правильно отображаются исполнения этого фрагмента, а вот в спецификации оба исполнения отображаются как "Текст 2". Т.е. в спецификации 4 фрагмента первого исполнения и 4 второго, а в спецификации только 8 фрагментов 2 исполнения. Создается такое впечатление если подкидывать переменные напрямую, то все нормально, а если использовать условие, то работает не верно.

Подскажите каким образом все это сделать правильно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
52 минуты назад, Alexey8107 сказал:

Подскажите каким образом все это сделать правильно?

файлик с "Наименование {L}х{d}" прикрепите.

есть несколько способов решения

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
40 минут назад, SAPRonOff сказал:

файлик с "Наименование {L}х{d}" прикрепите.

С этим файлом как раз проблем нет :) Может быть и сделал что то не так, но все работает как должно. Это файл Шкив.

Проблема с файлом Подшипник LM8.

Проект тестовый, для отработки навыков работы со спецификацией, поэтому особо не углублялся в мелочи моделей, и выбрал для деталей то, что первым пришло в голову.

Проект прикрепляю. Спецификация создана, сборка также имеется, состоит из фрагментов в разных исполнениях.

 

Посмотрел видео, примерно так и сделал. Единственная разница в том, что в видео показано дополнительно еще исполнения самой сборки. У меня только меняются исполнения фрагментов в сборке, сама сборка не трогается. Вот с фрагментом Шкив проблем нет, а вот с Подшипник LM8 спецификация отображает этот фрагмент в разном исполнении как один и тот же фрагмент. Сделано наподобие как в видео.

 

Хотя я наверное не верно применяю термин "исполнения", возможно этот термин логичнее применить к сборке если у нее есть разные исполнения. У меня меняются только размеры фрагмента, возможно здесь правильнее применять термин "конфигурация".

test.rar

Изменено пользователем Alexey8107

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 часа назад, Alexey8107 сказал:

Подшипник LM8 спецификация отображает этот фрагмент в разном исполнении как один и тот же фрагмент.

 у Вас в примере отвязана связь с переменной Наименования.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо, понял. Тогда вопрос, специально посмотрел фрагмент Шкив, там тоже самое, но разница в том, что $Наименование формируется из текста + переменные. В таком виде в спецификации все норма. Это нормально с точки зрения T Flex, либо все таки лучше привязывать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
13 минуты назад, Alexey8107 сказал:

Это нормально с точки зрения T Flex, либо все таки лучше привязывать?

вы тут через фигурные скобки прописали связь с перемнными:

5bcf1f6629e5b_.jpg.41f4ff7e3492b17b4611a2e7718253e6.jpg

связывать параметры структуры изделия можно:

либо

1. через флажок справа (как на видео выше - считаю более правильным/удобным способом)

либо

2. можно через {} делать ссылку на переменную (этот вариант вы использовали в шкиве)

Изменено пользователем SAPRonOff

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо, значит это просто две стороны одной медали :) Теперь буду знать как надо делать. Еще раз спасибо. Первый способ похоже мало того что проще, так еще и универсальнее. 

Изменено пользователем Alexey8107

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу



  • Сообщения

    • Ectoplaza
      Sarcasm on   Ох, беда-беда, огорчение. Суровые олдскульные кнопочки испортили :( Как будто больше не к чему придраться. Sarcasm off     Первое что сделал после установки SW2016 вернул классическую цветовую схему.
    • Юрий Лукьянов
      Всем привет! Решили мы немного поднять свой уровень и перейти на более серьёзную технику. По случаю приобрели с завода пару старых фрезерных обр. центров. Один из которых "Chiron FZ18s" 1996г.в., со стойкой "Sinumerik 840d". Подключение и освоение начали с него. В первую очередь необходимо было поднять голову по Z в референт, дабы открутить защитную шторку направляющих для устранения кое-каких механических дефектов, и тут на старте столкнулись с ошибкой 700153. По мануалу она сообщает о незапертости двери. Ошибка не сбрасывается. В замке торчит открученная от двери заглушка. Подёргали её туда-сюда, ничего не происходит. Включили станок без неё, потом вставили, опять подёргали - ничего. Та же ошибка и станок стоит как вкопанный. Полезли в этот замок/концевик, разобрали его. Там имеется подвижный механизм с контактами и блокирующий его соленоид. Который, как я понимаю, должен приходить в действие при включении питания, но этого не происходит, 24в на питающих его проводах нет. Вобщем вопрос: можно ли каким-то образом сбросить эту ошибку програмно, либо каким-то другим способом. Спасибо.   P.S.: При покупке проверяли работоспособность станка, всё было нормально. На данный вопрос заводские операторы и электрики разводят руками. 
    • Frantic
      Есть ли возможность спрятать модули Teamcenter от всех пользователей, кроме определённой группы (групп)? Знаю, что пункты меню можно прятать, а вот модули как, не нашёл.
    • Владимир56
      У наших слесарей. На 3 года меня младше:
    • Maik812
      да не удобно ! и не только значки там голубые! даже с цветовой схемой старых значков много голубого появилось в дереве построения!
    • Владимир56
      В общем покритиковать просьба. Просверлил 14 отверстий Ф5 в каждом кармане, крайнии в точках размеров кармана минус 0.05мм. Сделал выступы.  Далее думал пятёркой Геринг, залил парафином, но засомневался в износостойкости фрезы, дали одну штуку.  Прошёл фрезой 10 Р6М5 до дна без обработки  боковых стенок.  Далее думаю в несколько этапов. Насколько хватит длины фрезы. Выбрал вчистую на глубину 26.5 2 кармана, за 2 прохода -черновой, чистовой. Обороты 1200, больше нет. Подача 110-120 соответственно. По слоям 0.7мм. Сдвинул заготовку в тисках ещё на 2 кармана. Выбрал десяткой, оставил до понедельника. Далее думаю за 1-2 раза выдвигать фрезу и фрезеровать до дна с уменьшением съёма, подач. Зажим за остаток 7мм приблизительно. Визуально фреза износилась одним зубом больше, образовалось притупление 0.3, можно переточить на фаску 0.3, но наверное покрытие там. Лучше торец сточить.
    • Arkhipkin_Pavel
      Всем Здравствуйте!!! Подскажите, где в солиде имеется настройка по выбору плоскостей через прозрачность. Суть такая, есть модель, она вписана в габоритную модель, заготовку, все это нужно для solidcam, так вот, при выборе геометрии у основной модели солид не может выбрать плоскости за прозрачностью заготовки, выбор можно осуществить только путем нажития правой кнопки и выбора  команды другие, и там уже из предложеного списка можно выбрать необходимую плоскость, как настроить чтоб не нажимать каждый раз на команду другие, а  в графической области через заготовку выбирать нужную плоскость? 
    • nbg
      Благодарю всех! Пользуюсь логированием.
    • nbg
       Доброго времени суток! может кто сталкивался с подобной проблемой. написал Handler, который в зависимости от вида извещения формирует определенной сообщение и отправляет его по внутренней почте. при компиляции, нет ни каких ошибок. при использовании handler-а в процессе. он отрабатывает, но иногда teamcenter просто отваливается. если использовать на 4 звенном теряется связь с сервером. нет никакой закономерности, может отвалится и на 2, и на 10 раз. с помощью логера отследил, где все валится       SAFE_CALL(EPM_ask_root_task(task, &root_task), ifail, root_task); logger::print_log(">> get root task\n"); if (ifail != ITK_ok || root_task == NULL_TAG) return; logger::print_log(">> perem\n"); SAFE_CALL(EPM_ask_attachments(root_task, EPM_target_attachment, &targets_count, &targets), ifail, targets_count); logger::print_log(">> get attacment\n"); SAFE_CALL(AOM_ask_value_string(*targets, "ekp7_CMType", &type_izv), ifail, type_izv); logger::print_log(">> get type izv\n"); logger::print_log(" ekp7_CMType - %s\n", type_izv); что то происходит в : SAFE_CALL(EPM_ask_attachments(root_task, EPM_target_attachment, &targets_count, &targets), ifail, targets_count);  хотя выше точно такая же строчка выполнялась без проблем. teamcenter  отваливается, с сообщением подробности в системном журнале. в котором вижу только такие ошибки: ERROR - 2018/11/16-13:42:22.483 UTC -  - The loginUser is null, this is unexpected at this point in the Session.
      The Session State will not be updated with information from the client service request.   ERROR - 2018/11/16-13:42:30.431 UTC -  - 65: CFI error: -65.
      ERROR - 2018/11/16-13:42:30.431 UTC -  - loginUser::initialise failed for 515007 - Teamcenter at d:\workdir\tc114w1201_64\src\core\tc\loginuser.cxx(582)    ERROR 26003 ITK_internal_error: Unclassified error/exception. See system log file for possible explanation.
             ERROR515007 POM has not started.   которые не очень информативны для меня.     может кто сталкивался с подобной проблемой. если ошибка в коде, тогда почему хэндлер отрабатывает. вообще в какую сторону копать? EPM_ask_attachments использую выше этого места, там все отрабатывает. Поэтому решил, получить нужные мне свойства, тогда когда она отработала без проблем. для этого переписал , но в итоге точно такая же ошибка возникла: SAFE_CALL(AOM_ask_value_tags(*atts, "CMHasProblemItem", &n_problem, &CMHasProblemItem), ifail, n_problem); хотя выше AOM_ask_value_tags выполнялось без ошибки. в системном журнале те же сообщения:  The loginUser is null, this is unexpected at this point in the Session.   За раннее благодарен за любую подсказку!
    • Евгений Щиголев
      Столкнулся с той же проблемой. Однако, решение не помогло и с 10 и с 20 раза. Есть какие-то ещё предположения или мысли, в чём может быть проблема?