Гость

FAQ/PowerMill

503 сообщения в этой теме

Какую траекторию используете?

Прикрепите проект. Здесь инженерный форум, а не форум экстрасенсов.

Если " по профилю кривой", то:

2018-06-21_23-07-26.png.4e7d90517064568060d638defd19a4ec.png2018-06-21_23-12-40.png.e48bde6292135ca9ef5d9d8afcae61ef.png

 

1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах


Machinist, большое Вам спасибо!

Все замечательно получилось.

 

Я предполагал,что на инженерном форуме не пользуют оккультные практики,

поэтому стратегию обработки "По профилю 2D кривой" указал постом выше:smile:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите, пожалуйста, Pmill2017: немного изменил модель, заменил в проекте и теперь при пересчете прежней траектории появляется сообщение и траектория, соответственно, не пересчитывается. Как от этого избавиться, подскажите?

PMill 2017_1.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо огромное, очень помогло. Трудно понять логику разработчиков - это кошмар.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 486   Опубликовано: (изменено)

Доброго времени суток. В Powermill Modeling 2018 и 2019 - во вкладке МАСТЕР неактивна кнопка СОЗДАТЬ ЭЛЕКТРОД, может кто знает как решить эту проблему. В более ранних версиях такой проблемы небыло. Зараннее спасибо !

Изменено пользователем mortinio

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, mortinio сказал:

В Powermill Modeling 2018 и 2019 - во вкладке МАСТЕР неактивна кнопка СОЗДАТЬ ЭЛЕКТРОД

Вы не правы - в предыдущих версиях было тоже самое

просто повермилл моделлинг поддерживает только поверхностное и каркасное моделирование

для полноценной работы все модулей шейпа - нужно установить полную версию, а не обрезанную

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 488   Опубликовано: (изменено)

11 минуту назад, eksodus сказал:

Вы не правы - в предыдущих версиях было тоже самое

просто повермилл моделлинг поддерживает только поверхностное и каркасное моделирование

для полноценной работы все модулей шейпа - нужно установить полную версию, а не обрезанную

Всё верно PowerShape у меня установлен и там всё работает, но много манипуляций с импортом-экспортом туда-сюда. Раньше прямо в Powermill можно было создать электрод (открывался PM Modeling). Версия установлена Ultimate, как бы максимальная.По идее должно всё работать но нет... Ну или чтобы вместо моделинга шейп открывался как-то.. при нажатии опции моделирование поверхностей в миле.

 

Изменено пользователем mortinio

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 489   Опубликовано: (изменено)

В 01.07.2018 в 22:17, mortinio сказал:

Раньше прямо в Powermill можно было создать электрод (открывался PM Modeling).

опять Вы ошибаетесь - при выделении поверхностей и запуске мастера создания электродов -

открывался шейп в окне мила не как PowerMILL Modelling а как Delcam Electrode !

А это совсем разные лицензии, и как результат - разные возможности.

Более подробно по каждому режиму работы Delcam PowerSHAPE предыдущих версий  -

почитайте в справке к шейпу, там всё это расписано.

Изменено пользователем eksodus
1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

17 часов назад, eksodus сказал:

опять Вы ошибаетесь - при выделении поверхностей и запуске мастера создания электродов -

открывался шейп в окне мила не как PowerMILL Modelling а как Delcam Electrode !

А это совсем разные лицензии, и как результат - разные возможности.

Более подробно по каждому режиму работы Delcam PowerSHAPE предыдущих версий  -

почитайте в справке к шейпу, там всё это расписано.

Спасибо за разъяснение . Получается в более ранних версиях было проще работать с электродами. Может быть Вы мне подскажете алгоритм как быстро создать электрод без импорта-экспорта модели ?  Или может как-то деинсталлировать моделинг можно чтоб сразу в шейпе открывалось ? Возможно такое ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Просьба о помощи, подскажите, пожалуйста, Pmill2017: импортировал в проект измененную модель (файл *.sldprt), проверяю траектории на зарезы, сообщает, что зарезов нет, но визуально видно, что деталь зарезается. Как это лечится?

Для форума_1.jpg

Для форума_2.jpg

Для форума_3.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 492   Опубликовано: (изменено)

6 минут назад, Bear62 сказал:

Просьба о помощи, подскажите, пожалуйста, Pmill2017: импортировал в проект измененную модель (файл *.sldprt), проверяю траектории на зарезы, сообщает, что зарезов нет, но визуально видно, что деталь зарезается. Как это лечится?

1. Проверьте, что инструмент, для которого рассчитана траектория, совпадает с тем инструментом, который вы активировали в данный момент

2. Какую стратегию используете?

3. Есть ли игнорируемые поверхности/модели (функция припуск компонента)

4. Проверьте не только на зарезы, но и на столкновения.

либо опубликуйте проект

Изменено пользователем Kinematik

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1 Инструмент траектории и активный совпадают (D=16).

2 Стратегия "Чистовая с постоянной Z"

3 Да, поверхности установлены как игнорируемые (в параметрах траектории)

4 Проверка столкновений требует задания хвостовика или патрона. В моем случае при малых высотах детали патрон и хвостовик не задавал - лишние затраты времени

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 минут назад, Bear62 сказал:

Да, поверхности установлены как игнорируемые (в параметрах траектории)

Раз игнорируются, значит не учитываются программой при расчёте траектории.

Соответственно Вы видите "зарезы" при визуализации, что вполне логично.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На этой странице, немного выше, обращался с вопросом, пришлось редактировать модель и заменить прежнюю модель измененной. Прежние траектории начали ругаться, что вся модель задана быть проигнорированной. была подсказка игнорировать. Сейчас модель опять редактировалась. Наверное, траектории придется все пересчитывать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, Bear62 сказал:

На этой странице, немного выше, обращался с вопросом, пришлось редактировать модель и заменить прежнюю модель измененной. Прежние траектории начали ругаться, что вся модель задана быть проигнорированной. была подсказка игнорировать.

Всё наоборот) Траектория не рассчитывалась из-за того, что вся модель "игнорировалась". 

Вам нужно было убрать модель из игнора.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите, как убрать модель из игнора?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Большое спасибо. Лихо закручен сюжет! Буду пробовать

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Опять споткнулся на ровном месте; Pmill2017 : в проекте траектории были рассчитаны с "Размещением точек" вписать дуги; графически точки траектории показываются правильно; записываю NC-файл - Вывелась УП с большим количеством точек по G1. В проекте присутствуют ещё аналогичные траектории, но они записались в этой же УП правильно. То же самое происходит с использованием других п/процессоров. Как можно это явление победить?

Для форума 4.jpg

Для форума 4_2.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Наверное, нужно изменить что-то в п/процессорах в плоскостях отличных от базовой СК. Может кто подскажет? П/процессоры были импортированы из *.pmopt в *..pmoptz

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
17 часов назад, Bear62 сказал:

Опять споткнулся на ровном месте; Pmill2017 : в проекте траектории были рассчитаны с "Размещением точек" вписать дуги; графически точки траектории показываются правильно; записываю NC-файл - Вывелась УП с большим количеством точек по G1. В проекте присутствуют ещё аналогичные траектории, но они записались в этой же УП правильно. То же самое происходит с использованием других п/процессоров. Как можно это явление победить?

А270.0?

У вас траектория скорее всего multiax, поэтому дуги и не выводятся.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 503   Опубликовано: (изменено)

Да, УП работает в СК А90, А180, А270

Нужно вносить изменения в Настройках опционного файла. Разобрался, что-то получилось. Буду тестировать.

Изменено пользователем Bear62

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу