AleksandrMaas1

Вопросы по написанию постпроцессора для 4-axis

Pinned posts

ID: 1   Опубликовано: (изменено)

Начал писать постпроцессор для 4-х осевого станка (одна ось на голове - поворотная вокруг Z). 

Вначале создал 3-осевой станок и использовал стандартный постпроцессор. Все ОК. 

Дописал в этот пост дополнительную ось (Machine A), импортировал новую кинематику из mtd-файла, но этот пост вообще не генерирует координаты движения на выходе. Может быть проблема в cut-файле? Симуляция в POwermill проходит хорошо.  Можно как-то увидеть что в cut-файле внутри?

 

Также на форуме нашел 5-осевые постпроцессоры. Импортировал свою кинематику, но тот-же результат.

 

4axis+toolChange.cut

Debug постпроцессора.jpg

вид.jpg

Изменено пользователем AleksandrMaas1
добавил фотку

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах


UnPinned posts

Хоть кто-нибудь пишет посты? Есть какие-нибудь идеи. Почему все координаты выводятся нулями?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я не очень разбираюсь в постах - но у вас же в окне проги PostProcessor внизу куча предупреждений, что команды неактивны.

Неужели так тяжело перевести в гугле что означает "Command inactive" ?

Активируйте команды - может заработает. Но скорее всего их ещё настраивать придётся.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу