o.tel.o

При открытии сборки стала выскакивать ошибка

Всё было хорошо, до тех пор пока при открытии сборки не начала выскакивать ошибка: "Solidworks не удалось получить необходимую свободную память". Аналогичная сборка (с добавленными деталями) открывается нормально. Монитор памяти показывает, что памяти много свободной. При нажатии "cancel" или "retry" солид закрывается.

Методом тыка установлено, что ошибка исчезает при открытии сборки с опцией "только просмотр", нажатии "редактировать", ошибки солида, вылете солида, перегрузки солида и нормальном открытии сборки!

SW 2007 sp0, 2 гига RAM 800 МГц, 7600GT, 2.13 core duo

1) У кого такое было?

2) Какой памяти не хватает солиду?

3) Как ещё (кроме предложенного метода) можно это вылечить?

post-9424-1234190814_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах


Всё было хорошо, до тех пор пока при открытии сборки не начала выскакивать ошибка: "Solidworks не удалось получить необходимую свободную память". Аналогичная сборка (с добавленными деталями) открывается нормально. Монитор памяти показывает, что памяти много свободной. При нажатии "cancel" или "retry" солид закрывается.

Методом тыка установлено, что ошибка исчезает при открытии сборки с опцией "только просмотр", нажатии "редактировать", ошибки солида, вылете солида, перегрузки солида и нормальном открытии сборки!

SW 2007 sp0, 2 гига RAM 800 МГц, 7600GT, 2.13 core duo

1) У кого такое было?

2) Какой памяти не хватает солиду?

3) Как ещё (кроме предложенного метода) можно это вылечить?

Открывается какая-то определеная сборка или любая?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пока было замечено на 2х аналогичных сборках, в то время как на третьей аналогичной данный эффект не проявился (отличие аналогичных сборок лишь в нескольких деталях)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1) У кого такое было?

2) Какой памяти не хватает солиду?

3) Как ещё (кроме предложенного метода) можно это вылечить?

1. Такого не было...

2. скорее всего оперативки...

3. думаю - это связано с замусоренностю памяти (такое бывает часто, если винда долго работает без очистки) - советую посмотреть при помощи комбинации из 3х пальцев (проверить сколько свободной памяти) и поудалять всё что можно (разные красивульки и т.п., системные штучки удалить неудасться)...

4. проверить - что запускается в загрузке системы...

5. а может и вирус или троян (у нас несколько троянов бродят по КБ через флешки - типа "ntde1ect.com", ленивые чистят не хотят)...

6. может и сам Солид уже крякнулся и его нужно либо пичинить (восстановить/переустановить), либо переустановить с полным удалением этой установки...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Было такое в сборках с массивами компонентов. Лечил открытием сборки в сокращенном виде и удалением массивов.

Винда была свежеустанновленная. Памяти 3,2 Гб.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пока было замечено на 2х аналогичных сборках, в то время как на третьей аналогичной данный эффект не проявился (отличие аналогичных сборок лишь в нескольких деталях)

Можно попробовать удалить эти детали из папки проекта и попробовать открыть сборку.

SW должен обругаться на их отсутсвие - нужно отказаться.

Если сборка откроется, значит дело в этих деталях.

Перед этим, ессно, нужно сделать соответствующие копии...

И вообще, с чего все началось можно определить?

Может с этими деталями были произведены какие-то операции?

Попробовать "погасить" эти операции в деталях.

Или это началось после вставке какой-то детали, тогда переместить эту деталь в другое место.

Сами детали, кстати, открываются?

Где они расположены: в папке проекта или разбросаны по нескольким папкам.

Не велика-ли длина путей к сборке, деталям.

Посмотреть нет ли еще одного запущенного процесса SW.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Было такое когда по началу было что то типа папка в папке а в той папке папка с папкой в которой деталь лежит в своей папке. Тфу сам запутался, :rolleyes: а винда и подавно глючить начинает и не подаёт то что нужно солиду вовремя. Отсель и вылезает такое. Теперь проэкт колю на минимум файлов и то в процессе работы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Это скорее всего из-за ошибки в файле сборки или в какой-то из деталей, особенно возможно если детали строились в контексте и могла получится циклическая ссылка.

В настройках установите загрузить сборку в сокращенном виде. И постепенно решать все детали. Или поступить как в посте #6.

Можно открыть по очереди детали и перестроить их.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И вообще, с чего все началось можно определить?

Может с этими деталями были произведены какие-то операции?

Попробовать "погасить" эти операции в деталях.

Или это началось после вставке какой-то детали, тогда переместить эту деталь в другое место.

Сами детали, кстати, открываются?

Где они расположены: в папке проекта или разбросаны по нескольким папкам.

Не велика-ли длина путей к сборке, деталям.

Ничего необычного не делал. Предложенный мной метод в 1ом посте лечит сборку и в последующие разы она открывается без проблем! Значит дело в... (?)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ничего необычного не делал. Предложенный мной метод в 1ом посте лечит сборку и в последующие разы она открывается без проблем! Значит дело в... (?)

Как-бы потом эта ошибочка в "критический день" не вылезла.

Если эта сборка актуальна, конечно.

Я, вообще-то, привык "идти до конца". В смысле разбираться с проблемами.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Поставь 5 сервис пак

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да... солид глюковат... работаю в нем еще совсем мало, но уже напрегся нафик...

Что он выкинет непредсказуемо. На работе лицензия- дома не очень, а разницы особо никакой.

Вот такая вчера причуда выскочила: нажимаю" сохранить"- пишет, что не может (без обьяснений- не могу и все) Блин! Полчаса возни с сопряжениями...

Нажал "сохранить как" и сохранил с другим именем...

-----------------

"Кто этот потерпевщий! Куда он пашол! (с) :g:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

По поводу "Солид глюковат" - скажу, что нет. Очень стабилен.

По поводу памяти - год назад нахлебался по полной. Массивы совсем не причем. У меня проблема решилась после удаления деталей и сборок, сделанных на "старых" шаблонах. - Ну еще заметил, что детали, созданные в сборке создают "циклы".

Вот сегодня опять выскочило - не хватает памяти, закрываюсь, ужос. Глянул - есть детали 2 летней давности - детали выбросили - результат - все чисто и опрятно.

В сборке 46000 компонентов. (сорок шесть тысяч). Сейчас сижу делаю чертеж - медленно, но верно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В сборке 46000 компонентов. (сорок шесть тысяч). Сейчас сижу делаю чертеж - медленно, но верно.

Кошмар! А чертежей деталей тоже 46000????

Да... солид глюковат... работаю в нем еще совсем мало, но уже напрегся нафик...

Это, примерно, у всех программ такая ситуация. SW не исключение. Объемы кода растут, соответственно и ошибки. Но работать можно, и довольно комфортно...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Кошмар! А чертежей деталей тоже 46000????

Да нет, конечно - массивы и массивы. Слава Богу "оригинальных" деталей не много. Вот только это часть комплекса. Весь комплекс еще не собирал - там используем упрощенные модели.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всё было хорошо, до тех пор пока при открытии сборки не начала выскакивать ошибка: "Solidworks не удалось получить необходимую свободную память". Аналогичная сборка (с добавленными деталями) открывается нормально. Монитор памяти показывает, что памяти много свободной. При нажатии "cancel" или "retry" солид закрывается.

Методом тыка установлено, что ошибка исчезает при открытии сборки с опцией "только просмотр", нажатии "редактировать", ошибки солида, вылете солида, перегрузки солида и нормальном открытии сборки!

SW 2007 sp0, 2 гига RAM 800 МГц, 7600GT, 2.13 core duo

1) У кого такое было?

2) Какой памяти не хватает солиду?

3) Как ещё (кроме предложенного метода) можно это вылечить?

Было аналогично тоже на SW2007.Сборка со множеством мелких деталей+декоративная панель с рисунком в Photoworks+4 случайно сохраненных разреза.Вылет с тем же замечанием на последней стадии открытия сборки.Реально памяти много,должно хватать.

Сначала отключил Фотоворкс (т.е. без рисунка)-помогло.Потом убил разрезы-вроде все пошло.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу