Jump to content

Delem 65. Нужна консультация, не работает ось X.


Recommended Posts

vladimir.songin

Здравствуйте.

Есть пресс с контролёром DELEM 65. Имеются оси: Y1, Y2, X, X1, R, Z1, Z2. Некоторые оси отключены, некоторые работают хорошо, некоторые плохо. Например ось z2 сама по себе двигается постепенно в бок. Это начало раздражать и попытались эту ось отключить. Процедура понятная, некоторые оси уже были отключены раньше. Но после отключения появилась ошибка: MSA missing for module 2012391. Ошибка появлялась всегда после перезагрузки и оси даже не начинали инициализироваться. Проблема по CAN шине. Своими силами разбираться желания особо у меня небыло. Нашёл ребят в польше, которым выслал весь компьютер с расширениями и они как бы его починили, но... не совсем. После ремонта, контролёр видит все блоки, через 50 меню видим все входы, управляем всеми выходами, в том числе аналоговые. После включения соответствующих выходов, все оси (у которых рабочие сервомоторы) управляются и слушаются. Но при старте не инициализируются и станок не запускается. Никаких ошибок нет.

Кода заходим в 50 меню, а затем в какой либо блок расширения, в верхней строке видим счётчик энкодера. Во время управления конкретной осью, либо просто если ось подвинуть вручную или повращать энкодер, показания счётчика меняются. Кроме оси Х. А с осью Х происходят чудеса. При входе в блок DM02, который управляет осями Y1, Y2, X, и компенсатором нижней балки, в верхней строке должен высвечиваться счётчик энкодера, а справа сверху параметр аналогового входа. Аналоговый вход, в нашем случае, э то обратная связь положения компенсатора. При активации соответствующих выходов, включается мотор компенсатора и в одну либо другую сторону и  меняется значение обратной связи аналогого входа. А теперь самое интересное - в поле счётчика энкодера высвечивается то же самое значение, что и в окне аналогого входа.  Я не знаю это ли является причиной, лишь предполагаю, но ось Х не инициализируется и станок не запускается. Если отключаю ось X, X1, Z1, Z2, а оставляю только Y1 Y2 и R, то станок запускается и работает. Как только добавляю X, инициализация не проходит и станок не работает. 
Прилагаю видео:  https://1drv.ms/v/s!Agwfggcm6YCVweRffGg_8KeuB2SeJA?e=lleTFw

Если вдруг не качается напишите, размещу как-то по другому. 

Прицепляю ещё BackUp, который был сделан сразу после ремонта компа, но станок ещё не был запущен.  TOOLS

Внимание вопрос: Что за фигня и что можно с этим сделать. Очень буду благодарен за любые подсказки и направления движения. 

 

 

Link to post
Share on other sites


UnPinned posts
Tad

Читают, don't worry. А задача с этой машиной непростая, тем более для вас, несмотря на ваш высокий профессионализм. Ремонтом привода Х-оси тут не обойдешься. Решение проблемы есть и вы его знаете. Выбор за вами. Как говорится, было бы предложено. 

Link to post
Share on other sites
vad0000
16.04.2024 в 19:30, vladimir.songin сказал:

Есть пресс с контролёром DELEM 65. Имеются оси: Y1, Y2, X, X1, R, Z1, Z2. Некоторые оси отключены, некоторые работают хорошо, некоторые плохо. Например ось z2 сама по себе двигается постепенно в бок. Это начало раздражать и попытались эту ось отключить. Процедура понятная, некоторые оси уже были отключены раньше. Но после отключения появилась ошибка: MSA missing for module 2012391. Ошибка появлялась всегда после перезагрузки и оси даже не начинали инициализироваться. Проблема по CAN шине. Своими силами разбираться желания особо у меня небыло. Нашёл ребят в польше, которым выслал весь компьютер с расширениями и они как бы его починили, но... не совсем. После ремонта, контролёр видит все блоки, через 50 меню видим все входы, управляем всеми выходами, в том числе аналоговые. После включения соответствующих выходов, все оси (у которых рабочие сервомоторы) управляются и слушаются. Но при старте не инициализируются и станок не запускается. Никаких ошибок нет.

Кода заходим в 50 меню, а затем в какой либо блок расширения, в верхней строке видим счётчик энкодера. Во время управления конкретной осью, либо просто если ось подвинуть вручную или повращать энкодер, показания счётчика меняются. Кроме оси Х. А с осью Х происходят чудеса. При входе в блок DM02, который управляет осями Y1, Y2, X, и компенсатором нижней балки, в верхней строке должен высвечиваться счётчик энкодера, а справа сверху параметр аналогового входа. Аналоговый вход, в нашем случае, э то обратная связь положения компенсатора. При активации соответствующих выходов, включается мотор компенсатора и в одну либо другую сторону и  меняется значение обратной связи аналогого входа. А теперь самое интересное - в поле счётчика энкодера высвечивается то же самое значение, что и в окне аналогого входа.  Я не знаю это ли является причиной, лишь предполагаю, но ось Х не инициализируется и станок не запускается. Если отключаю ось X, X1, Z1, Z2, а оставляю только Y1 Y2 и R, то станок запускается и работает. Как только добавляю X, инициализация не проходит и станок не работает. 
Прилагаю видео:  https://1drv.ms/v/s!Agwfggcm6YCVweRffGg_8KeuB2SeJA?e=lleTFw

Если вдруг не качается напишите, размещу как-то по другому. 

Прицепляю ещё BackUp, который был сделан сразу после ремонта компа, но станок ещё не был запущен.  TOOLS

Внимание вопрос: Что за фигня и что можно с этим сделать. Очень буду благодарен за любые подсказки и направления движения. 

dm02.jpg

 

Если Вы курсор поставите на OUTPUT 0, и колесом начнёте увеличивать напряжение на аналоговом выходе, то ось Х поедет, или нет?

Сфоткайте машинные параметры для оси Х

Link to post
Share on other sites
vad0000
14 минут назад, vladimir.songin сказал:

Да поедет. Нужно только активировать перед этим выход 2006. 

Это выход на тормоз привода, или перевод привода из. stand by в run?

Link to post
Share on other sites
vladimir.songin

Ось Х поедет, нужно только активировать перед этим выход 2006, а когда доедет, то отработает вход 2020. 2020 это концевик оси Х. При этом, на вашем скрине в поле энкодера правильное значение. А у меня ENC = Input0.

2006 это скорее всего RUN. При его активации могу подвигать ось X и R. С другоими осями другие проблемы и их я отключил пока вообще. 

Screenshot 2024-04-19 082359.png

20240415_083254077_iOS.jpg

20240415_083303964_iOS.jpg

20240415_083340099_iOS.jpg
По моим ссылкам получается фото и видео  посмотреть?

 

Link to post
Share on other sites
vad0000
8 минут назад, vladimir.songin сказал:

2006 это скорее всего RUN

А Вы откройте шкаф, и посмотрите.

Статус привода до активации 2006, и после

Link to post
Share on other sites
vladimir.songin
15 часов назад, Tad сказал:

Читают, don't worry. А задача с этой машиной непростая, тем более для вас, несмотря на ваш высокий профессионализм. Ремонтом привода Х-оси тут не обойдешься. Решение проблемы есть и вы его знаете. Выбор за вами. Как говорится, было бы предложено. 

Вы ведь тоже понимаете, что решаю не я. Я бы с удовольствием соскочил с этого дела, но только путём решения вороса каким-либо образом.  Никогда не оставляю после себя нерешённых задач.  Я всё передал и предложил в соответствии с нашими с вами договорённостями.  К сожаление решение вышестоящих немного не такое, как я ожидал. 
Пытаюсь добить тему до конца. Много уже изучил, знаю и понимаю. Ось Х точно рабочая. Ничего с ней не нужно делать. Это мне уже понятно. 
P.S. За любую помощь буду в любом случае благодарен. 

Link to post
Share on other sites
vladimir.songin
13 минут назад, vad0000 сказал:

А Вы откройте шкаф, и посмотрите.

Статус привода до активации 2006, и после

Для оси X, по схеме, активация всегда активна. В шкаф посмотрю попозже. Сегодня поеду на этот завод. Тем не менее, чтобы ось X в подвигать, нужно активировать этот выход. На схеме указано, что 2006 это: proportional valve ON. 

схема.jpg
24В, которые активируют привод оси X, появляются после того, как запускаем гидравлику и отрабатывает реле безопасности. Я думаю что с разрешением на движение оси X всё нормально, потому что если:

  1. Включить ось X
  2. Передвинуть ось X куда-нибудь к середине
  3. Перезапустить станок и нажать старт

то

  1. ось X едет в конец до упора, (значит с разрешением всё ОК)
  2. отрабатывает концевик оси X, (Нажать концевик пораньше и проверить останавливается ось X по концевику или по упору не пробовал)
  3. позиционируется ось R
  4. Балка едет до упора вверх. 
  5. Станок дальше не работает. 

Если всё то же без оси X, то станок работает, но ось X соответственно не движется. 

Что касается оси R, ранее я ввёл в заблуждение. Для того, чтобы подвигать ось R, нужно активировать выход не 2006 а 1102. 

Link to post
Share on other sites
vad0000
13 минут назад, vladimir.songin сказал:

На схеме указано, что 2006 это: proportional valve ON. 

Покажите эту схему

14 минут назад, vladimir.songin сказал:
  • ось X едет в конец до упора, (значит с разрешением всё ОК)
  • отрабатывает концевик оси X, (Нажать концевик пораньше и проверить останавливается ось X по концевику или по упору не пробовал)
  • позиционируется ось R
  • Балка едет до упора вверх. 
  • Станок дальше не работает. 

Нажмите на ЧПУ - ручное позиционирование осей. Фото

Link to post
Share on other sites
vladimir.songin
1 минуту назад, vad0000 сказал:

Покажите эту схему

 

схема.jpg
видно?

1 минуту назад, vad0000 сказал:

Нажмите на ЧПУ - ручное позиционирование осей. Фото

Как я понимаю, хотите видеть ручное позиционирование без входа в 19 или 50 меню?

 

Простите за глупый вопрос, как помещать изображения и фото так как вы поместили?
dm02.jpg

Link to post
Share on other sites
vad0000
4 минуты назад, vladimir.songin сказал:

Простите за глупый вопрос, как помещать изображения и фото так как вы поместили?

Вы сначала загружаете файл с изображением, мышью выбираете поле, куда хотите вставить изображение, и мышью нажимаете на изображение.  

17 минут назад, vladimir.songin сказал:

Как я понимаю, хотите видеть ручное позиционирование без входа в 19 или 50 меню?

да

Link to post
Share on other sites
vladimir.songin
13 минут назад, vad0000 сказал:

Ось Х у Вас отключена?

На последней фотографии включена. 
Ось R слушается. Ось X нет. При выключенной оси X и при нажатии педали вниз, балка идет вниз.   При включенной оси X балка стоит. 
в сервисной строке после пробы инициализировать оси, cycle = -1. 

Link to post
Share on other sites
vad0000
5 минут назад, vladimir.songin сказал:

На последней фотографии включена. 

В этом режиме видно, что Х не инициализирована.

А этом режиме можно ось Х погонять колесиком?

Link to post
Share on other sites
vladimir.songin
1 минуту назад, vad0000 сказал:

В этом режиме видно, что Х не инициализирована.

А этом режиме можно ось Х погонять колесиком?

R можно

 

X нельзя. 

Только что, vladimir.songin сказал:

R можно

 

X нельзя. 

Даже после перезагрузки но без инициализации R можно. А X нельзя 

Link to post
Share on other sites
vad0000
41 минуту назад, vladimir.songin сказал:

Даже после перезагрузки но без инициализации R можно. А X нельзя 

Вообще любую механическую ось, можно погонять без инициализации.

 

Надо Вам посмотреть, при вращение колесика, идёт ли напряжение с DM02на сервопривод оси Х?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.




  • Сообщения

    • Пингвинчик
      Да, в 7.0 тоже есть в инфо эта строка. И при попытке добавить параметр "ptc_actual_pat_members" он пишет что тот зарезервирован.  Но на чертёж его вызвать невозможно, и в параметрах он не отображается (пытался через &ptc_actual_pat_members:FID_...)
    • kkk
      Благо в свойствах Солида появились уравнения, решил изменить записание Обозначения. Хотел сделать, чтобы при конфигурации 00 в обозначение шло бы только имя файла, при других конфигурациях - "имя файла"-"имя конфигурации".     Попробовал так: if ( $PRP:"SW-Имя конфигурации" = 00 , $PRP:"SW-File Name" , $PRP:"SW-File Name"-$PRP:"SW-Имя конфигурации"), пишет ошибка синтаксиса. Если во второй части подставить цифры, то работает, если буквы, то нет. Вот и думаю, это я что-то неправильно делаю, или функция IF работает только с цифрами?
    • zeppelin
      Только через инфо об элементе получилось узнать, но вытянуть через параметр, не нашел.
    • Пингвинчик
      Где? количества всех компонентов не вижу ни в одном массиве, только количество по параметрам (по 2 направлениям, по окружности и тд)   Выше массив по точкам, размеры вижу только позиционные для точек
    • 5axisCNC
      Такие радиуса я обычно делаю фрезой например ф10r0.5(с радиусом при основании 0,5 или 1) Zlevel  погружение по форме между уровнями, можно и Area mill
    • Black Rock
      Всем привет. Я не особо в теме, но когда то юзал учебную версию Тефлкс 2011. Теперь опять хочу вспомнить детство и для этого есть всё ещё живой Мак бук про 2015. Понимаю, что вопрос простой и поэтому может будет лучше послать меня туда где уже написано про мой случай. В общем хочу в торенте скачать Тефлекс 2011 учебный и установить на Макбук. Видимо для этого нужна будет винда 7 или симулятор 7й винды или что то, что бы Тефлекс можно было запустить на окаянном Макбуке. Пожалуйста подскажите пошагово, как мне снова стать счастливым.   
    • Ветерок
      Да ладно вам! Ещё в ПроЕ так делалось. Щелкаете на массив - отображаются его размеры: шаг и количество. Щелкаете на количестве - вот он. Можно посмотреть его имя, оно начинается с буквы p. И не надо искать ни по каким окнам.
    • zeppelin
      Да, такую возможность ввели в С10
    • Клиент
      Участок УП, где ошибка вылазит выложите
    • Пингвинчик
      Там выведен параметр массива со всеми подуровнями, так выглядит по умолчанию 
×
×
  • Create New...