Jump to content

Сброс прозрачностей в сборке (косячат)


3draven

Recommended Posts

Возникла странная проблема. Есть сборка. В ней часть деталей сделана прозрачными (в контекстном меню есть кнопка для этого, просто уточняю). Выделил все детали сборки с помощью ctrl+a и нажал ту же самую кнопку в дереве сборки, что бы вся сборка стала прозрачной (просто попробовать хотел). В результате сборка стала прозрачной. Потом отключил прозрачность и увидел то, что в приложении к посту. Прозрачность стала косячить в сборке. Такое впечатление, что наложились два противоречащих условия отрисовки элементов изображения. Как подобный косяк побороть?

 

solid 2014 sp4

post-42366-0-94754800-1404276262.png

Edited by 3draven
Link to post
Share on other sites


В режиме "перспективы" прозрачность работает нормально. В обычном режиме (ортогональном) не работает.

Link to post
Share on other sites
  • 6 months later...

Поднимаю тему снова так как нашел причину. Это баг в solidworks. Если в сборке сделать эскиз, в котором будет прямая вспомогательной геометрии, да еще бесконечной длинны, то как раз такое происходит с нормалями граней в модели и изображение летит к чертям. Стоит эту прямую удалить, и вуаля, все пашет. Почему так происходит я не выяснил, просто удалил злосчастную прямую.

Link to post
Share on other sites
  • 3 weeks later...

Да, в целом можно сформулировать правило. В сборке нельзя делать эскизы, только в деталях. Иначе будет вылазить эта проблема, даже без ранее описанных условий. Хорошо бы это испрвили, а то эскизы в сборке очень удобны для создания параметрических сопряжений.

Link to post
Share on other sites

Поставил solid 2015sp1.1 в нем проблему решили частично. Остался косяк при котором в такой ситуации при редактировании этих эскизов приближать камеру вида к ним нельзя. Эскизы пропадают. Отодвинешь вид подальше, появляются снова. Но хотя бы вышепоказаной ситуации нет пока.

  • Нравится 1
Link to post
Share on other sites
В сборке нельзя делать эскизы, только в деталях. Иначе будет вылазить эта проблема, даже без ранее описанных условий.

Частенько делаю (в сборке) эскизы для обработки деталей в сборе - никаких подобных косяков не замечал...

Может "косяк" в драйверах или в OpenGl, или ещё в чём??

Link to post
Share on other sites
Michael_Mira

С прозрачностью я замечал только один косяк: выбираешь деталь - кнопка "прозрачная", а прозрачной стает другая деталь. И сборке пофигу, есть там эскизы или нет.

Link to post
Share on other sites
  • 6 years later...
  • 1 month later...
Vladimir_k55

Доброго времени суток, уважаемые.

 

После установки SolidWorks 2021 начались такие проблемы (см. изображение): в сборке произвольные детали становятся прозрачными, но при этом они не приобретают свойства прозрачных деталей, т.е. не надо при выделении нажимать shift, как это было бы, если прозрачность задать вручную. Ctrl+B и Ctrl+Q помогают вернуть цвет, пока модель статична, начнешь вращать - прозрачность возвращается. Избавиться от такого глюка помогает, если закрыть всю сборку и снова открыть - все детали снова имеют цвет, но через какое-то время снова глюк возвращается, иногда на те же детали иногда на другие, короче произвольно выбирает.

 

До этого стоял SW2020 - такого не было, переустановили на SW2021 (сначала SP1 потом обновляли до SP2, SP3, SP4) - появился глюк в изображении и не важно сборка создана в последней версии и в старой. Переустановка Виндовс с чистой установкой Солида тоже не помогла. Такой глюк на двух ПК. Подскажите куда копать?

Image 062.jpg

Link to post
Share on other sites
Кварк

Краем уха слышал, что видеокарта может быть виной. Но это не точно.

Link to post
Share on other sites
Vladimir_k55
1 минуту назад, Кварк сказал:

Краем уха слышал, что видеокарта может быть виной. Но это не точно.

Ну тут было 2 варианта:

1. Солид 2021 стал глючить на тех же самых драйверах, на которых нормально работал 2020

2. При переустановки виндовс, поставили новые драйвера - результат не изменился.

 

На обоих ПК стоит Quadro P1000. Если для проверки поставить другую видеокарту (игровую например), что-то даст?

Link to post
Share on other sites
Кварк
4 часа назад, Vladimir_k55 сказал:

Ну тут было 2 варианта:

1. Солид 2021 стал глючить на тех же самых драйверах, на которых нормально работал 2020

2. При переустановки виндовс, поставили новые драйвера - результат не изменился.

 

На обоих ПК стоит Quadro P1000. Если для проверки поставить другую видеокарту (игровую например), что-то даст?

Попробовать же никто не мешает. Поставьте. Но я еще раз подчеркну, что сам не пробовал.  

Link to post
Share on other sites
sloter
4 часа назад, Vladimir_k55 сказал:

1. Солид 2021 стал глючить на тех же самых драйверах, на которых нормально работал 2020

Вполне возможно под 2021 заточили другой драйвер.

4 часа назад, Vladimir_k55 сказал:

2. При переустановки виндовс, поставили новые драйвера - результат не изменился.

Новые - не есть правильные. Надо ставить рекомендованный сертифицированный драйвер. Благо у Вас карта проф. и нужный драйвер можно найти на оффсайте.

 

4 часа назад, Vladimir_k55 сказал:

Если для проверки поставить другую видеокарту (игровую например), что-то даст?

Даст. Это поможет исключить проблему с текущей картой и/или её драйвером. Но быстрее будет запустить SW с опцией "Использовать программу Open GL" или такой же режим из под SW RX.

 

Edited by sloter
Link to post
Share on other sites
Kelny
5 часов назад, Vladimir_k55 сказал:

SolidWorks 2021

 

5 часов назад, Vladimir_k55 сказал:

Подскажите куда копать?

Может быть проблема как в видеокарте, так и в самих моделях при преобразовании в новую версию. А так же бывают проблемы из-за обновлений Windows, так что может быть что угодно.

Что бы исключить железо и драйвер, как уже написали выше галочка OpenGL или тоже самое через SolidworksRX

http://help.solidworks.com/2021/russian/solidworks/sldworks/c_graphics_adapters_drivers.htm

http://help.solidworks.com/2021/russian/solidworks/sldworks/c_solidworks_rx.htm

5 часов назад, Vladimir_k55 сказал:

стоит Quadro P1000

 

5 часов назад, Vladimir_k55 сказал:

1. Солид 2021 стал глючить на тех же самых драйверах, на которых нормально работал 2020

Рекомендуют другие драйверы для новой версии, в зависимости от системы:

https://www.solidworks.com/support/hardware-certification/

 

Link to post
Share on other sites
Vladimir_k55
17 часов назад, sloter сказал:

Надо ставить рекомендованный сертифицированный драйвер. Благо у Вас карта проф. и нужный драйвер можно найти на оффсайте

Пока с сисадмином решили переустановить драйвер, скачали рекомендованный. Т.к. глюк проявляется рандомно, сначала проверю версию с драйвером. Всем спасибо за советы, дальше буду тестировать программу, согласно рекомендациям

Link to post
Share on other sites
Kelny
9 часов назад, Vladimir_k55 сказал:

Всем спасибо за советы, дальше буду тестировать программу, согласно рекомендациям

Не забудьте сообщить о результатах, вашим последователям будет интересно.

Link to post
Share on other sites
Vladimir_k55

Почти за неделю проверки, прозрачность пока не появлялась, это уже хорошо. Но сразу в тему (или нет) вот что еще хотел спросить:

При выделении какой либо детали в графической  области обычно выскакивает всплывающая панель (см правую часть рисунка), но есть такой косяк, что при выделении рядом расположенных деталей, эта панель сразу гаснет (см левую часть рисунка). Тут иногда помогают Ctrl+B или Ctrl+Q или просто повернуть модель под другим углом, но не всегда.

 

Также в последних версиях солида появилась возможность быстро назначать сопряжения в графическом окне, посредством выделения граней деталей через Ctrl - также всплывает эта панель с основными сопряжениями. Так вот, при нажатии Ctrl, опять же не всегда выскакивает эта панель, а если выделять грани в графическом окне через Shift - то панель появляется всегда. Если выделять плоскости деталей нажатием Ctrl в дереве построения - то тоже панель появляется всегда. Ctrl не корректно работает в графическом окне.

Все это также связано с видеокартой? Или это что-то новое?

Image 003.jpg

Link to post
Share on other sites
Snake 60

@Vladimir_k55 Просто не дергайте резко мышкой при втором клике. Делаете второй клик и отпускаете Ctrl.

Link to post
Share on other sites
  • 3 months later...
Simlion

Несколько дней назад на рабочем месте установили Solidworks2021 и тоже в сборках возникла проблема с прозрачностью рандомно у моделей в основном импортированных. Решилась на данный момент проблема отключением отображения исправленных моделей в разделе вид. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...