Jump to content

FANUC - ошибки, послания, сигналы - ALARM & MESSAGE


GGarry

Recommended Posts



13 часов назад, gudstartup сказал:

@VldLg А если у вас простой вариант тогда проверьте  для начала питание и состояние соответствующих светодиодам  выходов Y. 

 

Это надо в Ладдере смотреть или вольтметром проверить на шлейфах? Там два плоских шлейфа еще идет на плату ввода-вывода. Меня начинают терзать смутные сомнения что что-то с ними. А еще больше напрягает то, что станок работал с мигающими лампочками больше года и перестал :( и ошибок никаких не выдает, как будто так и задумано. Вот что значит старое оборудование... Оно конечно хорошее, но старое.

Link to post
Share on other sites
gudstartup

@Viktor2004 Забыл сказать что еще у этой доп платы в пульте оператора есть функция запоминания состояния кнопок и после выключения станка пульт помнит состояния кнопок SBK M01 Z LOCK и т.д. на этом ее полезные свойства заканчиваются.

24 минуты назад, VldLg сказал:

Это надо в Ладдере смотреть

Лучше в STATUS там больше сигналов сразу видно но я конечно сомневаюсь что у вас там будет что то моргать можете также выбрать отдельный выход который идет на лампочку  и посмотреть в функции trace там будет более наглядно видно состояние вашего моргающего выхода. Я думаю что дело все таки в соединениях и плохих контактах 

или с питанием что то не так

31 минуту назад, VldLg сказал:

как будто так и задумано.

Это вряд ли.

Link to post
Share on other sites

Проверил Ладдер. Вроде все кнопки работают, произвольно нажатых нет. Игрики горят так как надо. Лампочки -не совсем, но в основном более менее. Куда копать дальше пока не понятно. 

Link to post
Share on other sites
gudstartup
10 минут назад, VldLg сказал:

Лампочки -не совсем, но в основном более менее.

А чего же моргает и что значит более менее?

13.01.2022 в 23:45, VldLg сказал:

можно было маховичком подвигать, а сейчас это все не работает

То есть в режим HANDLE (маховичка) стойка переходит а вот разрешения на движения осей нет?

А что у вас на экране POS перед именами осей нет ли буковки I (Interlock)?

Link to post
Share on other sites
7 минут назад, gudstartup сказал:

А чего же моргает и что значит более менее?

2-3 светодиода могут гореть или не гореть, если на них приходит сигнал. Но такого чтобы что-то горело без сигнала -такого нет. Похоже на контакты в шлейфах от платы расширения до панели оператора. Светодиоды подключены последовательно с резисторами. Похоже токи маленькие, вот и поокислялось кое-где. Сейчас сниму шлейфы, посмотрю на них внимательно.

Edited by VldLg
Link to post
Share on other sites
gudstartup

@VldLg

13 минут назад, gudstartup сказал:

у вас на экране POS перед именами осей нет ли буковки I (Interlock) блокировка движения осей?

 

Хотя может быть и контакты маховичка тоже окислились..:g:@VldLg

Link to post
Share on other sites
Viktor2004
1 час назад, gudstartup сказал:

контакты маховичка тоже окислились

Надо посмотреть что в параметре 12300

потом открыть в STATUS икс с этим значением и покрутить маховичок.

Счетчик импульсов должен считать

Link to post
Share on other sites
gudstartup
23 минуты назад, Viktor2004 сказал:

Счетчик импульсов должен считать

Это видно даже в диагностике в параметре nc pulse

Если есть импульсы с маховичка то На экране POS  приращение импульсов также отображается даже в том случае если ось физически не перемещается

Link to post
Share on other sites

Снял я таки эти платы снова. Предистория такая -вытянул шлейфы, воткнул снова -лампочек уже меньше светится, еще и кнопки некоторые работать перестали. Я немного обрадовался. Включил положение, когда должна гореть нерабочая кнопки и померял напряжение,которое она должна передавать на светодиод. Показало 24в, что ок. На плате кнопок я пдлезть к контактам не сог и все это дело снял. Собрал на столе и как ни странно цепь отлично звонится от платы расширения до светодиода. Светодиод я тоже проверял. Он рабочий. Я что-то в полном замешательстве. Может шлейф где-то переломлен и в этом положении работает, а в том что на станке нет... думаю перебить контакты. Больше мыслей пока нет. Но все равно, мне кажется что то что станок никуда не едет это не вина платы расширения.

20220115_192626.jpg

Link to post
Share on other sites
gudstartup
14 часов назад, VldLg сказал:

Но все равно, мне кажется что то что станок никуда не едет это не вина платы расширения.

Посмотрите идут ли импульсы с маховичка и нет ли блокировки осей PMC

Какие именно лампочки у вас моргают моргают ли они на неактивных выходах Y?

Я думаю что моргают только активные.

Link to post
Share on other sites

Да, моргают только активные, да и то не  то чтобы моргают, то загораются то тухнут. Светодиод кнопки ×10 вообще не загорается, хотя  соответствующий выходной сигнал активен. Светодиод MDI может гореть или не гореть, но все последующие процедуры вроде выполняются после того как соответствующий сигнал Y становится активен в ладдере. У меня подозрение на то что надо шлейфы перебить.

Было еще пару моментов, которые предшевствовали поломке. Первый - это когда в режиме редактирования у меня из программы удалился не один символ, как я хотел а группы строк, при чем не подряд, а двумя группами. Я был немного уставший, и не придал этому особого значения. Просто дописал то чего не хватало и все. Но конечно сильно удивился. Переписал на всякий случай программу на DNC устройство и продолжил, не вынимая кабеля из разъема rs232. На следующий день станок в процессе отладки программы, находясь в режиме MDI сам переключился в режим EDIT и больше ни на что не реагировал. Даже перезапуск станка ничего не изменил. Я случайно отсоединил разъем rs232 и станок начал нормально работать. Но радость моя была не долгой. Через минут 30 глюк с переключением в режим EDIT повторился. После этого я снял и помыл спиртом плату оператора. И перестали ездить оси. Может какое-то логическое реле не переключилось, я не знаю. Для меня это пока черный ящик, но думаю придется разбираться. Например когда станок смазывается он останавливается, если конечно не находится в состоянии рабочей подачи. Но это 20 секунд...

Если бы это был мазак, я бы подумал что надо сделать инициализацию параметров, но это все-таки фанук.

Link to post
Share on other sites
Viktor2004
12 минут назад, VldLg сказал:

Я случайно отсоединил разъем rs232 и станок начал нормально работать. Но радость моя была не долгой. Через минут 30 глюк с переключением в режим EDIT повторился.

Вот с этого места поподробнее.

Вы работаете с постоянно воткнутым кабелем rs232 ?

Разъем rs232 включаете-выключаете на включенном станке?

Компьютер с которого передаете программу находится рядом со станком ил далеко?

На каком расстоянии?

Этот компьютер включен в розетку с заземлением или без?

Пробовали работать с выключенным rs232 ?

Что касается rs232, я видел как эти платы rs232 горят как на станке так и на компе. Особенно когда их включают на "горячем" оборудовании. Если комп не заземлен третьим контактом розетки, на его корпусе появляется потенциал 120В за счет конденсаторов блока питания. Этот потенциал оказывается на корпусе разъема rs232 который на "горячем" оборудовании пытаются включить в станок. И тогда в момент включения, в момент касания станочного разъема rs232 происходит уравнивание потенциала иногда с искрами. Так сгорают платы. Правда видел я такое не на Fanuc, а на Legacy, но принцип один. Проверьте функциональность вашего оборудования без разъема rs232.

Link to post
Share on other sites
gudstartup
49 минут назад, Viktor2004 сказал:

Проверьте функциональность вашего оборудования без разъема rs232.

Возможно где-то нет заземления либо на станке либо на компьютере отсюда все эти чудеса.

Link to post
Share on other sites

Этот блок DNC питание получает по тому-же кабелю RS-232. Его можно подключить и через внешний блок питания, но перый глюк с перключением в режим EDIT произошел когда никакого внешнего подключения небыло и разъем RS-232  был пуст. Пока я думал что делать глюк пропал, но появилось сообщение о севшей батарее в одном из усилителей, батарею я поменял и подумал что возможно это и было причиной, хотя скорее всего просто совпало. В тот день больше глюков небыло и станок нормально день отработал. На станке осталась только одна батарейка, которая не менялась - та что стоит в стойке. Не может ли в ней быть причина? Третий год уже пошел...

Фото не моего блока, но у меня точно такой-же.  Он по прежнему работает с станком  и файлы как передает так и принимает . Ничего не поменялось.

DNC_Tytan.jpg

Edited by VldLg
Link to post
Share on other sites
Viktor2004

Меня один раз вызывали на такую ситуацию, где станок самопроизвольно переключался в режим Handle. Даже в процессе выполнения программы.

Там все оказалось просто. Логика была прописана так, что он переключался в Handle всякий раз когда на выносном пульте нажимаются две кнопки блокировки пульта. Ну, те самые, которые надо держать что бы оси двигались с открытой дверью. Так вот оператор замотал эти обе кнопки изолентой, что бы не держать их в нажатом состоянии. Изолента со временем ослабла и кнопки находились на гране срабатывания и стали самопроизвольно  срабатывать.  Я уже не помню какой G-сигнал переключает эти режимы

  • Нравится 1
Link to post
Share on other sites
gudstartup
2 часа назад, VldLg сказал:

Не может ли в ней быть причина? Третий год уже пошел...

Появилось бы сообщение об ошибке или  слетело статическое ОЗУ в зависимости от того в какой момент выключить станок! Она ни коим образом не влияет на перемещение осей. Вы так и не ответили у вас есть импульсы от маховичка CNC их считывает? 

  • Нравится 1
Link to post
Share on other sites
gudstartup

Проверьте состояние этих сигналов

All axes Interlock signal
*IT<G008#0 если = 0 то оси блокированы.

Interlock signal for each
axis
*IT1 - *IT8<G130#0-G130#7>

Вас интересуют  X,Z G130#0 G130#1

 

  • Нравится 1
Link to post
Share on other sites
53 минуты назад, gudstartup сказал:

 Вы так и не ответили у вас есть импульсы от маховичка CNC их считывает? 

Я обязательно отвечу, но сегодня воскресенье... В этот день я не подхожу к станку, иначе жена перестает мне готовить :)

Edited by VldLg
  • Нравится 1
  • Хаха 1
Link to post
Share on other sites
44 минуты назад, gudstartup сказал:

Проверьте состояние этих сигналов

All axes Interlock signal
*IT<G008#0 если = 0 то оси блокированы.

Interlock signal for each
axis
*IT1 - *IT8<G130#0-G130#7>

Вас интересуют  X,Z G130#0 G130#1

 

Извините за глупый вопрос, а где то смотреть? в параметрах или в ладдере? Я так понмаю что # - это биты в параметрах?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Сообщения

    • Udav817
      Вот человек, который тут выше картинки в шакальном качестве выкладывает последние 2 страницы, думает, что тут вообще надо членомерством заниматься, а не обсуждать и советоваться.
    • Udav817
      Делайте в SW или NX. Скругления с 12 версии правят, всё никак исправить не могут. Уже ядро поменяли, а толку-то?
    • Борман
    • статист
      Чет у меня только кончик в разнос пошел. Посчитал с большими перемещениями.   Перемещения общие   Напряжения Мизес
    • kapitalizm
      Какие жаркие дебаты разгорелись в теме... По делу 10%, остальное - флуд. А всего лишь хотелось советов получить от опытных коллег по цеху. В итоге большинство советов - не браться за это дело, либо предложения своих услуг в разработке. Спасибо тем кто реально помог советом, хотя таких было не много. Честно говоря не понимаю местных форумчан, которые с такое неохотой показывают свои чертежи или показывают их в таком разрешении, что разглядеть там что-либо практически невозможно. Неужели Вы думаете что кто-то "украдёт" Ваш комплект КД и слепит по нему такую же форму? Вряд ли здесь на форуме сидят директора /хозяева предприятий в поисках "халявной" документации на пресс-форму. Сидят здесь такие-же нищеброды-конструктора как я и как все остальные. Какова вероятность того что кому-то кроме Вас пригодится Ваша пресс-форма? 0,01%? Или ещё меньше? Или боитесь что Ваша КД будет использована как образец для похожих изделий? Ну так в интернете в принципе можно легко скачать и модели и чертежи на различные пресс-формы для образца от которого можно "отталкиваться". Скажете что выложенным в интернете моделям и чертежам доверять нельзя, не факт что это рабочие проекты? Согласен. Ну так и выложенным здесь чертежам также нельзя доверять, никто здесь не знает друг-друга достаточно хорошо с профессиональной точки зрения. Мне кажется что здесь обитают коллеги, с которыми можно посоветоваться, а не конкуренты по цеху.
    • soklakov
      Чет есть подозрение, что считать работу от силы на перемещении, которое получено поворотом жесткого целого - так себе затея.
    • soklakov
      я имел в виду именно скриншоты. а еще я про свойства материалов. Для симулейшена Вы привели, правда не скриншотом, а в Акробате? это из СВ?
    • vad0000
    • hayabusa
      От платы в ЧПУ идут два провода с такими разьемами Провели эксперимент Подаем питание, на плате горят две красных лампы. Это все. --- Отбрасываем шлейфы. Никаких изменений не происходит. Одно условие - вынимаем планку памяти. Получаем зуммер 1-3-3-1. --- Пробовали подключать VGA монитор в разъем на плате. Ничего. BIOS наверно не стартует.
    • konstryktor_press
      успокойтесь))) кроме ругани,других аргументов нету видимо))_)
×
×
  • Create New...