Jump to content
Sign in to follow this  
Maxim Vas

На Windows Xp Intralink возможно поставить?

Recommended Posts

Maxim Vas

На Windows XP Intralink возможно поставить (включая oracle fileserver, dataserver) ????

Share this post


Link to post
Share on other sites


Half

только клиент на Windows XP Professional - SP1

Share this post


Link to post
Share on other sites
suslad

На Windows XP Intralink возможно поставить (включая oracle fileserver, dataserver) ????

<{POST_SNAPBACK}>

Можно. У меня так работает. Пока проблем не обнаружил.

PS Понимаю что это не есть "харашо". Если уж начинать использовать Pro/INTRALINK реально то необходимо следовать рекомендациям PTC.

Share this post


Link to post
Share on other sites
Maxim Vas

Все поставил, ура! Спасибо.

Теперь передо мной окно INtralink'a, где все серое, кроме Login и Lauch Pro/E. Какое имя вводить? Или надо сначало этого юзера как-то завести??? Все доки, что у меня есть начинают работу с этого самого Login, но как залогиниться??????? :surrender:

Share this post


Link to post
Share on other sites
Basnev

но как залогиниться???????

Если не получается с седьмого раза - читай инструкцию... :smile:

user/passw: INTRALINK/INTRALINK :wallbash:

ps: еще полезно:

system/manager

dschangeme

fschangeme

etc...

Share this post


Link to post
Share on other sites
Maxim Vas

При любом login'e и пароле выдает:

Oracle connect failed while loading Pro/Intralink schema. The client has failed to connect to the Data server. :sad:

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

Сервисы необходимые все запущены? Там не все автоматом.. :rolleyes:

И ведь что интересно - в инструкции все написано... :wallbash:

Share this post


Link to post
Share on other sites
Maxim Vas

Все сервисы запущены :wallbash:

Я установил INtralink и Dataserver и Fileserver, запускаю Intralink Client, ввожу INTRALINK/INTRALINK - в итоге получаю сообщение:

"Oracle connect failed while loading Pro/Intralink schema. The client has failed to connect to the Data server"

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

А проверьте. В командной строке введите:

dbshut_ilink. Если служба запущена, она остановится с соответствующими сообщениями, а если не запущена, значит...НЕ

Все сервисы запущены

:rolleyes:

Share this post


Link to post
Share on other sites
suslad

Удалить файлы SQLNET.ORA из ptc\proiclient и ptc\dataserver\oracle\network\admin, и перезапустить сервисы oracle.

Share this post


Link to post
Share on other sites
Maxim Vas

Когда я ставил oracle с помощью ORACLE INSTALL ASSISTANT патч до версии 9.2.0.4.0 я ставил вручную, т.е. я запустил ASSISTANT указал пути к дискам с 1 по 3 для ORACLE 9.2.0.1.0 а когда он потребовал путь к патчу - мне не удалось заставить его скушать этот путь, причем какие я только пути не указывал..... поэтому пришлось прервать работу ассистента и пропатчить вручную (причем вручную патч отлично работает). Может дело в этом?????

Share this post


Link to post
Share on other sites
Maxim Vas

P.S. SQLNET.ORA - удалял - не помогло

dbshut_ilink - работает

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

dbshut_ilink - работает

Значит dbstart_ilink тоже работает? Он у вас сам стартует или вручную запускаете? Проверьте корректность файла ...\dataserver\untralink\intralink.new

Share this post


Link to post
Share on other sites
SHARit

Еще два момента:

1. Попробовать поменять

строчку в файле sqlnet.ora в директории .........\oracle\network\admin

с

sqlnet.authentication_services=(NTS)

на

sqlnet.authentication_services=(NONE)

2. Проверить имя host-а Data Server в строчке:

"<Host= <hostname>) #Hostname"

в файле tnsnames.ora в директории, где установлен клиент.

Share this post


Link to post
Share on other sites
Maxim Vas

в этих файлах все прописано.

У меня версия Intralink'a F000, а у PRo/E тоже F000, товарищ SHARit прислал ссылку на таблицу совместимости, на сколько я понимаю они не совместимы или я ошибаюсь????

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

Так в таблице совместимости они совместимы?

Еслм да, то да!

Если нет, то нет!

:doh:

Share this post


Link to post
Share on other sites
Maxim Vas

но даже если они в таблице не совместимы, то он по идее должен запускаться хотя бы отдельно :g:

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

то он по идее должен запускаться хотя бы отдельно

Отдельно он запускается вне относительно, какой Прое установлен на компе...

А что, по-прежнему не запускается?

Каких-нибудь файлов про ошибки привели-бы что-ли. Он должен логи и ерроры писать в текущую директорию. Есть что-нибудь?

Share this post


Link to post
Share on other sites
Maxim Vas

логов об errora'х нету, когда запускаю клиента - говорит, что dataserver или host не запущен (я вообще ставлю все на один компьютер). Как можно проверить запуен ли dataserver , в службах работают оракаловские службы и fileserver. :sad:

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

Так наберите из командной строки: dbstart_ilink....

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

Как можно проверить запущен ли dataserver

Можно так проверить:

Запустить "svrmgr23".

В подсказке набрать "connect internal/internal".

Если после выводится строка "connected to idle instance" DataServer не запущен.

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

У меня сильное подозрение, что что-то не так при установке было.

Вот инструкция по установке Dataserver.

Я бы переставил заново все...

Installing_Bundled_Pro_INTRALINK_3_4_F000_Data_Server.zip

Share this post


Link to post
Share on other sites
suslad

Похоже что вы некорректно выставили настройки хостов. Поэтому:

1. Проверьте хост на котором работает сервер.

2. Проверьте хост к которому подключается клиент.

3. Сравните результаты.

Share this post


Link to post
Share on other sites
Maxim Vas

когда пользуюсь этим самым Ассистентом - то при установке ORACLE 9.2.0.1.0 все в порядке, но далее установку приходиться прерывать, т.к. ассистент не хочеть принимать путь Patch'a 9.2.0.4.0 , поэтому патч я ставлю вручную самостоятельно без его помощи (патчится отлично).

Где можно посмотреть настройки хостов?

Share this post


Link to post
Share on other sites
Half

Maxim Vas

А если патч на RW записать?

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

После установки патча надо было вручную переименовать

файл <oracle loadpoint>\network\admin\sqlnet.ora в sqlnet.ora_oracle.

Делали?

Share this post


Link to post
Share on other sites
Maxim Vas

переименовал сейчас - результата нет

Share this post


Link to post
Share on other sites
SHARit

Maxim Vas

Переменные среды:

ORACLE_HOME

ORACLE_SID

установлены?

В переменную path путь <Oracle Loadpoint>\bin добавлен?

У вас ваще инсталэйшн гайд е? :rolleyes:

Edited by SHARit

Share this post


Link to post
Share on other sites
Maxim Vas

вот,

гайд есть, все сделал вроде по нему

post-2311-1097242646_thumb.jpg

Share this post


Link to post
Share on other sites
Basnev

Только что поставил 3.4 на XP-P russian.

Абсолютно никаких проблем. :g:

Share this post


Link to post
Share on other sites
Maxim Vas

сдается мне, что это патч какой-то нетакой.

2 Basnev : Сколько весит папка с патчем (в байтах) и какова внутри структура каталогов и файлов??

Share this post


Link to post
Share on other sites
Kostya_

Промучился 10 рабочих дней, но все-таки поставил Intralink 3.0 под WinXP SP2 rus.

Вдруг кому это чем-то поможет, поделюсь, тем более, что вопросы остались.

Утановка непосредственно под WinXP затыкается, когда Setup пытается Create Oracle Services (и висит бесконечно).

Поэтому ставлю Intralink 3.0 под Win2K без проблем, все работает, затем набрасываю WinXP поверх. Дальше самое интересное.

После первой перезагрузки служба OracleServiceilnk стартует нормально, и все работает.

Но после последующих перезагрузок служба OracleServiceilnk НЕ стартует (в состоянии запуск висит, пока не кончится отведенное на запуск время). Но при этом в диспетчере задач возникают новые процессы, и если навести курсор на процесс ORACLE.EXE и "завершить дерево процессов", то все последующие запуски/остановки службы OracleServiceilnk оказываются успешными, и Intralink работает.

Вот так и мучаюсь после каждой перезагрузки: запускаю службу OracleServiceilnk, снимаю дерево процессов ORACLE.EXE, снова запускаю службу OracleServiceilnk.

Обнаружил следующие глюки:

1. На других машинах сети, где Intralink 3.0 Client ставился под WinXP, не работает режим Integrate.

2. Chekin новых файлов иногда идет только после того, как они побудут в Workspace какое-то время, каждый раз разное, от 1 до 40 мин. Может быть, WinXP в этом не виноват, просто сам Intralink где-то не настроен?

3. Intralink 3.0 Client иногда (не всегда :sad: ) зависает при старте, но естли задачу закрыть и повторить запуск (как правило не более 4х раз), то все нормально.

Но вот чего никак не пойму, может кто подскажет: почему же после перезагрузки сразу после установки WinXP (или фиктивной установки SP2, который итак встроен в WinXP SP2) служба OracleServiceilnk запускается без проблем с первого раза, хоть Вручную хоть Авто? Чем же отличается режим WinXP, в котором она оказывается сразу после первой перезагрузки?

Edited by Kostya_

Share this post


Link to post
Share on other sites
SVS

Посмотри в Task Manager сколько "съел" памяти oracle.exe.

Должно быть что-то около "90 000 Kb"

Share this post


Link to post
Share on other sites
Kostya_

>>SVS:"Посмотри в Task Manager сколько "съел" памяти oracle.exe.

>>Должно быть что-то около "90 000 Kb""

Когда OracleServiceilnk зависает, процесс ORACLE.EXE съедает 7056 Kb, а когда стартует нормально - около 50 000 Kb.

Не совсем понимаю, как это может помочь для стабильного запуска OracleServiceilnk с первого раза. Но все равно спасибо за отклик.

Edited by Kostya_

Share this post


Link to post
Share on other sites
SVS

Чтобы oracle зпускался нормально попробуй поменять в

oracle\network\admin\sqlnet.ora

c

sqlnet.authentication_services=(NTS)

на

sqlnet.authentication_services=(NONE)

Попробуй запустить proimgr.bat и соедениться с сервером

Имя/Пароль

Для интралинка - INTRALINK/INTRALINK

Для датасервера system/manager

посмотри какую выдает ошибку.

Share this post


Link to post
Share on other sites
Kostya_

Чтобы oracle зпускался нормально попробуй поменять в

oracle\network\admin\sqlnet.ora

c

sqlnet.authentication_services=(NTS)

на

sqlnet.authentication_services=(NONE)

Обнаружил, что в oracle\network\ADMIN\ файл sqlnet.ora у меня отсутствует (там только listener.ora и tnsnames.ora). Но в oracle\network\ADMIN\SAMPLE есть образцы всех трех файлов sqlnet.ora listener.ora tnsnames.ora. Почему нет sqlnet.ora - не понимаю. Но раз его нет, то по идее все параметры берутся по умолчанию, а в образце sqlnet.ora написано, что по умолчанию sqlnet.authentication_services=(NONE).

Попробуй запустить proimgr.bat и соедениться с сервером

После запуска proimgr.bat в Data Server Management Utility выбираю Server > Start Up Server, и OracleServiceilnk стартует с первого раза :smile:(поэтому еще раз спасибо за отклик, все же это хотя и вручную, но не так криво, как завершать дерево процессов).

Правда, после Start Up Server сама Data Server Management Utilitа зависает, но если ее закрыть и запустить снова, то Server > Connect Dataserver и Server > Connect Intralink Admin после ввода паролей ошибок не вызывают, все пункты меню активны.

Edited by Kostya_

Share this post


Link to post
Share on other sites
SVS

А с клиента на этой машине войти в сервер не получается?

Share this post


Link to post
Share on other sites
suslad

1. На других машинах сети, где Intralink 3.0 Client ставился под WinXP, не работает режим Integrate

<{POST_SNAPBACK}>

Смотрите таблицу совместимости для версий Pro/E и Pro/I на сайте www.ptc.com

2. Chekin новых файлов иногда идет только после того, как они побудут в Workspace какое-то время, каждый раз разное, от 1 до 40 мин. Может быть, WinXP в этом не виноват, просто сам Intralink где-то не настроен?

3. Intralink 3.0 Client иногда (не всегда ) зависает при старте, но естли задачу закрыть и повторить запуск (как правило не более 4х раз), то все нормально.

<{POST_SNAPBACK}>

Настроек относительно взаимодействия с клиентами на сервере нет. Здесь надо анализировать трафик в сети. Похоже в ней проблемы.

Share this post


Link to post
Share on other sites
Finist

Хм, для начала я бы попробовал поставит Ilink 3.3 или 3.4 ... Пожалуй что эти релизы постабильней будут. Всего-то делов, купить техподдержку, обновить лицензию, скачать (ну или заказать диэйчэлем) свежий релиз ну и поставить наконец.

Кстати вопрос : кто работает с Ilink 8, как он в сравнении-то ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
  • Recently Browsing   0 members

    No registered users viewing this page.



  • Сообщения

    • piden
      Это все равно, что в соседней теме про молниевод сказать, что раз вихри с цилиндра срываются поочередно с каждой стороны, то и средняя боковая нагрузка = 0. Оно-то да, если по времени осреднить, но кому такое решение нужно?
    • karachun
      Это не наш метод, тем более что сетка все равно не очень большая. Это чтобы с запасом, по Идельчику для трубы нужно 50-100 диаметров для турбулентного течения и 150 для ламинарного течения. Да, эффект Коанды. Но, возможно, на разных сетках струя будет вести себя по разному, и в некоторых случаях прилипать не будет. опять же в реальной конструкции струя может прилипать к разным частям трубы в разные моменты времени и среднее значение все равно будет "осесимметричным".
    • piden
      Стабильно... но очень долго)    Пропиши в Execute commands /dis sw 3 /dis obj dis cont - отобразить contour-1 в окне 3. Чтобы выполнялась каждые, скажем, 20 итераций - и посмотри за эволюцией осевой скорости во время счета для SIMPLE/SIMPLEC... Как-то эта сетка стремно выглядит.. Если хотелось развитого профиля потока после входа - то лучше было бы профиль отдельно посчитать и задать на входе. И ощущение, что для выхода тоже слишком длинная область.   И еще, на заметку: в CFD симметрия геометрии и ГУ далеко не всегда означают симметрию течения. Для данной задачи (определения расхода) это может быть и не важно, но те картинки результатов для полной области, которые демонстрировал ТС в самом начале, с прилипанием струи к стенке - абсолютно физичны.    
    • karachun
      @MotorManiac @piden Еще странно что такая скромная сетка строиться минут десять на двух ядрах. Я ожидал что такая сетка будет строиться пару десятков секунд. Может я выбрал не оптимальные методы построения. Я с чем-то похожим сталкивался когда мешил геометрию состоящую из множества параллелепипедов сперва выбрал Мультизон и сетка строилась с черепашьей скоростью. Потом, когда перешел на Свип сетка начала строиться со свистом, на порядок быстрее.
    • MotorManiac
      странно, как такое может быть
    • karachun
      @piden действительно, перестроил сетку, потыкал в узлы и некоторые провалились под ось.
    • piden
      Там самое важное - ворнинг о том, что есть узлы ниже оси Х. Сейчас попробую исправить.
    • karachun
    • MotorManiac
      @karachun   После проверки сетки, если есть ошибки то можно воспользоваться TUI командами /mesh/repair-improve/repair Собственно флюент сам это предлагает сделать, можно просто скопировать в консоль строчку без точки на конце.
    • karachun
      А не могли бы подсказать на какую кнопку жать, а то я о такой команде первый раз слышу.
×
×
  • Create New...