Jump to content

Ошибка при сохранении в DWG


Recommended Posts

Kirteas

Добрый день всем, помогите. Сделал объект в SolidWorks, жму "создать чертёж из сборки" и выношу вид сверху в масштабе 1 к 1. Жму "сохранить как", указываю DWG, после грузит и выдаёт ошибку:

"Произошла ошибка при создании точной геометрии для следующих чертёжных видов. Они могут быть пустыми"

 

Всё, дальше я не знаю что делать, чертёж в DWG пустой. Мне точность не нужна. Вид он нормально отображает в Solid'e, так и надо, чтобы сохранил.

P.S. паника началась, объект через неделю сдавать, мне ещё чертежи оформлять в Автокаде, прежде надо виды все сохранить, а он не сохраняет.

Link to post
Share on other sites


UnPinned posts
brigval

Скриншоты не хотите показать? Может, несколько...

Link to post
Share on other sites
Kelny
3 часа назад, Kirteas сказал:

Сделал объект в SolidWorks, жму "создать чертёж из сборки" и выношу вид сверху в масштабе 1 к 1.

Попробуйте сохранить чертёж, а потом уже сохранять дальше.

 

3 часа назад, Kirteas сказал:

Жму "сохранить как", указываю DWG

В принципе одно и тоже, но попробуйте DXF, а так же поиграться с выбором версии сохранения и других параметров по кнопке ПАРАМЕТРЫ... в окне сохранения/экспорта.

Не уверен, но возможно, так же можно попробовать через Adobe Illustrator и его в AutoCAD.

 

Как решите проблему, не забудьте сообщить о том как этого добились!!! Что бы на форуме остался не только вопрос, но и ответ на него!

 

 

 

Link to post
Share on other sites
Kirteas

В общем не получается сохранить, даже в другие форматы.

Есть вариант этой работы, который я сохранял на середине, когда делал. Там многое не сделано.

Если его беру и сохраняю, то всё нормально сохраняет в dwg.

 

Так и не могу решить в чем проблема. После сохранения этого чертежа, сохраняется только рамка, а сам чертёж из моделей нет.

2.jpg

2.jpg

Link to post
Share on other sites
Slavdos

настройки сохранения посмотрите

впечатление что у вас стоит экспорт высокого качества

 

Link to post
Share on other sites
Kirteas

В общем нашёл в чём был косяк. Сперва решил попробовать методом исключения проверить, что и помогло найти причину.

1) Разбил всю сборку на подсборки (шт 10);

2) Каждую подсборку сохранил отдельно в папку, как сборку;

3) Открывал каждую сборку отдельно и переводил в чертёж, затем "сохранить как DWG", всё нормально сохраняло;

4) Не сохранило 2 сборки из 10 шт. Выскочила та же ошибка.

5) Проблема заключалась не в самой программе, а в 2ух моделях, которые я добавил в первую и вторую сборки.

Этой моделью оказался предохранительный клапан, модель которого я скачал с сайта фирмы "АДЛ" - Прегранн 095.

Вот так он выглядит, пол тела не распознал Solid, когда я добавлял его из формата dwg:

image.jpg

 

 

P.S. часто приходится скачивать модели в формате dwg либо step.

Может кто сталкивался с подобной проблемой и знает, как правильно распознавать модели, чтобы не было таких вот багов?

  • Нравится 1
Link to post
Share on other sites
jtok

Модели беру в основном отсюда: https://b2b.partcommunity.com/

Стараюсь качать в STEP

После импорта разрываю связь и делаю Исправление геометрии.

Скрытый текст

2.jpg

Скрытый текст

1.jpg

Если в геометрия исправлена, таких глюков не должно быть.

  • Нравится 2
Link to post
Share on other sites
Plumber

В любом случае чужие модели, перед использованием необходимо проверять на ошибки геометрии.

  • Нравится 1
Link to post
Share on other sites
Kirteas

@jtok @Plumber , господа товарищи, не знал, спасибо большое.

Надеюсь, этого достаточно для нормального добавления моделей - "Разъединить элемент>Диагностика импортирования".

 

 

Ещё вопрос встречный, всегда лучше "разрывать связи" ? Любую модель, которую импортирую?
Что это даёт?

Link to post
Share on other sites
jtok
3 часа назад, Kirteas сказал:

всегда лучше "разрывать связи" ? ...Что это даёт?

Ну если вам нужна связь, то оставляйте.

Например, кто-то в компасе чертит аппарат, а вы в солиде делаете этому аппарату опоры. И этот кто-то постоянно меняет модель аппарата. Обменяться с компасом можно через степ. Тогда вы вставляете его модель и рисуете свои опоры. В очередной раз, когда чувак с компаса выгрузит ее, у вас просто импортированная модель обновится. Разрывать связь не надо.

 

Другой случай, если вы скачали клапан какой-нить с каталога - связь держать смысла нет, клапан больше не изменится - разрываете связь.

  • Нравится 3
Link to post
Share on other sites
Plumber

И еще, если не разрывать связи, то диагностика и редактирование не работает. У меня по умолчанию 3D Interconnect выключен.

  • Нравится 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.




  • Сообщения

    • IgorT
      Понятно. Аргументов у тебя больше нету. Агрессия началась.   А вот не свалю.  Дальше что?
    • Tapoky
      Доброго дня,   Требуется смоделировать совместно два процесса: кавитацию и дегазацию (выход растворенного газа из жидкости при понижении давления). Если с кавитацией всё плюс/минус понятно, то как смоделировать дегазацию, и особенно одновременно с процессом кавитации - это вызывает вопросы. На данный момент всё это кажется каким-то нереальным для моделирования. Получается, что имеем кавитацию, как фазовый переход жидкости, и соответственно образование пузырьков с газообразным состоянием данной жидкости, плюс выделяется растворенный газ - имеем пузырьки растворенного газа, и получается, что эти два вида пузырьков также могут взаимодействовать друг с другом.   Поделитесь, пожалуйста, опытом, если кто-то имел практику моделирования дегазации, и особенно совместно с процессом кавитации.
    • Viktor2004
      даже если у кого и есть. Откуда он возьмет параметры привода? Их никто списком или на файлике не поставляет со станком.
    • ev121
      За песнями и плясками - на концерт Льва Лещенко
    • andromed
      Ответ тот же самый, что и когда я пытался менять кодировку построчно "unknown encoding"  Как я говорил ранее по команде получить кодировку в ответ только три кодировки и в них нет cp1251. Может дело в версии NX (тестирую в 10ке) или существует какая то возможность подгрузить системные кодировки, во всех примерах в сети по команде encoding names вылетает целый абзац кодировок.    Вопрос решен! Практически сам себе и ответил.  Действительно в NX10  только 3 кодировки,  начиная с 12шки  есть все нужные кодировки.  Но и тут важно место где разместить команду по смене кодировки.  Поставил сразу после  открытия/создания файла и все получилось. set ofile [open $arhiv_file_name w] fconfigure $ofile -encoding cp1251
    • Krusnik
      Судя по скриншоту  у вас в файле 7КЕ.1004.1000_СБ.SLASM есть свойство Weight. Значение этого свойства 0 (ноль). PDM зачитывает это свойство и записывает в переменную Weight а потом эту переменную отображает в проводнике. Переменную, не свойство файла.   А вот свойства Типоразмер в файле 7КЕ.1004.1000_СБ.SLASM нет, или есть, но пустое. Поэтому и переменная пустая и столбец в проводнике пустой.   И привыкайте всё регистрировать. Переменные обновляются при регистрации файла. А у вас на скриншоте всё разрегистрировано.
    • Anatoly55
      Просмотрел бегло Базовый и Продвинутый курсы. Теперь основательно с конспектом изучаю пока только 3-ий урок Базового курса.  Да, сделано профессионально. Есть чему поучиться. 
    • oleg96i
      станок HAAS TL1 всем привет подскажите , при рассточке вн. диаметра резцом близким диаметру начального отверстия, после первого прохода отводит слижком низко, по проге не должно опускаться ниже 20мм, он опускается до 18, на новом хаасе такого нет. может параметр какой надо включить!? симка показывает норм. то есть первый проход идет на D20.6 , дойдя до нужной Z опускается не до 20, а до 18.   N4 (RASTOCHNOY)  G54  T404  G00 X40. Z20.  M08  G96 S1000 M03 (!!!)  G01 X20. Z2. F1.  G71 P300 Q310 D0.5 W0.05 U-0.4 F0.2  N300 G00 X23. Z2.  G01 Z0.  G01 X22. Z-0.5 F0.1  Z-55.  N310 X20.  G70 P300 Q310  G00 Z20. M09 
    • andromed
      Ответ тот же самый, что и когда я пытался менять кодировку построчно "unknown encoding"  Как я говорил ранее по команде получить кодировку в ответ только три кодировки и в них нет cp1251. Может дело в версии NX (тестирую в 10ке) или существует какая то возможность подгрузить системные кодировки, во всех примерах в сети по команде encoding names вылетает целый абзац кодировок. 
    • Ан-162
      Принципиальная электрическая конечно. Мне отремонтировать ее нужно. По поводу, какой конкретно станок, сейчас не скажу. Буду у станка, напишу. Плату снял, она точно неисправна (сжигает предохран, при установке на ее место второй исправной, сменив предохранитель - она работает) От станка схема платы не зависит, а зависит от модели платы. На ней написано LPS-03E, буква Е заклеяна бумажкой с буквой F и номером 616.421.4 То-бишь плата LPS-03F 616.421.4
×
×
  • Create New...