Jump to content

Некорректная работа interface в transient rotor stator


Recommended Posts

Здравствуйте!

В рамках работы над своей диссертацией столкнулся  необходимостью расчёта аэродинамической нагрузки на движущийся поезд от объёктов инфраструктуры
Ранее моделировал эту задачу созданием объёма с вычитанием из него нужного объекта и "погружением" в него поезда как immersed solid
Очевидно, что основной недостаток этой модели - отсутствие пограничного слоя вокруг поезда, в связи с этим решил использовать слеующий подход к решению этой задачи:

1. Моделирование объёма с вычитанием из него объекта инфраструктуры

2. Создание домена c вычтеным из него объемом поезда и приданием верхней и нижней граням радиуса большой величины (500...1000 км)

3. Вычитание из домена п.1. домена п.2. Таким образом в домене 1 получается тоннель, в котором перемещается домен с поездом

4. Связь этих доменов через transient rotor-stator interface

 

Отмечу, что домен с поездом на 300...400 м больше в длину, чем объект с сооружением

 

Модель принципиально работает, все движется, картина распределения воздуха вокруг поезда корректная. Однако, interface некорректно передает параметры воздуха, домены словно не взаимодействуют.

С чем это может быть связано и как можно решить эту задачу?

 

a9021e566a7e.png

 

Link to post
Share on other sites


UnPinned posts
piden
On 2/20/2022 at 9:25 AM, NLab said:

Однако, interface некорректно передает параметры воздуха, домены словно не взаимодействуют.

Можно какую-нибудь простую модель попросить выложить? Типа кирпичик въезжает в карточный домик.

А то пилить с нуля модель ради поиска ответа совсем чуточку лень...

Link to post
Share on other sites
piden
1 hour ago, an_rushin said:

brick as per request :)

Так здесь тупо immersed solid сделан, а не rotor-stator, как ТС описывает.

Или предлагается самому напильником поработать? Спасибо, см. ответ выше.

Link to post
Share on other sites
piden
On 2/20/2022 at 9:25 AM, NLab said:

Однако, interface некорректно передает параметры воздуха, домены словно не взаимодействуют.

Попробовал через обычный интерфейс (general connection), и mesh motion для домена-кирпича. Вроде бы все работает ожидаемо.

output2.gif

 

Spoiler

image.png

Интерфейс:

image.png

 

Подвижная сетка:

image.png

 

Настройки подвижной сетки для Brick Default. Для Domain Interface 1 Side 1 - такие же.

image.png

 

image.png

 

 

 

On 2/20/2022 at 9:25 AM, NLab said:

Связь этих доменов через transient rotor-stator interface

...

interface некорректно передает параметры воздуха, домены словно не взаимодействуют.

Гадаю, что причина в этом:

Quote
5.3.3.1.4. Transient Rotor-Stator

...

As with a Frozen Rotor interface, pitch change is automatically accounted for by scaling of flows by the pitch ratio.

 

  • Нравится 1
Link to post
Share on other sites

Делаю все как у Вас но при запуске Solver'а вылетает ошибка негативного объёма ячейки

 


 | ERROR #002100012 has occurred in subroutine Out_NegVol.        
 | Message:                                                           |
 | A negative ELEMENT volume has been detected.  This is a fatal      |
 | error and execution will be terminated.  The location of the first |
 | negative volume is reported below.                                 |
 |     Volume   :  -0.4294E-04                                        |
 |     Location : (  0.76698E+02,  0.19344E+01,  0.15824E+01)         |
 

Еще у Вас в location у brick указан assembly, но в то же время два домена, если поступаю таким же образом то второй домен не создаётся т.к. ошибка назначения 

In Analysis 'Flow Analysis 1': The same location has been specified for more than one domain.

Link to post
Share on other sites
piden
7 minutes ago, NLab said:

Делаю все как у Вас но при запуске Solver'а вылетает ошибка негативного объёма ячейки

Ну, очевидно, раз ошибка - то что-то задано иначе.

 

Снова без файла предлагаете гадать? Попробую.

 

Начну с конца. Насчет location не заморачивайтесь - у меня там детали с именами Assembly (которая кубик) и Assembly 2 (которая статор). Имена такие приплыли из Спейсклейма.

Negative volume из-за того, что ячейки выворачиваются наизнанку - а это значит, что перемещение сетки идет не корректно. Скорее всего условие перемещения задано только на некоторых границах домена Brick. А надо вообще на всех его границах. У меня в расчете их только две - Brick Default и Interface... Side 1.

 

В expert settings можно отключить решение уравнений течения, энергии и всего прочего - в результатах останется только деформация сетки, будет видно, где затык.

image.png

 

Link to post
Share on other sites

Попробовал все сделать на элементарных кубиках, все работает

Но та же тестовая задача с частью поезда через промежуток времени вылетает

Почитав справку и форумы пришел к выводу, что в силу большой скорости (100м/с) необходимо просто уменьшить перемещение за одну итерацию снижением timestep

И действительно, снизив timestep до 0,005 c задача стала вылетать не через 0,3 с а через 0,8 с. Так как дальнейшее снижение tiimestep сделает задачу уже чрезмерно долго решаемой вижу выход в уменьшении размера сетки в поверхностях интерфейсов

Подскажите, прав ли я в своих рассуждениях и как действительно лучше поступить в данной задаче?

 

piden, готов поделиться с вами своей тестовой задачей, только скажите в каком объёме и как вам ее скинуть, буду крайне благодарен за совет и подсказку!

Link to post
Share on other sites
  • 4 weeks later...
21.02.2022 в 23:12, piden сказал:

Ну, очевидно, раз ошибка - то что-то задано иначе.

 

Снова без файла предлагаете гадать? Попробую.

 

Начну с конца. Насчет location не заморачивайтесь - у меня там детали с именами Assembly (которая кубик) и Assembly 2 (которая статор). Имена такие приплыли из Спейсклейма.

Negative volume из-за того, что ячейки выворачиваются наизнанку - а это значит, что перемещение сетки идет не корректно. Скорее всего условие перемещения задано только на некоторых границах домена Brick. А надо вообще на всех его границах. У меня в расчете их только две - Brick Default и Interface... Side 1.

 

В expert settings можно отключить решение уравнений течения, энергии и всего прочего - в результатах останется только деформация сетки, будет видно, где затык.

image.png

 

piden, еще раз здравствуйте!

Месяц уже с перерывами пытаюсь "запустить" свою задачу но все никак не получается

Анализ задачи с отключенным решением уравнений течения и т.д. показывает, что сетка движется и каких-либо "затыков" я не нахожу, ошибок нет

Но при включении решения уравнений на первой же итерации задача вылетает с негативным объемом

Очень прошу Вас помочь! Во вложении тестовая задача, с которой пока борюсь

https://disk.yandex.ru/d/4PRJsFT6babSqA

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Сообщения

    • shodan
      Мда..."засорять эфир" нечитабельными картинками...это некорректно как минимум.
    • shodan
      Самая подробная информация на сайтах  www.exaflow.de и www.i-mold.com. Там же можно скачать и 3D-модели литников.
    • Chuk
      У кого был глюк (или это не глюк) при попытке замены компонента в сборке на несвязанный - при попытке вызова таблицы ссылок для привязок ничего не происходит.  Само окно тупо не появляется.
    • lem_on
      22 ошибка по памяти, надо произвести снова сброс и инициализацию параметров, при условии исправной батареи.  Ошибка 274 Futterspannung, возможно надо подвинуть один сенсор на прижимной цилиндре патрона. Находятся в задней части шпинделя 2 штуки. Оба должны светится. 
    • streamdown
      @BSV1 Тоже заметил, что некоторые пользователи данного топика поставили себе целью прям отвечать на любую новость провокацией и именно в негативном ключе и в стиле "я больше вас знаю как должно быть и как правильно". Сталкивался с такими на заре пребывания этого форума, когда в топике по SW гнобили софт за то, что он не делает как надо ИМ. Т.е. если точка зрения форумчан отличалась от новичка-топикстартера, то тот всенепременно обязан был доказать свою правоту. Наверное это больше психологическое, плюс уровень компетенций помноженный на моральные качества. блм-щики тоже вот прям ВСЕ угнетены))) и всем доказывают свою правоту любыми доступными им возможностями.
    • an_rushin
      решился вопрос, обнаружена ошибка в датчике. теперь результаты в порядке.  
    • co11ins
      Турт, ну ты как дитё малое.  это уже даже не смешно.  для начало, попытайся заработать авторитет.  потом якать будешь как петух гамбургский  и ставить условия.  а пока ты ДЫРКА ОТ НУЛЯ.  и это надолго
    • gena.magistr
      Добрый день, прошлый раз проблема ушла само собой, просто подергали оптоволоконные провода. Но радовались не долго, снова связь пропала. Отключил все оси заднего упора, как рекомендовали выше, все равно ошибка горит: см. видео . Значить нет связи от монитора в шкаф или от главной платы(которая в эл.шкафу) к двум вспомогательным?
    • IgorT
      Вот это правильно! Работать надо в одной системе. В смысле чертежи получать там же. А у Вас что? Безобразие!
    • kkk
      Я удалял (по крайней мере последнее удаление, предыдущие не смотрел откуда) из ветки Компьютер\HKEY_CLASSES_ROOT\Installer\Products\ Там куча папок разных приложений, вот там то я и нашел ключи, которые мешали установке
×
×
  • Create New...