Jump to content

Не подключается клиент 4-tier


Recommended Posts

Mr. Tim

Добрый день

Через браузер подключается нормально, заходит, ищет и т.д., а вот когда клиент устанавливаю, то не может подключиться. Вроде всё по мануалам, правда вместо 7001 порта оставил тот что по умолчанию был - 8085, хотя даже и 7001 уже пробовал менял и на сервере и на клиенте, нет разницы. Службы вроде все стартовал, через админку в браузере везде зеленые кружки, через IIS тоже вроде всё включил что было в мануалах. Может службу какую запустить еще? Я правда и клиент и сервер сейчас тестирую на одной машине, поэтому везде прописан Localhost

Скрытый текст

con_err.jpg

 

Link to post
Share on other sites


UnPinned posts
Mad AlexX

Может файл portal\plugins\configuration...\client_specific.properties стоит посмотреть на предмет корректности указанных адресов. Например, не затесался ли там в url-е "webclient". Для 4-уровневого клиента его как раз не надо указывать, а в адресной строке браузера надо.

Edited by Mad AlexX
  • Нравится 1
Link to post
Share on other sites
Mr. Tim
3 часа назад, Mad AlexX сказал:

Может файл portal\plugins\configuration...\client_specific.properties стоит посмотреть на предмет корректности указанных адресов. Например, не затесался ли там в url-е "webclient". Для 4-уровневого клиента его как раз не надо указывать, а в адресной строке браузера надо.

Ну в нем вроде все ссылки верные(сравниваю с файлом от клиента другого сервера)

Link to post
Share on other sites
esergey

Mr. Tim

в свое время пробовал установить саит на iis - получилось с фиг знает какого разу и в архиве есть только не полное объяснение как это все делается 
как это все получилось - сеичас даже не вспомню 
единственное что могу добавить - у iis порт по умолчанию 80 

localhost по идее равен localhost:80 - может нужно изменить порт на iis на тот по которому вы пытаетесь связаться с приложением (7001 или 8085) 
и в руководстве написано  - никаких локалхост - типа обращение только по имени сервера  - или имя сервера или IP  - вроде как что то такое проскакивало в документации 


в свое время с разрешения Николая написал и опубликовал руководство как установить все это с помощью томкат 
если что - оно есть у пользователей данного форума , для них оно было опубликовано на форуме сименс - вдруг они поделятся ...

если нужно  - подробно напишу здесь с картинками как опубликовать каталог с помощью TomCat 
на мой взгляд  - это намного проще и быстрее чем использование iis...

 

Edited by esergey
  • Нравится 1
Link to post
Share on other sites
lexx174

ISS для 4х слойки по -моему самое простое и быстрое решение.

 

Вот с jboss и подобным там заморочек побольше в настройках

Link to post
Share on other sites
esergey
5 минут назад, lexx174 сказал:

ISS для 4х слойки по -моему самое простое и быстрое решение.

подскажите плиз как , если можно инструкцию по пунктам , буду благодарен 

Link to post
Share on other sites
lexx174
1 час назад, esergey сказал:

подскажите плиз как , если можно инструкцию по пунктам , буду благодарен 

 

поищите в гугле installation_guide - там будет все по пунктам

Link to post
Share on other sites
Mr. Tim
7 часов назад, lexx174 сказал:

installation_guide

из комплекта поставки? по серверу один, и по клиентам еще один? ну по ним я и делал, но что-то пошло не так...

Link to post
Share on other sites
lexx174
8 часов назад, Mr. Tim сказал:

из комплекта поставки? по серверу один, и по клиентам еще один? ну по ним я и делал, но что-то пошло не так...

компоненты IIS нужные устанавливали?или все по умолчанию  оставили при выборе роли сервера?

Link to post
Share on other sites
Mr. Tim
10 минут назад, lexx174 сказал:

компоненты IIS нужные устанавливали?

как в installation_server_windows указано, такие и проставлял

Link to post
Share on other sites
Mr. Tim
27.01.2021 в 14:45, esergey сказал:

localhost по идее равен localhost:80 - может нужно изменить порт на iis на тот по которому вы пытаетесь связаться с приложением (7001 или 8085)

Вроде разобрался. проблема была в том, что при установке клиента я указывал в строке url номер порта. Собственно по умолчанию там уже запись http://:7001/tc, плюс ко всему смутила эта же строчка из конфига клиента другой базы, там тоже url был с портом. Не знаю как они это настраивали, но в моем случае нужно было оставить url без порта http://hostname/tc и всё заработало и через браузер и через клиент залетает отлично. 2 раза уже откатывал виртуалку, ставил всё заново начиная от iis, и вроде как технология работает

  • Нравится 1
Link to post
Share on other sites
esergey

@Mr. Tim
попробуите откатиться ещё раз если такое возможно, снимок же виртуалки можно сделать без проблем , и прописать с портом 80 установку 
если получится - то предположение верно 
тогда и я буду пробовать так же iis установить 

хотя вы писали что ставите на одну машину - а виртуалка это уже по идее другой коленкор 

спасибо за пояснение 

Edited by esergey
Link to post
Share on other sites
Mr. Tim

Казалось бы, решилась одна проблема, но тут же за ней вылезла другая: после перезагрузки сервака перестал происходить вообще какой-либо коннект клиента, ни полный ни веб. Та же самая ошибка. Кажется это как-то связано с тем, что перестают запускаться службы Microsoft .NET Framework NGEN v4.0

При попытке стартовать их вручную ругается, типа служба остановлена т.к. процесс никем не используется(или что-то вроде того). Решений по этой теме несколько, вроде обновлений, но я решил поставить просто более новую версию, не 4.0, а 4.6. По итогу службы запускаются, по http://hostname/tc заходит быстро и уверенно, а вот по /tc/admin или /tc/webclient крутит крутит, крутит крутит... загрузка которая ни к чему не приводит. В общем продолжаю поиски решения :worthy:

Edited by Mr. Tim
Link to post
Share on other sites
esergey

после перезагрузки нужно запустить  приложение "типо " на стороне сервера 
иначе с клиента не воити  

Link to post
Share on other sites
esergey

пока "окошечко" такое не будет на стороне сервера и службы автоматом не запустятся  - клиент не подрубится к серверу 
 

 

Снимок.PNG

Edited by esergey
кавычки поставил для окошечко
Link to post
Share on other sites
Mr. Tim
29.01.2021 в 17:58, esergey сказал:

пока "окошечко" такое не будет

в четырехзвенке такого окошка ведь не бывает

да и службы fsc и service manager запущены

Link to post
Share on other sites
lexx174
29.01.2021 в 19:39, Mr. Tim сказал:

 По итогу службы запускаются, по http://hostname/tc заходит быстро и уверенно, а вот по /tc/admin или /tc/webclient крутит крутит, крутит крутит... загрузка которая ни к чему не приводит. В общем продолжаю поиски решения :worthy:

 

службы Microsoft .NET Framework NGEN v4.0 по-моему тут не причем,у меня их вообще нет в списке.

 

если не пускает в админ консоль - проверьте конфиг .../Admin/Web.config. там по умолчанию стоит доступ - пользователь built-in Администратор, например.

 

пропишите infodba

 

Edited by lexx174
  • Нравится 1
Link to post
Share on other sites
Mr. Tim
21 час назад, lexx174 сказал:

службы Microsoft .NET Framework NGEN v4.0 по-моему тут не причем,у меня их вообще нет в списке.

Вы правы. Они у меня так и остались с режимом запуска Automatic (Delayed start) и пустым статусом, а вот Teamcenter Server Manager пришлось стартануть вручную, хотя у него режим запуска Automatic.

 

21 час назад, lexx174 сказал:

если не пускает в админ консоль - проверьте конфиг .../Admin/Web.config. там по умолчанию стоит доступ - пользователь built-in Администратор, например.

 

пропишите infodba

тут ничего не трогал, но после пары перезагрузок виртуалбокса полностью(не только самой ВМ) и старта вышеуказанной службы всё заработало. Единственное что еще сделал, это в iis поменял версию net framework на используемом application pools со 2й, на 4ю. 

Скрытый текст

7.jpg

... а может это просто виртуалка глючила :confused_1:

:k05197: на данный момент вопрос считаю закрытым, всем спасибо за помощь :k05205:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Сообщения

    • kzs64
    • Kir95
      в последних версиях солида проще стало - теперь все размеры в дереве видны, для чертежа там и отмечать можно, для нк размеры от центров линий ставить, тогда всё норм будет (у меня нет необходимости) заставлять нужно )
    • REDGARS
      Первый и третий пункт можно не только в листовом металле делать, второй интересен. Спасибо.
    • Kir95
      размеры габаритные автоматом получать для ведомостей
    • tompsongun
      а знаете, мне сначала тоже показалось, что не прописалось, вернее я не сразу понял о чём Вы. т.к. не пробовал этот пункт ранее. я потом предварительно отрыл деталь и запустил тот пункт. всё появилось. попробовал без предварительного открытия другую - тоже прописалось. сейчас попробую закрыть программку. и повторить. может ей надо предварительно что-то открыть прежде.   работает. странно.. кстати, вспомнил, я несколько раз жал на кнопку "get sw current file" - он просил открыть деталь. я открыл. понажимал еще раз - ничего ))  - это всё до тех манипуляций - может она что-то включает. т.е я жал её до того как понял о чём вопрос. однако эта кнопка при открытой модели тоже ничего видимого не выдаёт
    • Kir95
      с пропиской не сработало, потому и спрашивал
    • tompsongun
      @Kir95 , при выборе этого пункта у меня прописались пути в файл. немного предисловия, что происходит при запуске при запуске этой проги открывается солид, потом ругается программа - надо указать путь до папки проекта - до общей папки со множеством проектов не указывайте - оооочень долго будет индексировать - записывает в файл index все пути. и потом обновлять по указанному времени тоже долго будет.   я выбрал этот пункт (на скрине первом) - в солиде открылась и закрылась деталь. я её открыл - в неё прописались все пути!, где она используется. может не пути лучше, а имена файлов, но это надо с разрботчиком общаться, декомпилятором вряд ли можно поправить.   иногда программа от чего-то падает, толком не тестил.
    • Plumber
      Сугубо IMHO - она листовая - эскиз базовой кромки может состоять вообще из одной линии - обработка углов - не промахнешься по кромке, все 4 угла можно закруглить одним кликом - глубина отверстий связана с толщиной и всегда перпендикулярна - при надобности можно добавлять сгибы, выступы, инструменты формы, etc ... использовать все прелести работы с листом  
    • kfmut
      Так вроде без всяких танцев с бубном ставите отображение "передних" нулей и ширину в нужное кол-во знаков для параметров.
    • Kir95
      прикольная штука. как добавить свойство "где используется" увидел, но что нужно, чтобы это поле заполнилось?  
×
×
  • Create New...