Mr. Tim

Кэш клиента пуст

Pinned posts

Добрый вечер!

На виртуалке при запуске клиента вылетает соообщение: "The client cache is empty. The Rich Client is logged in in skip client cache mode..."

Совершенно честно полез читать хелпы, нашел там такую рекомендованную команду: "generate_client_meta_cache generate all -u=infodba -p=**** -g=dba"

Кэш сгенерировался на томе, который я назначил для dba группы. Но при запуске теперь пишет что кэш не может быть загружен, не может найти там какую-то xml-ку. Я перешел в том, там кроме 6-8 zip-ов ничего нет.
Чистил кэш и темп на компе, снова генерировал клиентский кэш командой, ничего не сработало.

Попробовал сгенерировать и серверный кэш, а затем клиентский... всё так же

Что можно еще попробовать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах


UnPinned posts

1) Врятли поможет, но все же попробуйте заменить в %tc_root%\tccs\fcc.xml (на клиенте) каталог генерации кэша FCC_CacheLocation (в файле он закоментирован) и укажите короткий путь без пробелов, например: "D:\testtccache" (естественно права на запись должны быть

 

2) Попробуйте установить на стороне клиента переменную TC_SKIP_CLIENT_CACHE  с любым значением

 

3) попробуйте последовательно использовать команды:

- generate_client_meta_cache delete -u=infodba -p=xxxx -g=dba 
- generate_client_meta_cache -u=infodba -p=infodba generate all

4) проверьте работоспособность FMS на сервере (например создать текстовый набор данных в 2х слойном клиенте) и его доступность со стороны клиента.

 

5) посмотрите на GTAG

 

Изменено пользователем mbm
2 пользователям понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 13.02.2019 в 08:31, mbm сказал:

2) Попробуйте установить на стороне клиента переменную TC_SKIP_CLIENT_CACHE  с любым значением

да, пользуюсь давно этой командой при создании виртуалок, когда пути к томам еще с пром. базы прописаны, захожу в клиент с этой опцией, а уж потом переписываю пути в орг. структуре.

Кстати да, забыл упомянуть, что виртуалка это тестовый стенд с дампом и тс_дата с промышленного сервера, dba том тоже оттуда. Перебил там все имена и пути, чтобы все ок было.

в общем дба том скопировал сегодня полностью(он был немного разрозненным, потому что в разное время был на разных томах) и вроде зашел в клиент без сообщения о кеше, но после первого же деплоя шаблона МД из бизнес моделера, снова стали выскакивать сообщения о кеше(кстати так же они начинали снова вылетать если я просто перегенерировал кеш по командам вышеуказанным) либо сообщения о нехватке какой-нибудь xml-ки, которых нет даже на томах пром. сервера... непонятки в общем

так-то наборы данных создаются и записываются в том, это проверял.

 

 

Изменено пользователем Mr. Tim

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не простой случай, тут уже не знаю что и посоветовать. Когда я поднимал копию промышленной базы пользовался разными ресурсами, в т.ч. последовательностью, описанной тут . Посмотрите, может чем Вам поможет.

2 пользователям понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 13.02.2019 в 08:31, mbm сказал:

generate_client_meta_cache -u=infodba -p=infodba generate all

Кстати, перепроверил все настройки по томам еще раз, потом попробовал одну эту команду генерации, без удаления и всё пошло! Всё отлично! 

Спасибо за помощь :yahoo:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу