Mr. Tim

Интеграция Teamcenter 11 с NX 11

45 сообщений в этой теме

Добрый день! Установили сервер Teamcenter 11, у него добавили компонент NX Part Family Classification Integration(стоял по умолчанию) и NX Foundation. На клиентской машине соответственно клиент TC 11(с установкой компонента NX Rich Client Integration) и NX 11. При попытке запуска NX из под TC получаем ошибку(скрин). Отдельно NX стартует нормально. Подскажите, что я делаю не так и что где проверить?

 

11scr_m.jpg

Изменено пользователем Mr. Tim

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Первое, что ты делаешь неправильно - это то, что задаешь этот вопрос здесь, а не своему поставщику NX&ТС, который (trust me) заработал немало денежек на том, что продал вашему предприятию весь этот джентльменский набор. Стесняешься побеспокоить своего поставщика? Сомневаюсь, что подобные пакеты покупают в подземном переходе, наверняка, твой поставщик NX&TC не забыл включить в стоимость техническое сопровождение. Или - я наивный чукотский юноша, и сейчас на предприятиях умельцы разворачивают паленый NX и TeamCenter?! Даже и не знаю, за кого порадоваться....  
 

2 пользователям понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
6 минут назад, Ug_user сказал:

Стесняешься побеспокоить своего поставщика?

Ды нет, просто на их хэлпдеске отвечают очень долго, здесь намного быстрее можно обсудить вопрос да и другие могут почитать, для того ведь форумы и нужны :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

обновили xml-ки в soa\policies что в tc_data из UGMANAGER ?

1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
36 минут назад, Krusty сказал:

обновили xml-ки в soa\policies что в tc_data из UGMANAGER ?

Да, не помогло. На всякий случай рестартанул сервер. Может еще надо genreg сделать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

он тут не причем)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 часа назад, Mr. Tim сказал:

Добрый день! Установили сервер Teamcenter 11, у него добавили компонент NX Part Family Classification Integration(стоял по умолчанию) и NX Foundation. На клиентской машине соответственно клиент TC 11(с установкой компонента NX Rich Client Integration) и NX 11. При попытке запуска NX из под TC получаем ошибку(скрин). Отдельно NX стартует нормально. Подскажите, что я делаю не так и что где проверить?

 

 

а вы точно саму поддержку интеграции с NX установили на сервере? В TC11 возможно поменяли названия шаблонов и интеграций, но в 10ке там надо было ставить шаблон nx0tcin (как-то так) для поддержки интеграции с NX

1 час назад, Mr. Tim сказал:

Ды нет, просто на их хэлпдеске отвечают очень долго, здесь намного быстрее можно обсудить вопрос да и другие могут почитать, для того ведь форумы и нужны :)

их хелпдеск - это хелпдеск интегратора или сименса?

 

в плане форумов - советую дополнительно пользоваться форумом сименса если дружите с английским. там могут ответить не только пользователи но и разработчики или близкие к этому люди

1 час назад, Ug_user сказал:

наверняка, твой поставщик NX&TC не забыл включить в стоимость техническое сопровождение.
 

не знаю как у интеграторов партнеров, но полноценная сименсовская тех.поддержка стоит просто конских денег, и всякий генеральный директор рискует получить инфаркт когда видит какие счета нужно подписать за оплату тех.поддержки, особенно если предприятие при этом пытается проводить какую-нибудь политику оптимизации расходов

Изменено пользователем lexx174

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

сислоги давайте

всегда давайте сислоги, по этим скринам трудно давать заключение

у вас я правильно понимаю, что 2 Tier ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

corba и IIOP connection это по идее 2tier

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
28 минут назад, lexx174 сказал:

2tier

Она самая)

Изменено пользователем Mr. Tim

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, Mr. Tim сказал:

Она самая)

 

Я тут заметил, что в папке portal клиента, нет start_nxmanager.bat (в 9ке такое есть). Не из-за этого ли ошибка? 

ну так этот батник и отвечает за запуск NX. Соответственно NX вы и не увидите из под тимцентра

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, lexx174 сказал:

ну так этот батник и отвечает за запуск NX. Соответственно NX вы и не увидите из под тимцентра

не успел затереть)) это в общем на одном клиенте увидел, наверное не поставил там интеграцию, но на другом(с которого скрин) это все есть! Сейчас проверил, в компонентах выбрано "NX Rich Client Integration", еще доступна "NX Foundation", но ее я на клиенте не ставил, а ставил ее на сервере. Больше никакие компоненты из списка "Teamcenter Integration for NX" на клиенте не доступны

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

дык чо, проблема есть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
24 минуты назад, Krusty сказал:

дык чо, проблема есть?

хитрая проблема как всегда: я на сервере ТС поставил клиент ТС и NX, в клиенте ТС ткнул галочку "NX Rich Client Integration", адрес до NX, все как обычно... установил, запустил... работает

снес клиент ТС на другом компе, на котором не работало, заново начал устанавливать, тыкаю галочку "NX Rich Client Integration" иду дальше, она мне говорит что нужен еще "NX Foundation", выбрал его, устанавливают, запускаю - снова та же самая ошибка. 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
30 минут назад, Mr. Tim сказал:

хитрая проблема как всегда: я на сервере ТС поставил клиент ТС и NX, в клиенте ТС ткнул галочку "NX Rich Client Integration", адрес до NX, все как обычно... установил, запустил... работает

снес клиент ТС на другом компе, на котором не работало, заново начал устанавливать, тыкаю галочку "NX Rich Client Integration" иду дальше, она мне говорит что нужен еще "NX Foundation", выбрал его, устанавливают, запускаю - снова та же самая ошибка. 

 

на GTAC есть такое

 

Цитата

user is unable to launch NX with the following error 
"Teamcenter Integration for NX initialize failure. 
NX cannot be started as NX Foundation (NX0TCIN) database feature is not installed 
in Teamcenter database."

Install NX foundation feature on the server side NX foundation is available at 
Extensions > Teamcenter Integration for NX > NX Foundation.

 

Цитата


 

PROBLEM: 
Newer NX data model needs are added into the NX0TCIN template, and the 
NX0TCIN template is now a required template for the Teamcenter Integration for 
NX installation. 

For the TC 10.x.x series ot higher, installing the NX0TCIN template is required. 

Note that beginning with Tc 11.1 the name of the template is NX Foundation. 
Prior to this the name was Teamcenter Integration for NX. 

REMEDY: 
The NX0TCIN is a new template and as such will not be automatically installed. 
Customers must select the template for installation.

 

Изменено пользователем lexx174
1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 минуты назад, lexx174 сказал:

NX foundation

у меня он на сервере установлен

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Иначе ведь при установке клиентов он не просил бы еще и NX Foundation поставить, не так ли?)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, lexx174 сказал:

Customers must select the template for installation.

Да,  вот это реально сработало! И на сервере и на клиентах должна быть эта галочка.

На проблемном компе правда до сих пор не запускается, буду все сносить чистить и пробовать снова, а вот попробовал еще на одной машине чистую установку так сразу все пошло как надо :)

Всем спасибо :clap_1:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот что радует на этом форуме в целом и в этом разделе в частности, так это то, что помимо криков а-ля "Мальчик, ты что тут делаешь?! Надо обращаться к интегратору/Siemens!" или "Пацан, ты чо тупишь, звони своим админам!!!" тут всё-таки ещё и реально помогают. :worthy:

Может быть и не во всех случаях, но помогают.

Изменено пользователем Алексей256
1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
22 часа назад, lexx174 сказал:

их хелпдеск - это хелпдеск интегратора или сименса?

 

в плане форумов - советую дополнительно пользоваться форумом сименса если дружите с английским. там могут ответить не только пользователи но и разработчики или близкие к этому люди

хэлпдеск интегратора)) на сименс пока ни разу не обращались, по тем самым причинам ))

Но их форум я использовал недавно для решения вопроса вывода файлов hpg из NX4 под windows 7, долго мы там с местными экспертами решали проблему, но в итоге все-таки решили! :) а вот на сообщество siemens plm тему так и не удалось создать, все время сайт ошибки выкидывает :g:

15 часов назад, Алексей256 сказал:

Вот что радует

Очень радует на самом деле, уже сколько раз выручали! :clap_1:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
17 часов назад, Mr. Tim сказал:

Да,  вот это реально сработало! И на сервере и на клиентах должна быть эта галочка.

На проблемном компе правда до сих пор не запускается, буду все сносить чистить и пробовать снова, а вот попробовал еще на одной машине чистую установку так сразу все пошло как надо :)

Всем спасибо :clap_1:

а там раньше стоял какой нить еще двухслойный клиент?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
7 минут назад, Krusty сказал:

а там раньше стоял какой нить еще двухслойный клиент?

ды нет, притащили нам комп с чистой 10кой, говорят надо проверить будет ли на 10ке работать ТС 11, NX 11 и прочий софт, ну вот об ТС с NX сразу и споткнулись 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

т.е. нормально не работает только на компе с 10-ой?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 минуты назад, Krusty сказал:

на компе с 10-ой

да, только что закончил по новой установку ТС11, NX11...попробовал, снова такая же ошибка как на скрине

из-за отсутствия лицензий на серваке может такое быть? лицухи ща все расхватали полные, остался только nx viewer

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

вы  бы хоть сислог сюда запостили с той машины

 

а забавы ради запустите клиента от имени администратора)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
28 минут назад, Krusty сказал:

а забавы ради запустите клиента от имени администратора)

итак под админом работаю, но запустил на всякий случай через контекстное... не помогло

прикладываю свеженькие логи

soaclient_2672.log

ugs_router_733922f0.syslog

Администраторa708a65.syslog

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

отключите firewall

И! сдлеайте устовноку клиента щелкнув по правой кнопке на тем бате от имена администратора

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

меня смущают

 

Could not connect to "" via IIOP

 

по нормально должно быть типа

 

Could not connect to "iiop:localhost:1572/TcServer1" via IIOP


 

 

виндас 10 какой редакции? всякие хоумы не поддерживаются

1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

попробуйте

 

 

REG ADD “HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System” /v EnableLUA /t REG_DWORD /d 0 /f

Изменено пользователем Krusty
1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну чо там у вас?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
18 минут назад, Krusty сказал:

попробуйте

попробовал все что вы советовали, результат тот же самый

Windows 10 Pro стоит 

доставил даже MS Visual C++ 2008, который почему то снова не поставился(уже как то бывало, что версии 2005 и 2010 из пакета установки ставились, а 2008 не ставился и потом были проблемы в работе клиента) все равно ничего не изменилось

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

от дерьмо

редакция винды какая?

а давайте вообще отмочим)

упаковывайте ваш чертов клиент в зип и куда нить выкладывайте

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
22 минуты назад, Krusty сказал:

редакция винды какая?

windows 10 Pro x64 русская версия

22 минуты назад, Krusty сказал:

чертов клиент

на гугле выложил

неужели я где-то торможу:g:

хотя на 7ках то "завелась"... 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

имхо проблема с 10-ой

просто допустить ошибку в установке клиента, уверен, что вы не такой)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 минуты назад, Krusty сказал:

просто допустить ошибку в установке клиента, уверен, что вы не такой)

у меня конечно мало опыта работы с этой системой и я не проходил обучения, но блин.. я тут же ставлю клиента на 7ку и все работает...видимо да, я не виноват)) 

клиент все же работоспособный? выяснить бы точно в винде проблема или нет, я б тогда репорт на жестянщиков отправил, чтоб другую ОС ставили....а хотя какую другую то....8ку чтоли (7ки не продаются уже ведь):g:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

а есть где нить внутри компании развернытй 4 tier?

я бы вам батник сварганил, что бы попробовать прицепить NX к TC без RAC (так частенько делают, особенно буржуи;))

1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 минуты назад, Krusty сказал:

развернытй 4 tier?

нету такого, как то пару лет назад пробовали делать, но не пошло, железки надо ж обновлять...пока только разговоры

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Судя по логам, в качестве пользователя используется Администратор. Кириллица-это зло 

2 пользователям понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
25 минут назад, denzil сказал:

в качестве пользователя используется Администратор. Кириллица-это зло 

Именно! Как не странно, с 9кой таких проблем не было...  На всякий пожарный зашел в систему под доменным профилем юзерским и ... заработало! 

Не перестаю удивляться работе программ от сименса... никогда не угадаешь в чем косяк

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
40 минут назад, denzil сказал:

Судя по логам, в качестве пользователя используется Администратор. Кириллица-это зло 

Бинго!

 

9 минут назад, Mr. Tim сказал:

Именно! Как не странно, с 9кой таких проблем не было...  На всякий пожарный зашел в систему под доменным профилем юзерским и ... заработало! 

Не перестаю удивляться работе программ от сименса... никогда не угадаешь в чем косяк

Вы знаете все таки зло кириллица в учетных записях)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу

  • реклама

  • Реклама

  • Ближайшие события

    Предстоящих событий не найдено
  • Дни рождения сегодня

    1. barbos
      barbos
      (43 года)
    2. cnc_expert
      cnc_expert
      (28 лет)
    3. Fraser
      Fraser
      (50 лет)
    4. Grom1
      Grom1
      (37 лет)
    5. Kord77
      Kord77
      (40 лет)
    Просмотреть все