DuS

solid 2015 тормозит на игровом компе с win10, почему?

350 posts in this topic

Всем добрый день!

Есть комп: Видеокарта MSI GTX 950, Процессор AMD FX-8350, мамка MSI 970 GAMING и 6 ГБ оперативы. Win10x64

 

Поставил Solid Works 2015 sp5. Результат: жуткие лаги даже на небольшой сборке (60 деталей). 

Та же сборка на рабочем компе летает без проблем. Рабочий на базе нвидиа квадро М4000 win 10х64, 16 оперативы и тд.

Вопрос почему тормоза? Посоветуйте куда копать.

 

ЗЫ я понимаю, сейчас скажут что ты хотел этож игровой комп проц амд, нищеброд беги за интелом и квадрой, НО какого ... игры последние идут на самых максимальных настройка и 50-60 фпс? Да я дипломный проект делал на старинном компе и то не так лагало. 

Share this post


Link to post
Share on other sites


ID: 2   Posted (edited)

оперативы мало. Тем более для win10. А видео тут думается ни при чем. SSD имеется для системы и программ?

Edited by Bully

Share this post


Link to post
Share on other sites

@Bully нет. У меня те же 6 гигов, и одновременно работает виртуалка, солид, Visual Studio. Работать, конечно сложновато с чертежами там... но сборки и модельки все крутятся :smile:

2 минуты назад, DuS сказал:

жуткие лаги

И как это проявляется?

 

Share this post


Link to post
Share on other sites
4 минуты назад, Bully сказал:

оперативы мало. Тем более для win10. А видео тут думается ни при чем. SSD имеется для системы и программ?

ssd нет. То есть есть смысл поставить семерку?

3 минуты назад, streamdown сказал:

И как это проявляется?

проявляется в том что увеличение вращение сборки работает очень медленно и с большими рывками. Я даже подумал что у мыши скрол сдох.

Причем иногда всё работает очень хорошо.

По загрузке: Проц 40-50% а оператива не более гига.

Share this post


Link to post
Share on other sites

В связи с некоторыми последними новостями, а виновато ли железо? ))

Вот из последнего:

Цитата

 

Краткое описание

Проблема с отображением графики при ее обновлении из-за конфликта с обновлениями Windows - KB3205394 для Windows 7 и KB3206632 для Windows 10.

Затрагиваемое программное обеспечение

SOLIDWORKS (все версии)

Симптомы

«Мерцание» изображения: изображение в графической области обновляется, затем возвращается в предыдущее состояние и снова обновляется. Причиной является наличие в системе обновлений Windows KB3205394 для Windows 7 и KB3206632 для Windows 10. 

Условия возникновения

Данное поведение имеет место быть на всех поддерживаемых операционных системах при следующих условиях:

  • Окно SolidWorks «развернуто» на весь экран;
  • Окна других приложений открыты за окном SolidWorks;
  • Установлены обновления качества безопасности (Security Only Quality Update) или ежемесячные накопительные обновления (Security Monthly Quality Rollup), датированные декабрем 2016 г.  

 

  •  

Это и на 2015 и на 2016 и на 2017 и на семёрке и на восьмёрке и на десятке. Кароч везде и во всём. Спасибо Microsoft.

1 person likes this

Share this post


Link to post
Share on other sites
7 минут назад, streamdown сказал:

В связи с некоторыми последними новостями, а виновато ли железо? ))

Вот из последнего:

  •  

Это и на 2015 и на 2016 и на 2017 и на семёрке и на восьмёрке и на десятке. Кароч везде и во всём. Спасибо Microsoft.

описанный косяк я вижу на рабочем компе (и у коллеги тоже), возможно что на домашнем компе разновидность этого косяка. 

Вопрос всё тот же , что делать?

Share this post


Link to post
Share on other sites

Самое первое, что советует техподдержка:

1) запустить всё в режиме OpenGL

2) Создать нового виндопользователя и запустить-открыть солид там.

1 person likes this

Share this post


Link to post
Share on other sites
20 минут назад, streamdown сказал:

 

@Bully нет. У меня те же 6 гигов, и одновременно работает виртуалка, солид, Visual Studio. Работать, конечно сложновато с чертежами там... но сборки и модельки все крутятся

 

тоже win10? Для семерки вполне нормально. Но для десятки...

14 минуты назад, streamdown сказал:

Спасибо Microsoft.

Ах вон оно что...

Share this post


Link to post
Share on other sites
1 минуту назад, Bully сказал:

тоже win10? Для семерки вполне нормально. Но для десятки...

Ну так может докупить оперативы?

4 минуты назад, streamdown сказал:

Самое первое, что советует техподдержка:

1) запустить всё в режиме OpenGL

2) Создать нового виндопользователя и запустить-открыть солид там.

про этот open gl я не понимаю один момент. Запустил я солид rx, запустил в режиме OpenGL, в последующие запуски солид в каком режиме будет запускаться? В директ х или OpenGL?

Share this post


Link to post
Share on other sites
5 минут назад, DuS сказал:

В директ х

в этом солид не работает. Этот режим отключает аппаратную поддержку и запускает всё в программной эмуляции. Это нужно для проверки работоспособности железной части видео.

 

9 минут назад, Bully сказал:

тоже win10?

Да. Маловато? ... только временами.

Share this post


Link to post
Share on other sites
15 минут назад, streamdown сказал:

в этом солид не работает. Этот режим отключает аппаратную поддержку и запускает всё в программной эмуляции. Это нужно для проверки работоспособности железной части видео.

что то я не понимаю, так как запустить в режиме open gl навсегда?

Share this post


Link to post
Share on other sites

Не надо этого делать. :biggrin: Всё будет хорошо в случае включённой эмуляции, если только у вас напрочь отсутствует видяшка и стоит проц с 6 гигагерцами на одно ядро.

Share this post


Link to post
Share on other sites
1 минуту назад, streamdown сказал:

Не надо этого делать. :biggrin: Всё будет хорошо в случае включённой эмуляции, если только у вас напрочь отсутствует видяшка и стоит проц с 6 гигагерцами на одно ядро.

Тогда как же заставить его работать?

Вот такую сборку я делал для дипломного, там и кинематика и детали подробно. Тормозило конечно жутко, но сейчас на более более мощном компе тупит гораздо более маленькая сборка.((((

y_38c67b52.jpg

Share this post


Link to post
Share on other sites

У меня такая же беда, но в какой то момент, где то месяц назад, после очередного обновления стало значительно легче, но проблема не прошла. Коллега с этого сайта посоветовал решить эту проблему установкой винды 10 версии не выше 1511, там таких глюков не наблюдается.

Share this post


Link to post
Share on other sites
2 минуты назад, ff25tj сказал:

У меня такая же беда, но в какой то момент, где то месяц назад, после очередного обновления стало значительно легче, но проблема не прошла. Коллега с этого сайта посоветовал решить эту проблему установкой винды 10 версии не выше 1511, там таких глюков не наблюдается.

то есть отключить обновление винды? 

Поделитесь какая у вас конфигурация.

Share this post


Link to post
Share on other sites

ID: 16   Posted (edited)

у меня i5 6гигов видюха нвидиа 840 памойму, Win10x64 , все летает

Edited by Spikard

Share this post


Link to post
Share on other sites

ID: 17   Posted (edited)

1 час назад, DuS сказал:

то есть отключить обновление винды? 

Поделитесь какая у вас конфигурация.

если есть возможность отключить, если нет то переустановить винду.

у меня такая : FX-6100, мамка на 780G чипсете, видяха Gt730, 8gb Ram, HDD винт, солид 2016 sp5

 

25 минут назад, Spikard сказал:

у меня i5 6гигов видюха нвидиа 840 памойму, Win10x64 , все летает

у меня коллега, за соседним компом с такой же конфигурацией и у него нет этих проблем, а почему они появляются хз (напоминает проблемы с 98 виндой, как установишь...)

Edited by ff25tj
1 person likes this

Share this post


Link to post
Share on other sites
22 минуты назад, Spikard сказал:

у меня i5 6гигов видюха нвидиа 840 памойму, Win10x64 , все летает

а солид какой?

У меня тоже всё летает, кроме солида. Играл в последний дум и параллельно рендерилось видео в сони вегасе.

Share this post


Link to post
Share on other sites

13, 16, 17 устанавливал

стоит попробовать процесс хакер или процесс эксплорер - они более подробно показывают что именно нагружено в компе

MivIUK2x.jpg

2 people like this

Share this post


Link to post
Share on other sites
1 минуту назад, Spikard сказал:

13, 16, 17 устанавливал

стоит попробовать процесс хакер или процесс эксплорер - они более подробно показывают что именно нагружено в компе

MivIUK2x.jpg

сегодня попробую. спасибо!

Share this post


Link to post
Share on other sites

ID: 21   Posted (edited)

небольшой костыль: выделяешь какую нибудь плоскость и модель крутится замечательно, без тормозов. если сбрасываешь выделение плоскости, то начинается унылое ожидание прогруза тормозов

 

 я ошибся, у меня 16 гигов оперативки а не 8

 

кстати, на счет процесс эксплорера вангую: что покажет где то 20% занятости проца, при этом 2-3 ядра могут вообще быть без нагрузки, и никакую нагрузку на видяху,

Edited by ff25tj

Share this post


Link to post
Share on other sites

у меня на i7 выдает 50% загрузки (гипертрейдинг выключен ессно) и до половины загружает квадра 4000 на довольно простенькой сборке

XRyI5yP2.jpg

 

Share this post


Link to post
Share on other sites
17 часов назад, Spikard сказал:

у меня на i7 выдает 50% загрузки (гипертрейдинг выключен ессно) и до половины загружает квадра 4000 на довольно простенькой сборке

XRyI5yP2.jpg

 

Как то многовато? 

Итак чем окончились мои эксперименты с домашней конфигурацией.

-под новым пользователем солид с указанной сборкой (мультипликатор из 50-и деталей) работает действительно шустрее. Основной лаг при масштабировании сборки скролом. Под новым незасранным пользователем он практически незаметен, но есть.

Загрузка видео от 40 до 60(редко) % на быстродействии не сказывается. 

 

Вывод: для солида на десятке мало оперативы. У меня она 2+2+4 Гб к тому же. И не самая быстрая. Вопрос что делать остается и мне видится два решения. Первое ставить семерку, второе бежать в магазин за оперативой (-10тр из семейного бюджета).

 

ЗЫ игры с файлом подкачки (задавал и много и совсем выключал) ни к чему не привели. 

ЗЗЫ Большое спасибо всем участникам данной ветки!

Share this post


Link to post
Share on other sites

ID: 24   Posted (edited)

по моим наблюдениям в порядке значимости

процессор, причем важно именно одно ядро (гипертрейдинг если есть я выключаю, именно по этому у меня так загружен процессор, но это дает прибавку скорости работы)

видюха

оперативка/жесткий диск/сеть если используется пдм сервер. Если оперативки 16+ то какой диск неважно и кеширование через диск я отключаю, если меньше то лучше если ссд и все это неважно если работаете через пдм сервер

соотв в место оперативки можно попробовать купить ссд, но это наугад.Нужно выяснять причину, по моему там дело не в памяти, потому что на тех же 6ти оперативки мой домашний тягает сборки по 300-500 деталей

7ка, по ощущениям, меньше оперативки использует, но сама по себе медленнее

Edited by Spikard
1 person likes this

Share this post


Link to post
Share on other sites
39 минут назад, Spikard сказал:

по моим наблюдениям в порядке значимости

процессор, причем важно именно одно ядро (гипертрейдинг если есть я выключаю, именно по этому у меня так загружен процессор, но это дает прибавку скорости работы)

видюха

оперативка/жесткий диск/сеть если используется пдм сервер. Если оперативки 16+ то какой диск неважно и кеширование через диск я отключаю, если меньше то лучше если ссд и все это неважно если работаете через пдм сервер

соотв в место оперативки можно попробовать купить ссд, но это наугад.Нужно выяснять причину, по моему там дело не в памяти, потому что на тех же 6ти оперативки мой домашний тягает сборки по 300-500 деталей

7ка, по ощущениям, меньше оперативки использует, но сама по себе медленнее

Мне вот еще что не понятно, почему солид тормозит, а ресурсы максимум на 50-60% задействованы? К примеру если запустить архивирование RAR сразу несколько архивов, то проц и оператива загружаются почти на 100%! 

То есть я что хочу сказать, ну тормозит прога , ну возьми еще ресурсов.

зы про гипертрейдинг можно подробнее или ссылку?

Share this post


Link to post
Share on other sites

Hyper-threading интеловская технология разделения ядра процессора на потоки для выполнения разных задач - увеличивает его эффективность для многопоточных приложений или при запуске нескольких приложений

печалька в том что солид большую часть операций выполняет в одном потоке, и соотв если не выключить гипертрейдинг на i7 с 4мя ядрами он будет загружать только половину ядра одного процессора или 12,5%

солид это объясняет тем что дерево построения можно считать только последовательно сверху вниз, но по моему они просто вовремя не наняли нормального многопоточного програмиста или лень было переписывать код.

2 people like this

Share this post


Link to post
Share on other sites

ID: 27   Posted (edited)

Короче та же проблема сборки очень сильно тупят. Комп i3+gt940m, до этого был комп i5+gt320m(6 летней давности) дак вот там эта же сборка на этой же версии солида (16) работала замечательно. Заметил, что перестает так сильно лагать, когда запускаешь, пропустив настройки в Инструменты/Параметры в solidworks Rx, как на скрине. Наверняка проблемы с программной частью, а ни как не с железом. На забугорных тоже пишут о такой проблеме. Может кто-то уже решил эту проблему?

1.jpg

Edited by track
2 people like this

Share this post


Link to post
Share on other sites

ID: 28   Posted (edited)

1 час назад, track сказал:

Короче та же проблема сборки очень сильно тупят. Комп i3+gt940m, до этого был комп i5+gt320m(6 летней давности) дак вот там эта же сборка на этой же версии солида (16) работала замечательно. Заметил, что перестает так сильно лагать, когда запускаешь, пропустив настройки в Инструменты/Параметры в solidworks Rx, как на скрине. Наверняка проблемы с программной частью, а ни как не с железом. На забугорных тоже пишут о такой проблеме. Может кто-то уже решил эту проблему?

1.jpg

Я в шоке! Запустил как показано на скрине, скорость дикая. Никаких лагов вообще нет!!!!

Это я так понимаю дефолтные настройки?

Edited by DuS

Share this post


Link to post
Share on other sites

ID: 29   Posted (edited)

Вот я тоже не понимаю, какие это настройки дефолтные или не дефолтные. В гугле об этом вообще ничего не пишут. Может кто подскажет, что это? Как теперь выставить данные настройки в солидворксе, чтобы при любом запуске устанавливались именно эти настройки?

Edited by track
1 person likes this

Share this post


Link to post
Share on other sites
21 час назад, track сказал:

Вот я тоже не понимаю, какие это настройки дефолтные или не дефолтные. В гугле об этом вообще ничего не пишут. Может кто подскажет, что это? Как теперь выставить данные настройки в солидворксе, чтобы при любом запуске устанавливались именно эти настройки?

А что если сохранить эти настройки с помощью копи сеттинг визарда?

 

Вот как выглядит диспечер задач при рендеренге в программе сони вегас. Сразу видно программисты с прямыми руками.

 

Снимок.PNG

Share this post


Link to post
Share on other sites
11 час назад, DuS сказал:

Вот как выглядит диспечер задач при рендеренге

так рендеринг сам в любой проге может распараллеливаться вроде? Т.е. это просто другой тип операции, нежели перестроение модели.

Share this post


Link to post
Share on other sites

На мой взгляд проблема обновления windows 10 (сборка 1607) и драйверов видеокарты или самой видеокарты. Потому что на работе в сборке windows 10 (1607) наблюдались лаги, а дома при той же сборке windows но другой видеокарты все нормально. Мой совет, откатите или переустановите windows на сборку (1511). И ждать пока этот баг не пофиксят.

Share this post


Link to post
Share on other sites
1 час назад, Ardianen сказал:

На мой взгляд проблема обновления windows 10 (сборка 1607) и драйверов видеокарты или самой видеокарты. Потому что на работе в сборке windows 10 (1607) наблюдались лаги, а дома при той же сборке windows но другой видеокарты все нормально. Мой совет, откатите или переустановите windows на сборку (1511). И ждать пока этот баг не пофиксят.

Ну во первых десятка обновляется сама и без бубна автообновления не отключаются, а во вторых при запуске из под Rx (см выше) лаги пропадают совсем.

Share this post


Link to post
Share on other sites
48 минут назад, DuS сказал:

Ну во первых десятка обновляется сама и без бубна автообновления не отключаются, а во вторых при запуске из под Rx (см выше) лаги пропадают совсем.

Я сначала откатил обновление, а потом отключил автообновление и все стало снова хорошо. Так что вам решать.

1 person likes this

Share this post


Link to post
Share on other sites
11 минуту назад, Ardianen сказал:

Я сначала откатил обновление, а потом отключил автообновление и все стало снова хорошо. Так что вам решать.

как вариант

Share this post


Link to post
Share on other sites

ID: 36   Posted (edited)

В 18.02.2017 в 23:10, DuS сказал:

Я в шоке!

в реестре удалить/переименовать папку "HKEY_CURRENT_USER\Software\SolidWorks\SOLIDWORKS 20XX" где XX - номер версии

Собсна, вся хрень может даже быть  из-за того, что вы начали использовать шаблоны, стандарты, основные надписи - перетащенные из прошлых версий, а не создали в текущей заново. Это реально))) ибо в младших версиях был такой глюк. Указанная ветка реестра сбрасыает всё для текущего пользователя, а это значит что всё вышеперечисленное идёт "из коробки" а не ваше.

Edited by streamdown

Share this post


Link to post
Share on other sites
13 минуты назад, streamdown сказал:

в реестре удалить/переименовать папку "HKEY_CURRENT_USER\Software\SolidWorks\SOLIDWORKS 20XX" где XX - номер версии

Собсна, вся хрень может даже быть  из-за того, что вы начали использовать шаблоны, стандарты, основные надписи - перетащенные из прошлых версий, а не создали в текущей заново. Это реально))) ибо в младших версиях был такой глюк. Указанная ветка реестра сбрасыает всё для текущего пользователя, а это значит что всё вышеперечисленное идёт "из коробки" а не ваше.

я не уверен что из под RX запускается солид с дефолтными настройками, так как все панели и кнопки остаются мои.  Макросы пропадают и шаблоны. 

Кстати, на рабочем компе те же настройки и те же шаблоны и работает все нормально.

Короче, буду экспериментировать. 

Share this post


Link to post
Share on other sites

ID: 38   Posted (edited)

Всем привет. Вижу тут у многих такая проблема, вижу есть способы ее решения, но, к сожалению, ни один из них мне не помогает, может у меня с железом что-то не так? Geforce GTX 950M, i5 2*2.5 GHz, 6 Gb RAM, солид стоит на SSD диске, win 10(была 1607, после танцев с бубном и с помощью великого могучего откатил на 1511, ничего не изменилось по-сути).

Однако, у меня лагает даже при работе с одной деталью, а сборку я даже боюсь открывать. Поможет ли увеличение оперативки? В комментариях выше видел, что для 10 винды 6 гб маловато

И да, проблема не только с SW, но и с Компасом тоже.

Edited by Lufer666
дополнил

Share this post


Link to post
Share on other sites

у вас и проц не очень. 2.5ГГц на сегодняшний день слабоват будет. Видеокарта (сразу надо было сказать, что у вас ноутбук), как говорит поиск, может быть оснащена памятью как GDDR5, так и GDDR3. Второй случай способствует тормозам, ест-но. А ещё в ноутах проблема с охлаждением. Т.е. проц может включить экономный режим.

Share this post


Link to post
Share on other sites

Хм..а как-то можно ограничить включение этого "экономного режима"? Память GDDR5. Дело еще в том, что до обновления до 1607 таких косяков не было. А сейчас начались и т.к. все указанные способы перепробовал уже и не знаю на что грешить.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Сообщения

    • igarr
      Проверил  все, нормально. У меня получаеться при ST35,выставляеться правильно когда переходишь с большего на меньший металл или наоборот. Если просто поменять марку металла тогда выставляеться не правильно. С этим я разобрался ,теперь вычислил одну фиговину по зазорам. Выставил ST42 металл 10мм ,все четко опустил сначало левый край ножа,замерил, опустил правый край ножа(полностью нож опустил)замерял правый край ножа. Всё чётко, зазор согласно бумаге. Теперь выставил металл 7мм, все 0,7мм щуп не лезет,а надо 0,74мм.Щуп 0,65 проходит как положенно, но это для металла ST35 ,а выставленно ST42. Пока оставил все так, какие будут рекомендации?  
    • Chardash
      Суррогатные модели - ИИ и Численные методы     весь плейлист для тех, кому интересно  
    • Francoligas
      Здравствуйте,помогите пожалуйста,есть фаил с цифрами - строка грубо говоря,с нее нужно сделать три массива данных,не как не доходит,как сделать
      Вот на чем остановилась
      using System;
      using System.Collections.Generic;
      using System.Linq;
      using System.Text;
      using System.Threading.Tasks;

      namespace ConsoleApp1
      {
      class Program
      {
      static void Main()
      {

      string[] lines = System.IO.File.ReadAllLines(@"C:\Users\Kristina\Downloads\y_axis_Channel 1_CH1.frf");

      System.Console.WriteLine("Contents of y_axis_Channel 1_CH1.frf");
      foreach (string line in lines)
      {

      Console.WriteLine("\t" + line);
      }


      Console.WriteLine("Press any key to exit.");
      System.Console.ReadKey();

      }
      }
      }
    • Kir95
      Чтобы начертить линию на плоскости-ЛКМ по плоскости или грани и нажать клавишу "L" (при любой раскладке клавиатуры). Солид переходит в режим эскиза с выбранным инструментом "Линия". Экономия, как минимум в один клик мышью ). Команда осталась со времён 2д эмулятора, когда можно было чертить текстом из командной строки, а-ля автокад.
    • Kir95
      В Windows 10 уже встроенный PDF принтер есть. Ctrl+P->Print->в списке принтеров выбрать Microsoft Print to PDF.
    • igarr
      Я тоже об этом подумал.) Но казалось бы 100 раз проверил, а на 101й нашел,разок было такое.)
    • Tad
      Проверьте таблицы зазоров для всех пяти материалов.
    • Kir95
      Могу ошибаться, но похоже, что тип спецухи не "смещённый". В любом случае, без файла не разобраться, почему размеры не появились.  В суммарной информации размеры берутся из эскиза, на 1 скриншоте это ж видно. Создаёшь свойство "L", тип текст, тыкаешь по нужному размеру эскиза и в вычисленном значении получаешь размер, который потом выводишь в столбец спецификации (выбираешь свойство "L"). Файл с чертежом и сборкой (СВ 2019), посмотри, в чём разница. Может на английский интерфейс переключиться будет нужно, солид иногда оставляет названия 3д рамки на языке исходного файла.   Configs.zip
    • ded-
      Да вроде полно информации https://yandex.ru/video/search?from=tabbar&text=станок правильно гибочный для арматуры
    • igarr
      Странно ,для ST35 ход штоков намного меньше ST42. Вот значения для ST35. F1 =36мм, F5=47мм. Для ST35 через раз правильно выставляет.(сегодня еще попробую 2раза проверял и оба раза разные хода штоков) Для ST 42 всегда правильно выставляет зазоры.(три раза проверял и все одинаковые)