fox1001

SWPlus.Net (оформление конструкторской документации)

1 339 сообщений в этой теме

Ребята всем привет! У меня стоит SW16, win 10. Кто знает как решить данную проблему?

Screenshot_1.jpg

Screenshot_2.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах


@Kastiyel По-моему вы ошиблись темой.

Тут вам быстрее помогут

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите, в MProp ввёл свойства, всё нормально отображалось - по строчкам, нажал сохранить/перестроить и получается так. В других местах есть по записи 2-3 строки, там слетает так же если саму ячейку редактировать нажать. Как исправить?

 

123123.JPG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Межстрочный интервал надо увеличить.. Но первым делом в таком случае надо выходить без сохранения.. Обычно восстанавливается..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@ILL Нк а как его увеличить? тот , что в редакторе таблиц вообще криво работает

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Он работает, но через раз.. Если файл уже был сохранен, боюсь, проще заново сгенерировать специю.. А можно попробовать очистить ячейку и потом восстановить связь со свойством модели..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
31 минуту назад, R2D2_ сказал:

Ситуация: оформляю сборочный чертеж, генерирую СП (SWPlus.NETовский SpecEditor). Позиции в СП - все ок, пытаюсь ставить на чертеже, а они ничерта не отвечаю тому, что СП. Причем проставляются на каждую деталь подсборки (а не одна позиция, в какую деталь подсборки не ткни).

Вопрос: где я уже натупил?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Так вроде разобрались..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@ILL , да. Сюда написал по Вашему совету, т.к. специя оформлена в .NET'овском варианте SpecEditor.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я имел ввиду, что вопрос изначально надо было создавать в этой теме..

А так дублирование получилось..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 1331   Опубликовано: (изменено)

Ситуация следующая: если в какой либо детали из сборки не заполнены свойства имеем пустые строки в СП с прочерком в колонке "Поз.". Для небольших сборок (10...20 уникальных деталей) можно вручную выследить в какой детали не заполнены свойства, но когда деталей до сотни ручное отслеживание представляется весьма напряжным. Для деталей с заполненными свойствами выйти из СП на деталь легко:

ПКМ по нужной строчке -> "Открыть [Имя детали]". Вот если б так можно было выйти на детали с незаполненными свойствами, которые и порождают эти пустые строки - было б чудесно. Или может кто подскажет другой способ устранения этой проблемы?

Показать содержимое  

Снимок.PNG

Hide  

 

Изменено пользователем R2D2_

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 1332   Опубликовано: (изменено)

Уважаемый @R2D2_ а вы пробовали. У меня на Солид Воркс 2014( сп 1) работает по ПКМ и без свойств. Версии макросов  SWPlus.NET .5.6 .

 

 

 

Работает.jpg

Изменено пользователем ГЕЛА

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Уважаемая @ГЕЛА, уверяю Вас, что пробовал. Просто так будоражить общественность не стану. Объясню по косвенному признаку: видите у меня такой мааааленький дефис в колонке "Поз.". Так вот там где го нет (т.е. как на Вашем скрине) можно абсолютно спокойно перейти в деталь по ПКМ. А вот где он есть (как на скринах, что я приложил выше) такой фокус не работает. Догадиваюсь, что такая трабла как у меня, возникает не просто тогда, когда не заполнены свойства, а еще и при условии, что использован не стандартный шаблон детали.

В принципе, прошерстив форум, проблему решил радикально - удалил неугодные строки и пересортировал СП :smile:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
6 часов назад, R2D2_ сказал:

А вот где он есть (как на скринах, что я приложил выше) такой фокус не работает.

 

А нет там деталей.. это результат вставки пустых строк SpecEditor'ом..

Если ручками вставить строку будет та же фигня.. Похоже, это глюк Солида..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 1335   Опубликовано: (изменено)

Вдруг заметил, что где могло сломаться? т.е. не происходит переключения в свойствах чертежа единиц измерения. солид 2018 MProp 1.2

картинка  

Screenshot_2.jpg.cea93309da5c9ed3c96ef1390a524455.jpg

Hide  

 

подозрение, что это в этом солиде так стало. в 2015 было с этим хорошо

 

 

 

и не отрабатывается количество знаков после запятой

Изменено пользователем tompsongun

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подключил MProp из SWPlus2017 на солиде 18сп3, в деталях все прекрасно работает, а вот в сборках макрос не вызывает такую же панель для заполнения свойств. Куда копать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 06.06.2018 в 09:29, РоманВ сказал:

Куда копать?

 

Ну, если

 

В 06.06.2018 в 09:29, РоманВ сказал:

SWPlus2017

 

, то сюда

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Так речь-то о макросе, записывающем свойства детали или сборки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 часа назад, РоманВ сказал:

Так речь-то о макросе,

 

Макросы из пакета SWPlus (с расширением ".swp") написаны на VBA и обсуждаются в теме

 

http://cccp3d.ru/topic/6622-спецификация-для-sw-по-гост/?do=getLastComment

 

А в этой теме обсуждаются приложения SWPlus.net, имеющие расширение ".exe" и написанные на VB.Net"

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу