Leon

Спецификация для SW по ГОСТ

Ваш опыт использования пакета макросов SWPlus   468 пользователей проголосовало

  1. 1. Вы используете макросы из пакета SWPlus?

    • Да, постоянно на основной работе.
      348
    • Да, но не на основной работе.
      60
    • Нет
      62
  2. 2. Каие макросы из пакета Вы используете?

    • SpecEditor - для создания спецификаций и ВП
      379
    • MProp - для заполнения свойств моделей
      362
    • DProp - для управления листами чертежа
      247
    • SProp - для заполнения свойств моделей из разделов Стандартные изделия, Прочие изделия и Материалы
      242
    • SaveDRW - для "правильного" сохранения чертежа
      108
    • SaveAsPDF - для сохранения чертежа в формате PDF
      156
    • Master - для создания шаблонов основных надписей
      237
  3. 3. Были ли у Вас проблемы с освоением (изучением) макросов?

    • Нет, мне все интуитивно понятно
      122
    • Да, но я разобрался с помощью форума и описания
      233
    • Да, я до сих пор не могу разобраться как с этим работать
      74
    • Я не стал разбираться, глянул и стер все нафиг
      6
    • Я не пользовался этими макросами
      35
  4. 4. Были ли у Вас проблемы (глюки) с установкой и настройкой макросов?

    • Нет, все установилось нормально
      113
    • Да, но они решились
      202
    • Да, и я до сих пор не могу заставить макросы работать, но хочу это сделать
      115
    • Да, поэтому я и не стал с ними связываться
      6
    • Я не пользовался этими макросами
      34
  5. 5. Устраивает ли Вас подход к автоматизации оформления КД, заложенный в данных макросах?

    • Да
      208
    • Да, хотя кое-что я бы изменил
      194
    • Нет
      21
    • Не знаю
      47

Пожалуйста, войдите или зарегистрируйтесь для голосования в опросе.
6 473 сообщения в этой теме
Pinned posts


UnPinned posts
8 минут назад, KonstruktorRus сказал:

А как же мне узнать в чем причина? Promta у меня не было - система-то только в субботу установлена.

может просто банально нет совместимости???

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, pavel-kpll сказал:

может просто банально нет совместимости???

Одновременно и у SWPlus 2014, и у SWPlus 2017? Вряд ли...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 минуту назад, KonstruktorRus сказал:

Одновременно и у SWPlus 2014, и у SWPlus 2017? Вряд ли...

я имею ввиду ОС

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, pavel-kpll сказал:

я имею ввиду ОС

Да ну! Каким же краем может Винда 10 не работать с тем, что нормально работало в Винде 8 и 7?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
6 минут назад, KonstruktorRus сказал:

Да ну! Каким же краем может Винда 10 не работать с тем, что нормально работало в Винде 8 и 7?

 

https://forum.solidworks.com/thread/63596

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, KonstruktorRus сказал:

Да ну! Каким же краем может Винда 10 не работать с тем, что нормально работало в Винде 8 и 7?

 

https://www.solvusoft.com/ru/errors/ошибки-во-время-выполнения/dassault-systèmes/solidworks/91-solidworks-api-runtime-error-91/

1 час назад, KonstruktorRus сказал:

Да ну! Каким же краем может Винда 10 не работать с тем, что нормально работало в Винде 8 и 7?

 

все оттуда же из форумов

 

Недавно была похожая проблема с уравнениями, долго бодались потом связались с техподдержкой солида вот что посоветывали, почитайте может поможет:

Затрагиваемое программное обеспечение

SOLIDWORKS 2011 - 2015, и SOLIDWORKS 2016 beta.

Симптомы

Нестабильность может проявиться во многих различных областях программного обеспечения, поэтому список ниже может быть не полным. Известные симптомы следующие:

Отсутствуют добавления SOLIDWORKSв списке добавлений в меню Инструменты.
Ошибкапризапуске SOLIDWORKS или открытии файла: "Could not load SOLIDWORKS DLL: GdtAnalysisSupport.dll".
Падения при записи, запуске или редактировании макросов SOLIDWORKS.
Нестабильное поведение при решении уравнений.
Ошибка при запуске SOLIDWORKS или SOLIDWORKS Explorer: "DWG document manager library is invalid or missing".
Решение

Сначала, проверьте, установлено ли у вас обновление KB3072630:

Из Панели управления Windows, запустите Центр обновлений Windows.
В левой части окна, нажмите Просмотр журнала обновлений.
Просмотрите список установленных обновлений на предмет установки KB3072630. Если оно присутствует в списке, то оно установлено 14 Июля 2015 или позже.
Если KB3072630 установлено в вашей системе просмотрите рекомендации и возможные сценарии решения ниже.
Важно: Мы не рекомендуем вам удалять KB3072630 т.к. это важное обновление безопасности. Посмотрите шаги приведенные ниже.

Важно: Серьезные проблемы могут случиться если вы сделаете неправильные изменения в реестре. Настоятельно рекомендуем делать резервные копии реестра перед любыми изменениями. Настоятельно рекомендуем вам работать вместе с системными администраторами вашего предприятия при проведении любых действий с системой.

Сценаний 1

Для пользователей, которые еще не установили или не обновили SOLIDWORKS и KB3072630 применен. Для предотвращения проблем мы рекомендуем временно отключить KB3072630 перед установкой или обновлением SOLIDWORKS:

Для временного отключения KB3072630 (мы не рекомендуем его удалять) следуйте следующим шагам или запустите файл KB3072630_Disable.reg (см. вложения статьи).
Нажмите Click Пуск, затем Выполнить, впишите "regedit" в поле Открыть, после чего нажмите OK.
Найдите и выберите следующий раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer Примечание: Если этот раздел отсутствует, создайте его.
В меню Редактировать, Нажмите Создать, и выберите Параметр DWORD.
Введите имя параметра "RemappedElevatedProxiesPolicy", и нажмите Enter.
Щелкните правой кнопкой мыши по параметру RemappedElevatedProxiesPolicy, и далее Изменить.
В поле Значение введите 1 и нажмите OK.
Установите или обновите SOLIDWORKS удобным для вас способом.
После завершения установки или обновления SOLIDWORKS, сбросьте значение параметра RemappedElevatedProxiesPolicy установив значение 0 для включения обновления безопасности системы KB 3072630 или запустите файл KB3072630_Enable.reg (см. вложения статьи).
Сценарий 2

Пользователи, которые установили или обновили SOLIDWORKS после применения KB3072630 – в случаях если SOLIDWORKS устанавливался как "индивидуальная" (standalone) установка. Ваша установка SOLIDWORKS вероятнее всего будет нестабильной, и возможно не сможет корректно удалиться. Выполните следующие действия для исправления вашей установки SOLIDWORKS:

Проделайте шаг 1 из Сценария 1.
Запустите исправление установки SOLIDWORKSс помощью инструмента Программы и компоненты в Панели управления Windows. Найдите установку SOLIDWORKS нажмите Изменить, далее выберите Исправить установку в менеджере установки и следуйте инструкциям на экране.
Выполните шаг 3 из Сценария 1.
Сценарий 3

Пользователи, которые установили или обновили SOLIDWORKS после применения KB3072630 – в случаях если SOLIDWORKS установлен из Администрирующего образа. Ваша установка SOLIDWORKS может быть не стабильной. В этом случае необходимо переустановить SOLIDWORKS, выполните следующие действия:

Проведите удаление SOLIDWORKS с помощью инструмента Программы и компоненты в Панели управления Windows. Найдите установку SOLIDWORKS нажмите Удалить.
Проделайте шаг 1 из Сценария 1.
Установите SOLIDWORKS из вашего Администрирующего образа.
Выполните шаг 3 из Сценария 1

 

 

оригинал по ссылке

http://forum.dwg.ru/showthread.php?t=126503

Изменено пользователем pavel-kpll

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@pavel-kpll напугали. Если дело в винде, то переустанавливать придется всё. Я два дня мудохался со всеми этими АвтоКАДами, Компасами и Солидом. :( Пока переустановил Solid Works из другого инсталлятора, поставил не 2016 SP0.1, а 2016 SP5. Завтра попробую поставить SWPlus. Только не знаю какой ставить, 2014 или 2017. Я так понял, что уважаемый Leon не делал SWPlus 2016...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
9 часов назад, KonstruktorRus сказал:

@pavel-kpll напугали. Если дело в винде, то переустанавливать придется всё. Я два дня мудохался со всеми этими АвтоКАДами, Компасами и Солидом. :( Пока переустановил Solid Works из другого инсталлятора, поставил не 2016 SP0.1, а 2016 SP5. Завтра попробую поставить SWPlus. Только не знаю какой ставить, 2014 или 2017. Я так понял, что уважаемый Leon не делал SWPlus 2016...

Коллега, лично у меня версия SWPlus 2013 SP0 на солиде 2016 SP5.0 x 64 работает без нареканий. Система правда win 7 x 64.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@MUXALblCH , уже переустановил Solid, поставил заново SWPlus 2014 - та же беда :( Не могу включить "Настройки" в макросе Master

ОК, зайду с другого конца.

В шапке темы указано:

В 17.06.2005 в 11:31, Leon сказал:

Совет 2. При возникновении ошибки при первом запуске макросов необходимо нажать кнопку Debug, далее зайти в меню Tools-References, убедиться в отсутствии потерянных библиотек (если таковые есть - подключить их), нажать ОК, закрыть окно с кодом макроса и снова запустить его.

У меня при открытии дебагера пункт Tools-References неактивен. Что делать?

Далее:

В 17.06.2005 в 11:31, Leon сказал:

Совет 4. Убедитесь, что папка с макросами доступна SW для записи.

Как в этом убедиться на Windows 10 Corp x64?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, KonstruktorRus сказал:

переустановил Solid, поставил заново SWPlus 2014 - та же беда

это как снять ботинок и заново одеть, надеясь подобным действием избавиться от камушка который не дает вам покоя.

мне просто не понятно. если на вин7 все работало хорошо и стабильно, зачем было переходить на 10 ???

Как разбирали подобную проблему чуть выше, вашего самого первого вопроса, читали?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@pavel-kpll , спасибо! Задал шаблоны по умолчанию - и макросы заработали! MProp не смог обновить шаблоны основных надписей. Я так и не разобрался какие разрешения и для каких папок нужно давать. Думаю, форматы и руками поправлю если не устраню причину.
Еще MProp ругается, что базы материалов нет. Ну, это не так критично. Разберусь попозже. Пока не работает генератор спецификаций. Буду дальше ковыряться.

P.S. Ага, со спецификацией понятно. По умолчанию стоит метод _run.Finish, а нужно, как и в остальных макросах, _run.main ставить.

Изменено пользователем KonstruktorRus
одна проблема решена

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Помогите пожалуйста, на недавно установленном SolidWorks 2018 sp2.0 не устанавливаются макросы, чего только не делал, выдает ошибки  

Окно ошибки.png

Ошибка2.png

Сообщение.png

Изменено пользователем Дмитрий26

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1. Перекачать файлы заново..

2. Попробовать открыть в младшей версии солида и сохранить..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

С массой какая чушь происходит. В свойствах пишет 27 г, в основной надписи 0,02 г.

ScreenClip.png

ScreenClip [1].png

При подготовке чертежа по модели выполненный по старому шаблону в новых макросах в основной надписи чушь. Пробовал чистить свойства в модели вручную не помогает.

 

Работаю в СВ 2018 СП01 + макросы последние из шапки.

 

Есть рецепты?

ScreenClip [2].png

1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В 2018 солиде размерность массы задаётся в ШАБЛОНЕ ЧЕРТЕЖА, а не в ШАБЛОНЕ ДЕТАЛИ, как было ранее.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Доброго времени суток.

Столкнулся с проблемой создания надписи Формата чертежа при создании основных надписей макросом Master. Основные надписи книжной ориентации создаются с меткой формата, а альбомный вариант без надписи формат (SWPlus 2013 SP1 + SW 2017 sp3). Кто нибудь сталкивался с подобным?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем доброго времени суток!!

Возникла ошибка запуска макроса Mprop на SW18sp2 и win10. При запуске вылазить ошибка под номером 91.

Я конечно уверен что решение уже было на этом форуме, но беглый поиск результатов не дал, а на большее просто нету времени)) Можете подсказать как решить проблему?2.thumb.png.3a7d56cc941946c429bf6c4f36f73690.png1.thumb.png.f3f544fd61c8b8dfe92caf852efcfe5f.png

 

 

Изменено пользователем SanyaShurik

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Кто-то ж недавно тоже самое спрашивал..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите пожалуйста. При использовании макроса RecordDimM как можно настроить чтобы в листовой детали при простановке диаметра отверстий, количество этих отверстий считалось автоматически. Когда отверстий немного можно и так посчитать, а вот когда количество отверстий порядка сотни уже можно сбиться. Знаю точно что это возможно, так как приходилось работать раньше с такой настройкой на чужой машине, но там к сожалению узнать уже не могу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 часов назад, SanyaShurik сказал:

И что прям на столько важно правильное количество отверстий посчитать? ну ошибешься штук на пять, и что с того? 

Это всерьез? Инженерный подход((...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 27.04.2018 в 11:16, norets сказал:

При использовании макроса RecordDimM как можно настроить чтобы в листовой детали при простановке диаметра отверстий, количество этих отверстий считалось автоматически

 

Автоматом никак..

 

В 27.04.2018 в 11:16, norets сказал:

Знаю точно что это возможно, так как приходилось работать раньше с такой настройкой на чужой машине,

 

"Нет, сынок, это фантастика" (с) реклама..

 

Если отверстия сделаны соответствующим элементом и размножены массивом, то можно вручную..

 

1. В модели создать эскиз..

2. В эскизе начертить линию и поставить размер..

3. В уравнениях связать длину линии из п. 2 с количеством элементов массива..

4. В чертеже вставить вид за пределами формату и преобразовать линию из п. 2 в эскиз, поставить размер..

5. Создать заметку и сослаться в ней на размер из п. 4..

 

 Это если несколько массивов с одинаковыми отверстиями и надо их сумму..

 

Если массив один, можно создать свойство и сослаться в нем на количество элементов массива..

 

И в п. 5 можно сослаться на свойство.. Тогда доп. вид не нужен..

 

Вот только к макросам это никакого отношения не имеет..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 6223   Опубликовано: (изменено)

В 27.04.2018 в 09:16, norets сказал:

как можно настроить чтобы в листовой детали при простановке диаметра отверстий, количество этих отверстий считалось автоматически.

Использовать не обыкновенный размер, а "Обозначение отверстия". Только там с ЕСКД не очень. За то автоматизация))

-------------------------------------------------------------------------------------------------------------------------------------------------------------

Други! Ситуация: конфигурации (что созданные вручную, что созданные через таблицу параметров) именую, как советует мне хелп SWPlus'а (00, 01 ...). Но сталкиваюсь с тем, что что бы в СП корректно заполнялась графа "Обозначение" для детали с конф-ями мне надо зайти в деталь и ВРУЧНУЮ через MProp для каждой конфигурации (01, 02, ...) нажать галку "Исполнение", ВРУЧНУЮ (ничего не перепутав) ввести номер исполнения (01, 02, ...) ну и продублировать остальные свойства.

Вопрос: нельзя ли как то упростить этот процесс? Что бы при заполнении через MProp свойств основного исполнения (00) эти же свойства назначались и во все остальные исполнения (конфигурации). И для всех кон-ий, кроме "00" устанавливалась галка "Исполнение" и присваивался соответствующий номер исполнения?

Изменено пользователем R2D2_

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Leon@fox1001 выручайте! :sad:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
18 часов назад, R2D2_ сказал:

нельзя ли как то упростить этот процесс?

Далеко не все читают хелп и тем более следуют ему. Я даже у себя на работе сталкиваюсь с таким разнообразием использования конфигураций у разных пользователей, что если попытаться автоматизировать то, что вы хотите, это приведет к большой путанице и крикам. Хотя, безусловно, так им и надо.

Если у вас много конфигураций и вы знаете что такое таблица параметров, то проще заполнить нужные вам свойства через эту таблицу. Макрос потом их подхватит.

2 пользователям понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
15 минут назад, Leon сказал:

то проще заполнить нужные вам свойства через эту таблицу

О! Спасибо за идею. Буду пробовать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 26.04.2018 в 12:22, SanyaShurik сказал:

Можете подсказать как решить проблему?

 

Вот буквально на предыдущей странице аж два раза спросили..

 

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Люди дорогие, помогите пожалуйста!

Пользуюсь Solidworks 2018.

В тот момент когда из сборочного чертежа макросом

SpecEditor из пакета SWPlus_v_2017_SP0.0.zip 

хочу создать спецификацию, при нажатии на

него ничего не происходит. Просто Nothing!!!

Все остальные макросы из данного пакета работают и отзываются.

Расскажите откуда у меня руки растут? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
22 минуты назад, Nikolai Engovatov сказал:

Расскажите откуда у меня руки растут? 

Ну начните с прочтения предыдущей страницы, там и вопрос аналогичный и ответ на него от автора вопроса.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Описание проблемы:  Макрос SpecEditor не реагировал на команду клика. Ничего не проиcходило.

Решение проблемы: При добавлении макроса в выпадающем списке Method выбрать Speceditor_run.main

 

Kelny, спасибо что нашёл данную тему и отправил меня на следующую страницу!

Всё разобрался.

Особая благодарность за решение проблемы пользователю - AntonDu

1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 часа назад, Nikolai Engovatov сказал:

Kelny, спасибо что нашёл данную тему

Ссылку на эту тему в вашей дал я :blush2:.. А вот на предыдущую страницу действительно отправил @Kelny..

 

2 часа назад, Nikolai Engovatov сказал:

Особая благодарность за решение проблемы пользователю - AntonDu

 

Так это в справке к макросам написано..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ребят, спасибо всем!

Спасибо форуму! 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 22.04.2018 в 06:19, ILL сказал:

1. Перекачать файлы заново..

2. Попробовать открыть в младшей версии солида и сохранить..

не помогает. Там где процедура (метод) раньше автоматом прописывало, сейчас нет. Если я вручную прописываю, то показывает вышеуказанные ошибки. Переустановка солида не помогает. Что еще можно сделать, может кто-то сталкивался с таким. Буду переустанавливать Виндовс. Но все равно хотелось бы знать, в чем же проблема, уж слишком много времени я потратил на это

Сообщение.png

Сообщение1.png

Сообщение3.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
34 минуты назад, Дмитрий26 сказал:

не помогает

 

В младшей версии солида

 

1. Инструменты - Макрос - Редактировать..

2. Указать путь к макросу..

3. Изменить что-нибудь, например, добавить в пустой строке пробел и сохранить..

4. Попробовать открыть в текущей версии солида..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ситуация: оформляю сборочный чертеж, генерирую СП (SWPlus.NETовский SpecEditor). Позиции в СП - все ок, пытаюсь ставить на чертеже, а они ничерта не отвечаю тому, что СП. Причем проставляются на каждую деталь подсборки (а не одна позиция, в какую деталь подсборки не ткни).

Вопрос: где я уже натупил?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
25 минут назад, R2D2_ сказал:

(SWPlus.NETовский SpecEditor

 

Это сюда

 

 

27 минут назад, R2D2_ сказал:

они ничерта не отвечаю тому, что СП

 

А других специй нет в файле??

 

28 минут назад, R2D2_ сказал:

Причем проставляются на каждую деталь подсборки

 

Тип специи не тот..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
10 минут назад, ILL сказал:

А других специй нет в файле??

Неа, нету. Когда добавлял еще одну, родную солидовскую, так в ней хоть можно было при клике на выноске позиции менять саму цифру позиции (в меню слева). В SpecEditor'е же такой возможности, увы, нет(( ТАк бы хоть в ручную раскидал...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
6 минут назад, R2D2_ сказал:

Когда добавлял еще одну, родную

 

Возможно, из-за этого косяк..

На каждом виде ПКМ, Свойства, Связать со спецификацией..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 минуты назад, ILL сказал:

Возможно, из-за этого косяк..

Солидовскую специю снес. Даже чертеж заново делал.

За "Связать со спецификацией" - благодарствие тебе, человек. В чертеже СП одна, в свойствах в выпадающем списке - она же (ОДНА!), но когда связываешь "в лоб" начинает работать. Только теперь одна подсборка противится: в какую деталь подсборки не ткни - позиция "*"

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
55 минут назад, R2D2_ сказал:

Солидовскую специю снес. Даже чертеж заново делал.

 

Вообще, вроде, Ctrl+Q должно было помочь..

 

55 минут назад, R2D2_ сказал:

За "Связать со спецификацией" - благодарствие тебе, человек.

 

Да всегда пожалуйста..

 

55 минут назад, R2D2_ сказал:

Только теперь одна подсборка противится: в какую деталь подсборки не ткни - позиция "*"

 

Вот тут с разбегу не подскажу..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
27 минут назад, ILL сказал:

Вот тут с разбегу не подскажу..

Та эта подсборка у меня еще с двумя конфигурациями (для чертежа и для модели). Так что явно что то нахомутал(( Пока что забил - поставил одну позицию этой подсборки вручную.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   1 пользователь

    • viktortut1