Murasch

Ошибка скрипта при попытке сдать на хранение

Здравствуйте, уважаемые пользователи Windchill.

Столкнулся вот с такой проблемой.

3D-модели и чертежи невозможно сдать на хранение в Windchill. При попытке сдачи на хранение появляется диалоговое окно с сообщением об ошибке скрипта (см. скриншот).

Версия Windchill 9.0, ОС Windows 7 x64, Pro/Engineer Wildfire 3.0, версия IE 7.0, ява version 6 update 7. На других аналогичных машинах такой ошибки не возникает, поэтому о причинах несовместимости речи быть не может.

Кстати, выгрузка проходит нормально, без ошибок. А вот сдать на хранение не получается как из-под Pro/E, иак из Windchill непосредственно. В чём может быть дело?

post-29120-1356684832.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Попробуйте из Firefox.

Официально Windchill 9.0 и ОС Windows 7 x64 несовместимы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Попробуйте из Firefox.

Да, попробуйте.

В конфиге ПроЕ установите соответствующую опцию для исподьзуемого веб-браузера (ну и саму Мозилу не забудьте установить).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте, уважаемые пользователи Windchill.

Столкнулся вот с такой проблемой.

3D-модели и чертежи невозможно сдать на хранение в Windchill. При попытке сдачи на хранение появляется диалоговое окно с сообщением об ошибке скрипта (см. скриншот).

Версия Windchill 9.0, ОС Windows 7 x64, Pro/Engineer Wildfire 3.0, версия IE 7.0, ява version 6 update 7. На других аналогичных машинах такой ошибки не возникает, поэтому о причинах несовместимости речи быть не может.

Кстати, выгрузка проходит нормально, без ошибок. А вот сдать на хранение не получается как из-под Pro/E, иак из Windchill непосредственно. В чём может быть дело?

У нас такая проблема возникает на 64 разрядных машинах причем не навсех при загрузке длинного списка рабочей области.

Побороть это не получилось. Но у нас сдается на хранение, просто при открытии большого списка приходиться несколько раз нажимать нет нет

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

мож кому и полезно будет. Проблема с появлением сообщения об ошибке скрипта была и на 32 и на 64 разрядных ХР с использованием IE.

решили так.

Создали reg-файл с содержимым:

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles]

"MaxScriptStatements"=dword:ffffffff

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

"SyncMode5"=dword:00000004

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"Disable Script Debugger"="yes"

Изменено пользователем DEMONOS

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте, уважаемые пользователи Windchill.

У меня такой вопрос. Можно ли сдать на хранение не по одиному  а сразу несколько 5 - 10  CAD деталей.

Как это можно сделать ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте, уважаемые пользователи Windchill.

У меня такой вопрос. Можно ли сдать на хранение не по одиному  а сразу несколько 5 - 10  CAD деталей.

Как это можно сделать ?

В рабочей области выделить все объекты и сдать на хранение.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Можно ли сдать на хранение не по одиному а сразу несколько 5 - 10 CAD деталей. Как это можно сделать ?

А Вас не учили работать с Виндчиллом? Обратитесь к своему руководителю чтобы он организовал для Вас обучение. Хотя бы силами старших товарищей. На это нужно не так много времени.

Кстати, Вы пробовали задавать этот вопрос своим коллегам? Неужели они тоже не знают на него ответ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за ответ. Тут мне понятно.

Тогда вопрос следующий,  я имею на локальном компьютерре папку с десятком документов (файлов )  и я хочу их сразу все сдать на хранение в виндшил в нужную мне папку.  Можно ли так сдать их ?  И как это сделать ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте, уважаемые пользователи Windchill.

Столкнулся вот с такой проблемой.

3D-модели и чертежи невозможно сдать на хранение в Windchill. При попытке сдачи на хранение появляется диалоговое окно с сообщением об ошибке скрипта (см. скриншот).

Версия Windchill 9.0, ОС Windows 7 x64, Pro/Engineer Wildfire 3.0, версия IE 7.0, ява version 6 update 7. На других аналогичных машинах такой ошибки не возникает, поэтому о причинах несовместимости речи быть не может.

Кстати, выгрузка проходит нормально, без ошибок. А вот сдать на хранение не получается как из-под Pro/E, иак из Windchill непосредственно. В чём может быть дело?

А вот при таком сообщение указанные строки в рег-файле помогут?

А то тоже приходится жать "нет" по нескольку раз.

post-26163-0-86311300-1424771435.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Могу также посоветовать забыть про IE, перейти на Firefox. Некоторым нравится Хром, с ним тоже хорошо работает.

"IE - это штатное средство Винды, которое нужно только для того, чтобы после установки Винды скачать нормальный браузер."

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Меня интерисует поможет ли это?

Правда у меня семерка 64.

 

 

мож кому и полезно будет. Проблема с появлением сообщения об ошибке скрипта была и на 32 и на 64 разрядных ХР с использованием IE.
решили так.
Создали reg-файл с содержимым:

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles]
"MaxScriptStatements"=dword:ffffffff

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"SyncMode5"=dword:00000004

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Disable Script Debugger"="yes"

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Меня интерисует поможет ли это?

А самому попробовать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И, о чудо, не выходит больше сообщение.

Просто боялся чо-нибудь повредить в системе, да и прав админа у меня нет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Доброго дня.

Вопросик такой. ПроеWF4 браузер по умолчанию использует ИЕ или в нем используется какой то встроенный?

Посыпались ошибки сценария с разными ошибками у юзера . не помогло   и это

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles]
"MaxScriptStatements"=dword:ffffffff

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"SyncMode5"=dword:00000004

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Disable Script Debugger"="yes"

 

Причем в самом ИЕ проблемы нет , а если из под прое открыть к примеру раб область валится ошибка сценария.

Как такое может быть не понятно.

Есть ли где возможность переключить браузер к примеру на хром?

Файл конфига просмотрел и чего то не нашел в нем ни одного параметра который бы отвечал за смену браузера.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Файл конфига просмотрел и чего то не нашел в нем ни одного параметра который бы отвечал за смену браузера.

виндуз_браузер_тайп

 

В Крео есть, в WF4 не знаю.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

виндуз_браузер_тайп

 

В Крео есть, в WF4 не знаю.

Неа нет такого параметра.Есть только web_browser_home_page.

Похож переустановка прое как вариант остается.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Похож переустановка прое как вариант остается.

И как тебе это поможет? Думаешь, после переустановки сами появятся опции в конфиге?

Ну, попробуй, попробуй...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И как тебе это поможет? Думаешь, после переустановки сами появятся опции в конфиге?

Ну, попробуй, попробуй...

Опций в конфиге не появится. Может какие настройки слетели в прое, что он так косячит. На остальных компах все нормально. На этом одном такие чудеса.

Переустановка возможно сбой устранит.Хотя не факт что глюк исчезнет . Это ведь могут и виндовые чудеса быть.

Юзер сам продвинутый ждем от него новостей. Он сам все переустанавливает уже не дожидаясь меня.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот эта опция отвечает за браузер если что.


WF5

post-26163-0-70067200-1428409989_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот эта опция отвечает за браузер если что.

WF5

я так понял называется она windows_browser_type. В WF4 нет и такой опции.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тогда наверное имеет смысл покопаться в настройках самого браузера IE.


Скорее всего отключено выполнение каких-нибудь скриптов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А если банально сделать Мозилу программой по умолчанию?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пробовали сейчас оперу и хром ставить по умолчанию. Все без изменений. Надо копаться в настройках ИЕ судя по всему

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

может кому пригодится ещё, мы лечим переименованием ключа реестра

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer

правда настройки слетают, но можно написать батник для переименования ключа и восстановления настроек

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу

  • реклама

  • Реклама

  • Ближайшие события

    Предстоящих событий не найдено
  • Дни рождения сегодня

    1. dim3
      dim3
      (42 года)
    2. FuelMasterZ
      FuelMasterZ
      (35 лет)
    3. Sergey___1978
      Sergey___1978
    4. YUS
      YUS
      (41 год)