Freddie_X

Элементы дерева проектирвоания на английском

Добрый вечер! :)

На компе стоит SolidWorks 2012 и почему-то сама программа у меня на английском языке, а разные элементы в дереве конструирования (которые появляются сразу после создания детали - плоскости, начальная точка) на русском языке? А также и все элементы в закладке Анимация. Я уже и регион в Панели управления сменил на English (UK), да и сама винда на английском, но всё равно эти названия на русском языке.

post-35458-1335562055.png

Может кто в курсе, как их на английский переделать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах


Шаблоны смотрели? Какие файлы указаны в качестве шаблонов?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В качестве шаблона используется файл gost-part.prtdot. Дефолтный шаблон. Можно где-нибудь взять англоязычный шаблон? А то простым переименованием не обойтись, не все пункты дерева можно перевести.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А в настройках- использовать английские имена названия файлов?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Freddie_X

Шаблоны по умолчанию указаны в настройках. Установленный SW содержит шаблоны для всех проинсталировнных языков, английские в обязательно порядке.

А в настройках- использовать английские имена названия файлов?

Это только для вновь создаваемых элементов, уже имеющиеся имена не преобразовываются.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А в настройках- использовать английские имена названия файлов?

Там обе галки, связанные с языками, неактивны.

Freddie_X

Шаблоны по умолчанию указаны в настройках. Установленный SW содержит шаблоны для всех проинсталировнных языков, английские в обязательно порядке.

Благодарю! Нашёл шаблон на английском, поставил, теперь всё как надо. Спасибо ещё раз!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Sw2017 sp5 - у нас схожая проблема, но как бы наоборот: солид на русском, галочка эта в настройках выключена, но при создании любого типа файла в солиде английские имена файлов и элементов включаются самопроизвольно. Саппорт с ходу не ответил... Пробовал править в реестре - всё равно возврат на инглиш происходит!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, djrandom сказал:

Sw2017 sp5 - у нас схожая проблема, но как бы наоборот

http://cccp3d.ru/topic/46760-выбор-языка-в-solidworks/#comment-840375

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ID: 9   Опубликовано: (изменено)

23 минуты назад, Kelny сказал:

Спасибо, буду изучать...

И ведь речь идет о ЛИЦЕНЗИОННОМ ПО крупнейшей корпорации... :g:

Изменено пользователем djrandom

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@djrandom может подробно показать и рассказать.

Саппорт сдулся нынче, после октября.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 часа назад, Narwhal сказал:

@djrandom может подробно показать и рассказать.

Саппорт сдулся нынче, после октября.

Так а чего тут рассказывать? У нас лицензионный Solidoworks 2017, установлен из администрирующего образа поверх sw2013.

Софт у нас русскоязычный, в настройках галочка "Использовать английские имена файлов и элементов" выключена. Это если смотреть сразу после загрузки солида. Но стоит создать любой новый файл - деталь, сборку или чертеж, как эта галочка оказывается включеной :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 часа назад, djrandom сказал:

Но стоит создать любой новый файл - деталь, сборку или чертеж, как эта галочка оказывается включеной :(

Может попробовать пересохранить шаблоны (как вариант) - создать->деталь/сборка/чертеж - установить галки в нужных позициях - сохранить как шаблон

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
21 минуту назад, Plumber сказал:

Может попробовать пересохранить шаблоны (как вариант) - создать->деталь/сборка/чертеж - установить галки в нужных позициях - сохранить как шаблон

Пробовали, не помогло

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
13 минуты назад, djrandom сказал:

Пробовали, не помогло

Тогда точно надо долбать саппорт :bash:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создал для тестирования нового пользователя - и вуаля, глюк этот исчез! Мало того, я-то думал что у меня солид грузится быстро (40 сек), так тут он стал загружаться за 7 (!!!)

Но для нас не вариант создавать новых пользователей по всему предприятию :( Будем, значит, с реестром ковыряться :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Баг с английскими именами лечится путем сброса настроек SW - для этого нужно переименовать соответствующую ветку реестра в HKCU.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Но уже могу добавить - что не на всех компьютерах :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Рано я обрадовался - на все компьютеры баг этот "вернулся"... :no:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может ПДМ или сервер лицензий настройки выставляет обратно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

PDM мы даже в администрирующий образ не включали, ибо не пользуемся и не планируем.

А сервер лицензий разве следит за такими настройками? Тем более именно за одной галочкой... В любом случае я не знаю, как это проверить, а тех.поддержка пока ничего действенного не подсказала.

Изменено пользователем djrandom
исправление опечаток

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу